Results 1 to 6 of 6

Thread: ML3 still drives me crazy

  1. #1

    ML3 still drives me crazy

    Just a note, I get on gbpvr kicks in spurts, so I don't always come here to report a problem when I have one. Hence, I'm gonna talk about an issue I've had for a while but never posted about. Very, very sorry about this. I'm horrible, I know.

    Anyway, I've had this same issue every time I've tried to use ML2/ML3, either one. I just recently blew away all the old ML2 and ML3 stuff and did a fresh install of the last ML3 release. It still never finds all my music.

    I keep all of my music on a server the whole house can access. I map a drive letter in my XP GB PVR box to the music directory on the server. In the past, I've tried to just add that drive to the system paths, but it wouldn't find all the music files. There are several directories on my server under music, like 'kids' and 'christmas' and 'mystuff' and 'mywifes', etc. This time I added each of those directories as a separate system path, nuked the db and then did a scan. Once again, it still only found a really random sampling of the music I showed it under the system paths.

    I know its not tag related, because very recently (this summer) we redid every single tag to get everything right for a load onto an mp3 player for a long road trip we took. Let me tell you, that was a chore ;- )

    Anyway, any ideas? Its really, really random what shows up in the lists. I'd get two country artists, and a couple of my stuff, and a bunch of the stuff from my wife's directory, and a christmas album here and there, and then some of the albums are incomplete, etc.
    My PVR setup:
    AMD A8-5500
    8GB Ram
    Windows 10

  2. #2
    Well, a slight correction to the 'redid every tag' item. We made sure all the artist, song title, and genre were right, but we didn't fill in album info everywhere. However, I know its missing quite a few that have every single detail correct, like my Beatles albums.
    My PVR setup:
    AMD A8-5500
    8GB Ram
    Windows 10

  3. #3
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,312
    Check the share attributes of the some of the files you know are missing. It is very easy with Windows to move a file into a shared folder and these files won't have the proper share permission. Maybe try unsharing and resharing the folder. After that, if you have a specific file that doesn't work, give me sample (PM me and I will give your email). It might be something simple (ie a Beatles file might be mono and possibly mono files aren't supported)

    Martin

  4. #4
    Quote Originally Posted by mvallevand View Post
    Check the share attributes of the some of the files you know are missing. It is very easy with Windows to move a file into a shared folder and these files won't have the proper share permission. Maybe try unsharing and resharing the folder. After that, if you have a specific file that doesn't work, give me sample (PM me and I will give your email). It might be something simple (ie a Beatles file might be mono and possibly mono files aren't supported)

    Martin
    The server is a linux machine, and shares out every other file type just fine, and even the music in the basic music library. Everything is attrib'ed the same, so the files ML3 is listing are set the same way as the missing ones. I have noticed that it looks like its grabbing the first few files from each directory and then moving on, as I get files starting with As, Bs, and some Cs from one particular folder, but no further letters.
    My PVR setup:
    AMD A8-5500
    8GB Ram
    Windows 10

  5. #5
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,312
    I didn't see a PM but if you want a solution, you will need to participate. From the command prompt go to the root of a folder, create a list of all the files

    dir /s /b > files.txt

    and then compress files.txt and attach the compressed file. Then compress musiclibrary.db3 and since it likely is too big to attach PM me and I will give you my email address.

    Martin

  6. #6
    Sorry about the delay, I've been at a conference for the last few days. I'll get this listing to you tomorrow.
    My PVR setup:
    AMD A8-5500
    8GB Ram
    Windows 10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •