Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 37

Thread: Windows Desktop Gadget support thread

  1. #21
    Join Date
    Nov 2011
    Location
    UK
    Posts
    66
    I upgraded to v3.6.2 which uses NET 4 and the gadget no longer works,
    I run Win8 with sidebar7 and find the gadget useful to see whats recording and about to record at a glance.
    Am I doing something wrong (need to reinstall?) or does the gadget need an upgrade for NET 4?

  2. #22
    Join Date
    Nov 2011
    Location
    UK
    Posts
    66
    Sorry the Thread above should read;
    "I upgraded to v3.1.1 which uses NET4 and the gadget no longer works
    I run Win8 with sidebar7 and find the gadget useful to see whats recording and about to record at a glance.
    Am I doing something wrong (need to reinstall?) or does the gadget need an upgrade for NET 4? "
    I typed it hurriedly from memory and got it wrong!!!!!!!

  3. #23
    Join Date
    Feb 2005
    Location
    Pennsylvania, USA
    Posts
    5,517
    Quote Originally Posted by Bobbybear View Post
    Sorry the Thread above should read;
    "I upgraded to v3.1.1 which uses NET4 and the gadget no longer works
    I run Win8 with sidebar7 and find the gadget useful to see whats recording and about to record at a glance.
    Am I doing something wrong (need to reinstall?) or does the gadml.aspxget need an upgrade for NET 4? "
    I typed it hurriedly from memory and got it wrong!!!!!!!
    I am running sidebar on W8 with the gadget and not having any issues.

    Does this url return anything for you:

    http://your-server:your-port/public/...s/infoxml.aspx

    your-server:your-port/public/services/infoxml.aspx

  4. #24
    Join Date
    Jun 2007
    Location
    St. Paul, MN, USA
    Posts
    1,029

    Verbose web.log file due to Desktop Gadget

    I really like the desktop gadget on my laptop. However, it appears that every 5 minutes, my web.log file gets entries like these:
    Code:
    2014-11-09 14:44:08.081	[DEBUG][16]	Got Web Request (10.54.26.125): /public/services/InfoXML.aspx    gadget=true
    2014-11-09 14:44:11.270	[DEBUG][4]	Got Web Request (192.168.143.10): /public/services/manageservice.asmx    
    2014-11-09 14:44:11.736	[DEBUG][9]	Got Web Request (10.54.26.125): /public/services/InfoXML.aspx    
    2014-11-09 14:44:11.738	[INFO][9]	Using wmi for free space determination.....
    2014-11-09 14:44:11.738	[DEBUG][9]	Root: E:
    2014-11-09 14:44:11.738	[DEBUG][9]	Scope: \\.
    2014-11-09 14:44:11.738	[DEBUG][9]	Mgmt Obj Scope: \\.\root\cimv2
    2014-11-09 14:44:11.738	[DEBUG][9]	Mgmt Obj Path Win32_LogicalDisk.DeviceID="E:"
    2014-11-09 14:44:11.770	[INFO][9]	Processing 58 File System Objects
    2014-11-09 14:44:11.771	[INFO][9]	Processing 4 File System Objects
    2014-11-09 14:44:11.771	[DEBUG][9]	   +++ Processing File: E:\NPVR Recordings2\2 Broke Girls\2 Broke Girls.S04E02.And the DJ Face.edl
    2014-11-09 14:44:11.771	[DEBUG][9]	   +++ Processing File: E:\NPVR Recordings2\2 Broke Girls\2 Broke Girls.S04E02.And the DJ Face.log
    2014-11-09 14:44:11.771	[DEBUG][9]	   +++ Processing File: E:\NPVR Recordings2\2 Broke Girls\2 Broke Girls.S04E02.And the DJ Face.ts
    2014-11-09 14:44:11.771	[DEBUG][9]	   +++ Processing File: E:\NPVR Recordings2\2 Broke Girls\2 Broke Girls.S04E02.And the DJ Face.txt
    2014-11-09 14:44:11.771	[DEBUG][9]	>>> Processing Folder: E:\NPVR Recordings2\2 Broke Girls
    2014-11-09 14:44:11.771	[INFO][9]	Processing 4 File System Objects
    2014-11-09 14:44:11.771	[DEBUG][9]	   +++ Processing File: E:\NPVR Recordings2\A to Z\A to Z.S01E06.F Is for Fight, Fight, Fight!.edl
    2014-11-09 14:44:11.771	[DEBUG][9]	   +++ Processing File: E:\NPVR Recordings2\A to Z\A to Z.S01E06.F Is for Fight, Fight, Fight!.log
    2014-11-09 14:44:11.771	[DEBUG][9]	   +++ Processing File: E:\NPVR Recordings2\A to Z\A to Z.S01E06.F Is for Fight, Fight, Fight!.ts
    2014-11-09 14:44:11.772	[DEBUG][9]	   +++ Processing File: E:\NPVR Recordings2\A to Z\A to Z.S01E06.F Is for Fight, Fight, Fight!.txt
    2014-11-09 14:44:11.772	[DEBUG][9]	>>> Processing Folder: E:\NPVR Recordings2\A to Z
    2014-11-09 14:44:11.772	[INFO][9]	Processing 4 File System Objects
    2014-11-09 14:44:11.772	[DEBUG][9]	   +++ Processing File: E:\NPVR Recordings2\About a Boy\About a Boy.S02E04.About a Bad Girl.edl
    2014-11-09 14:44:11.772	[DEBUG][9]	   +++ Processing File: E:\NPVR Recordings2\About a Boy\About a Boy.S02E04.About a Bad Girl.log
    2014-11-09 14:44:11.772	[DEBUG][9]	   +++ Processing File: E:\NPVR Recordings2\About a Boy\About a Boy.S02E04.About a Bad Girl.ts
    2014-11-09 14:44:11.772	[DEBUG][9]	   +++ Processing File: E:\NPVR Recordings2\About a Boy\About a Boy.S02E04.About a Bad Girl.txt
    2014-11-09 14:44:11.772	[DEBUG][9]	>>> Processing Folder: E:\NPVR Recordings2\About a Boy
    2014-11-09 14:44:11.776	[INFO][9]	Processing 29 File System Objects
    .
    .
    .
    They keep going for about 5 seconds and quickly fill up and rollover the log file. Is there a way to turn down the logging level for this operation?

    Additionally, it seems like at least sometimes when this happens while I'm playing a recording on the NMT, the playback will freeze for a brief time. Could this 5 second gadget processing be affecting the NMT playback?

  5. #25
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,376
    Quote Originally Posted by BrettB View Post
    I really like the desktop gadget on my laptop. However, it appears that every 5 minutes, my web.log file gets entries like these:
    I asked for an option to turn it off because of the logging and the fact it has to wake my shares, but UJB didn't want to do that so I just edit web\public\service\InfoXML.aspx.cs

    Code:
    		private long GetDirectorySize(string pathName)
    		{
    			long totalsize = 0;
                            return totalsize;
    You do lose the the files size for the recording folder and how much of the drive is in for that folder.

    Martin

  6. #26
    Join Date
    Jun 2007
    Location
    St. Paul, MN, USA
    Posts
    1,029
    Quote Originally Posted by mvallevand View Post
    You do lose the the files size for the recording folder and how much of the drive is in for that folder.
    Where is that information displayed? The only thing that I see in the gadget is the "Free Disk Space" (in my case "xx GB / yy TB") on the default recording device. And that still seems to be displayed after I made your modification.

  7. #27
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,376
    The only place I know of is in http://ip:8866/public/services/InfoXML.aspx

    Martin

  8. #28
    Join Date
    Jul 2011
    Location
    VA US
    Posts
    185
    So it must be my week for weird stuff. I noticed the note about manual recordings stopping the display on the fly out, but mine is a bit different. I do get data, but its truncated for the day with the manual recording and the days are out of order a bit. Notice the 23rd which only shows 2 recordings, then it lists 31st with a blank (which is the manual recording) then goes back to list the rest of the 23rd as a new day. NEWA picks them up right on the pending recordings list, it's just the gadget fly-out. Is this still a "feature" or have I managed to break it? I'm running v1.1 of the gadget which I think is the most recent.

    Snag
    Attached Images Attached Images   
    NPVR 3.7.7/Win7ProX64/Intel Core i7-4790 Haswell Quad-Core 3.6GHz /HDHRPrime X2/Schedules Direct

  9. #29
    Join Date
    Dec 2004
    Location
    Cambridge, ON. Canada
    Posts
    630
    Have a connection issue, this started when i "reloaded" the gadget (at work), below details:

    NPVR : 3.6.6
    Gadget v1.1
    Condition : WOrks on the local LAN, doesn't work outside, however can get to the server on port 8866 on the "non working" PC.

    Says no connection (either using DNS or IP address), however on the "affected" remote PC i can get to http://DNS:8866

    Only thing is locally i dont need to login, the remote one i do, did something change with the gadget and allow access remotely with regards login?

    Ive tried turning the firewall off on the WIndows PC (WINdows 7 Pro), that didnt fix it (its normally a firewall issue like this), so i am at a loss, esp as the http://dns:8866 works from the PC that the Gadget doesnt work on. Any ideas?
    Last edited by SFX Group; 2016-02-22 at 04:27 AM.
    Many Thanks
    Ashley

    Copyright 2015 - www.ashleygriffin.ca

  10. #30
    Join Date
    Feb 2005
    Location
    Pennsylvania, USA
    Posts
    5,517
    Quote Originally Posted by SFX Group View Post
    Have a connection issue, this started when i "reloaded" the gadget (at work), below details:

    NPVR : 3.6.6
    Gadget v1.1
    Condition : WOrks on the local LAN, doesn't work outside, however can get to the server on port 8866 on the "non working" PC.

    Says no connection (either using DNS or IP address), however on the "effected" remote PC i can get to http://DNS:8866

    Only thing is locally i dont need to login, the remote one i do, did something change with the gadget and allow access remotely with regards login?

    Ive tried turning the firewall off on the WIndows PC (WINdows 7 Pro), that didnt fix it (its normally a firewall issue like this), so i am at a loss, esp as the http://dns:8866 works from the PC that the Gadget doesnt work on. Any ideas?
    Have you tried externally on a pc other than a work asset or work network... many companies (including mine) now block outgoing connections to non-standard ports which will prevent you from getting to NEWA from your work machine.

    If you can get to NEWA web interface from the work machine than the client should be able to get to it. The client calls a service that is not protected so no login is needed.

    Let me know.
    Last edited by UncleJohnsBand; 2016-02-19 at 02:27 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •