Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Incomplete guide data

  1. #1
    Join Date
    May 2006
    Location
    Brighton, UK
    Posts
    1,199

    Incomplete guide data

    Hi, ndroid has started working again after a prolonged period of downtime (NFI what was going on, probably my custom ROM, or maybe a recent update by yourself,so don't worry about that aspect...) However an even older problem is occurring in that I'm getting incomplete guide data. Only some channels and only / often a block of hours in the middle of the day missing.
    All the data is present in NPVR but re-downloading the EPG to the phone doesn't fix the issue.
    What logs do you need next time I catch it, and where does the local DB live on the phone so I can post a copy if required?
    This is original ndroid btw, not TE.
    Server: Win7 N | AMD Phenom II X4 3.2GHz | 4Gig RAM | Gigabyte GA-MA770-DS3 Mobo | 5TB+ HDDs | 2x BlackGold Twin HD DVB-T| ATI HD 5450 | Cambridge Audio DAC Magic
    Client 1: OpenElec / XBMC | Dell GX280 P4 3.4GHz |2Gig RAM | ATI HD 5450 | SPDIF pass through
    Client 2: OpenElec / XBMC | Dell GX280 P4 3.4GHz |2Gig RAM | ATI HD 5450 | C-MEDIA USB DAC
    Android: Samsung Galaxy S2 GT-I9100 4.4.2 Cyanogenmod 11

  2. #2
    Join Date
    Dec 2004
    Location
    West Yorkshire, UK
    Posts
    4,541
    Quote Originally Posted by fuzzweed View Post
    Hi, ndroid has started working again after a prolonged period of downtime (NFI what was going on, probably my custom ROM, or maybe a recent update by yourself,so don't worry about that aspect...)
    The original nDroid hasn't had any updates for a long time now (well over a year) so you can rule that out.

    All the data is present in NPVR but re-downloading the EPG to the phone doesn't fix the issue.
    What logs do you need next time I catch it, and where does the local DB live on the phone so I can post a copy if required?
    Unless your phone is rooted, you won't be able to find the ndroid database as it lives in the app's private internal memory. If the phone is rrooted, however, try something like...

    Code:
    /data/data/uk.co.beetec.nDroid/databases
    ...it's difficult to say though as different Android versions are allowed to arrange their own filesystem structure and apps simply use "helper" code to find files without having to know the absolute paths to them.

    As for logs - all the nDroid Service logs from your PC. I'd also be interested in seeing the ZIP files containing the EPG data. Feel free to send them through to my beetecservices gmail address.

    Cheers,
    Brian

  3. #3
    Join Date
    May 2006
    Location
    Brighton, UK
    Posts
    1,199
    I'll pm you a link with NPVR db, android db and ndroid logs. It's been chugging away unattended for a while so I can't say when the problem re-occured with any accuracy. BBC SD for Friday 9th (for example) starts at 9.15am (although I would think it should have the news listed before then from 6) but if you look at BBC HD for the same day it seems to start at 12.15pm with nothing listed earlier than that. Saturday seems full on both of them. Friday ITV2 only has three entries. Sunday BBC1 SD starts at 9 again, but BBC1 HD looks OK for the same day. etc...
    Server: Win7 N | AMD Phenom II X4 3.2GHz | 4Gig RAM | Gigabyte GA-MA770-DS3 Mobo | 5TB+ HDDs | 2x BlackGold Twin HD DVB-T| ATI HD 5450 | Cambridge Audio DAC Magic
    Client 1: OpenElec / XBMC | Dell GX280 P4 3.4GHz |2Gig RAM | ATI HD 5450 | SPDIF pass through
    Client 2: OpenElec / XBMC | Dell GX280 P4 3.4GHz |2Gig RAM | ATI HD 5450 | C-MEDIA USB DAC
    Android: Samsung Galaxy S2 GT-I9100 4.4.2 Cyanogenmod 11

  4. #4
    Join Date
    Dec 2004
    Location
    West Yorkshire, UK
    Posts
    4,541
    OK, zip downloaded - I'll take a look.

    Cheers,
    Brian

  5. #5
    Join Date
    Dec 2004
    Location
    West Yorkshire, UK
    Posts
    4,541
    Just to let you know I'm still looking at this. I can see from the nDroid service logs a couple of times when there's a file 'lock' preventing creation of EPG files but that would knock out a whole day for all channels - if you're seeing partial data for one channel but all data for another on the same day that doesn't tie up. I'll keep digging.

  6. #6
    Join Date
    May 2006
    Location
    Brighton, UK
    Posts
    1,199
    The other oddity is that a delete and refresh data reloads ( I think, although I haven't checked it ever line by line) the same 'corrupt' EPG data. I would presume a file lock was a thing that came and went, so if it couldn't access the db on a first run, it ought to pick up the missing data at a later date.
    Just a thought; Could it be related to failed updates? This will often happen if I'm out and about and it tries to update over the mobile network, as I haven't set up a mobile access address, (or have a port open at home).
    However a very quick scan of the guide after the phone has been sat at home on the wifi for a few days seems to show me with full guide data again.
    Server: Win7 N | AMD Phenom II X4 3.2GHz | 4Gig RAM | Gigabyte GA-MA770-DS3 Mobo | 5TB+ HDDs | 2x BlackGold Twin HD DVB-T| ATI HD 5450 | Cambridge Audio DAC Magic
    Client 1: OpenElec / XBMC | Dell GX280 P4 3.4GHz |2Gig RAM | ATI HD 5450 | SPDIF pass through
    Client 2: OpenElec / XBMC | Dell GX280 P4 3.4GHz |2Gig RAM | ATI HD 5450 | C-MEDIA USB DAC
    Android: Samsung Galaxy S2 GT-I9100 4.4.2 Cyanogenmod 11

  7. #7
    Join Date
    May 2015
    Location
    United Kingdom
    Posts
    5
    Did you ever get to the bottom of this as I am having the same issue. If there is still no solution can I send any additional log data etc to help?

    Cheers

    Sam

  8. #8
    Join Date
    May 2006
    Location
    Brighton, UK
    Posts
    1,199
    Not personally. In fact I've just loaded it up for the first time in a while, done a EPG reload from scratch and it's got missing data, so it's still a present issue (NPVR has been updated to most recent version since the original post). Bump from me.
    Last edited by fuzzweed; 2015-05-23 at 08:56 AM.
    Server: Win7 N | AMD Phenom II X4 3.2GHz | 4Gig RAM | Gigabyte GA-MA770-DS3 Mobo | 5TB+ HDDs | 2x BlackGold Twin HD DVB-T| ATI HD 5450 | Cambridge Audio DAC Magic
    Client 1: OpenElec / XBMC | Dell GX280 P4 3.4GHz |2Gig RAM | ATI HD 5450 | SPDIF pass through
    Client 2: OpenElec / XBMC | Dell GX280 P4 3.4GHz |2Gig RAM | ATI HD 5450 | C-MEDIA USB DAC
    Android: Samsung Galaxy S2 GT-I9100 4.4.2 Cyanogenmod 11

  9. #9
    Join Date
    May 2015
    Location
    United Kingdom
    Posts
    5
    I guess we just need to hope that bgowland is still looking at the problem. If he isn't and the source code is available I would be happy to assist with maintenance etc.

    Cheers

    Sam

  10. #10
    Join Date
    Dec 2004
    Location
    West Yorkshire, UK
    Posts
    4,541
    Quote Originally Posted by xssammy View Post
    Did you ever get to the bottom of this as I am having the same issue. If there is still no solution can I send any additional log data etc to help?

    Cheers

    Sam
    Quote Originally Posted by fuzzweed View Post
    Not personally. In fact I've just loaded it up for the first time in a while, done a EPG reload from scratch and it's got missing data, so it's still a present issue (NPVR has been updated to most recent version since the original post). Bump from me.
    I never did get to the bottom of this. Can you both zip * attach your nDroidService logs and I'll take another look.

    Cheers,
    Brian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •