Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Streams not working in Kodi

  1. #1
    Join Date
    Mar 2014
    Location
    Calgary
    Posts
    13

    Streams not working in Kodi

    Hi guys,

    I installed NextPVR next to Cast4ME but having same issue on both.

    I use the IPTV PVR addon from Kodi to watch streams (Because I have other http streams), so my playlist looks like this:
    Code:
    #EXTINF:-1, tv-id="992" tvg-id="I209.71729.schedulesdirect.org" tvg-logo="CBC.png" group-title="USA" tvg-name="CBC",CBC
    http://server:8867/live?channel=9.1
    
    #EXTINF:-1, tv-id="992" tvg-id="I211.63639.schedulesdirect.org" tvg-logo="Global.png" group-title="USA" tvg-name="Global",Global
    http://server:8867/live?channel=2.1
    
    #EXTINF:-1, tv-id="992" tvg-id="I210.62890.schedulesdirect.org" tvg-logo="CTV.png" group-title="USA" tvg-name="CTV",CTV
    http://server:8867/live?channel=4.1
    
    #EXTINF:-1, tv-id="992" tvg-id="I213.69551.schedulesdirect.org" tvg-logo="City.png" group-title="USA" tvg-name="City",City
    http://server:8867/live?channel=5.1
    
    #EXTINF:-1, tv-id="992" tvg-id="I215.72839.schedulesdirect.org" tvg-logo="YesTV.png" group-title="USA" tvg-name="YesTV",YesTV
    http://server:8867/live?channel=32.1
    
    #EXTINF:-1, tv-id="992" tvg-id="I214.72804.schedulesdirect.org" tvg-logo="Omni.png" group-title="USA" tvg-name="Omni",Omni
    http://server:8867/live?channel=38.1
    When I open this playlist with VLC (on Android) the streams are all fine, but when I open it with Kodi nothing happends, sometimes it tries to buffer for a few seconds, but then nothing.

    I attached the logs from Kodi, but nothing really stands out to me.

    Thanks!
    Attached Files Attached Files

  2. #2
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    83,529
    I don't know anything about Kodi's IPTV PVR addon.

    If you want to use Kodi to view NextPVR channels, you're supposed to use Kodi's NextPVR addon, or XNEWA addon. The authors of these addons are here and we can provide support for them (usually).

  3. #3
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,331
    That isn't IPTV that is a playlist of URLs that use NextPVR's web stream. Not sure why you use port 8867 instead of the default, but if it works in VLC I suspect Kodi is having trouble resolving server.

    Martin

  4. #4
    Join Date
    Mar 2014
    Location
    Calgary
    Posts
    13
    Quote Originally Posted by mvallevand View Post
    That isn't IPTV that is a playlist of URLs that use NextPVR's web stream. Not sure why you use port 8867 instead of the default, but if it works in VLC I suspect Kodi is having trouble resolving server.

    Martin
    8867 is Cast4me. But it's the same with NextPVR.

    I don't use the PVR because you can't run 2 PVR's reliable at the same time, too much messing around.

    This setup worked for about 2 years, but for some reason about 2 months ago it stopped working. I do suspect something with Kodi it doesn't like but I haven't come across any other stream that does the same.

  5. #5
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,331
    To me it seems odd to use cast4me and NextPVR together but I'd start by triaging NextPVR and seeing if the local web server is working from your browser on the host PC at http://localhost:8866

    Martin

  6. #6
    Join Date
    Mar 2014
    Location
    Calgary
    Posts
    13
    Yes the web service works too, everything about cast4me and NextPVR works fine. I installed NextPVR just to test it out if it was a Cast4Me issue. I tried the NextPVR addon on Kodi and that works too, it's just the http streams that are broken somehow.

  7. #7
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    83,529
    I tried to have a go investigating this, but I can't work out how get the IPTV PVR addon working. I've had a go at creating a M3U file with some NextPVR/Cast4ME streams, and pointing the addon at it, but I can seem to get it to list the channels, so haven't been able to attempt watching a stream.

  8. #8
    Join Date
    Mar 2014
    Location
    Calgary
    Posts
    13
    That's odd, did you use the same kind of m3u I posted in the topic start? I use that one (plus some extra stuff).

    Yeah you need to enable the Simple IPTV addon (like you would the NextPVR addon), then in the settings of it you just give the M3U path, and enable TV like you would normal.

    I find that Kodi's implementation with the TV addon's does not work reliably at all when enabling more than 1 PVR addon at the same time.

  9. #9
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    83,529
    Yeah, at the moment I'm using that exact file you posted above. I haven't modified it the URLs at yet.

    I've got it configured to use a local path, and selected the m3u file, enabled the addon, and restarted kodi, but no sign of TV menu.

    I've only got that addon enabled. pvr.nextpvr is not enabled.

  10. #10
    Join Date
    Mar 2014
    Location
    Calgary
    Posts
    13
    You sure that TV is enabled in the TV menu? Otherwise I don't know either.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •