Results 1 to 3 of 3

Thread: Refresh Rate Problem

  1. #1
    Join Date
    Jan 2011
    Location
    North Gloucestershire, England
    Posts
    711

    Refresh Rate Problem

    On my main TV although my RPi2 runs 1080p at 50Hz OK both my AMD E450 and Intel Celeron powered nettop PCs will only run at 24Hz or 30Hz. It seems to be some incompatibility between this particular TV and LibreElec/KODI as both PCs when connected to other TVs run at up to 50Hz & 60Hz at 1080p.

    As a work around I am using the KODI Player setting “Adjust Display Refresh Rate” which seems OK. Will it be best to run at 24Hz or 30Hz for best results or wont it matter? The other option is to playback at 720p which offers 50 Hz playback.

    Chris
    NextPVR Server - HP N54L Microserver, Windows 7 - Storage 2 X 3TB in Windows mirror- Tuners DVBSky S952 Twin DVB-S/S2 PCIe, August T210 DVB-T/T2 USB, KWorkd UB499-2T Twin DVB-T USB.
    Clients RPi2 & Acer RL80 Celeron Nettop both running X-NEWA on LibreElec.

  2. #2
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,017
    Did you try different HDMI ports on your TV? Often they use different chipsets with different functionality. Note the GUI resolution and video resolution may be different too.

    For playing your 25/50 PAL videos you probably will be the best critic.

    Martin

  3. #3
    Join Date
    Jan 2011
    Location
    North Gloucestershire, England
    Posts
    711
    The problem seems to be with the Linux driver not correctly detecting what refresh rate that particular Sharp TV can do as I ran Ubuntu on a live USB drive on the same setup and that also only offered 24Hz and 30Hz refresh.

    Running with “Adjust Display Refresh Rate” set seems a good work around as I cannot detect any objectionable flicker on SD or HD recordings. I dont know if its running at 25Hz or 50Hz at unlike my Samsung TV the Sharp does not report changes in the video signal.

    The RPi2 has played all SD and HD without a problem for about a year but at some point possibly when I installed LibreElec 8 Alpha/Beta to run Kodi 17 "Skip" became irritating as it would miss about 1 in 4 skips.

    Chris
    NextPVR Server - HP N54L Microserver, Windows 7 - Storage 2 X 3TB in Windows mirror- Tuners DVBSky S952 Twin DVB-S/S2 PCIe, August T210 DVB-T/T2 USB, KWorkd UB499-2T Twin DVB-T USB.
    Clients RPi2 & Acer RL80 Celeron Nettop both running X-NEWA on LibreElec.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •