PDA

View Full Version : Loading mvpmc



mvallevand
2007-02-11, 03:15 AM
The following are the steps to install and load mvpmc

1. Check this thread for the recommended dongle

http://forums.nextpvr.com/showthread.php?t=25206

2. Save the file to your GB-PVR folder typically to C:\Program Files\devnx\gbpvr\Dongle
3. Rename the file that you downloaded to mvpmc.bin
4. From the GB-PVR Config program go to the MVP tab and select mvpmc.bin and apply.
5. Reset the power on your MediaMVP.
6. When mvpmc starts, select Emulation Mode from the main menu.

To get back to the mvpmc main menu from emulation mode the key combination is to hit the Go and then then Back key.

For any parts of GB-PVR that need the Go key, you must hit the Go twice.

To revert back to the Hauppauge dongle.
1. From the GB-PVR Config program go to the MVP tab and select dongle.bin and apply.
2. Return to the mvpmc main menu
3. Select the Reboot menu option

Advanced Configuration (Optional)

mvpmc is very configurable but for the most part GB-PVR users don't need to do any special configuration. f you want to create a startup file check out Step 2 on http://mvpmc.wikispaces.com/Loadconfig

For example if you always want to run GB-PVR you can have mvpmc power on into Emulation Mode with the following command line option saved in dongle.bin.config

mvpmc --startup emulate --emulate ? &

(or specify the GB-PVR server if you'd prefer this will work best)

mvpmc --startup emulate --emulate 192.168.1.1 &

Martin

bluesxman
2007-02-20, 12:16 PM
Advanced Configuration (Optional)

mvpmc is very configurable but for the most part GB-PVR users don't need to do any special configuration. f you want to create a startup file check out Step 2 on http://mvpmc.wikispaces.com/Loadconfig


Hi Martin,
I've attempted to use a config file, to access some network shares and to boot straight into emulation mode, but it doesn't seem to be picking it up. Are there any logs that I can look at to help troubleshoot the problem? I suspect it's an issue accessing the share containing the config file. Ages ago I set a password on the Guest account, I've since reset it but does MVPMC try to connect with a password? Thanks for any help with this.

mvallevand
2007-02-20, 01:02 PM
Hi Martin,
I've attempted to use a config file, to access some network shares and to boot straight into emulation mode, but it doesn't seem to be picking it up. Are there any logs that I can look at to help troubleshoot the problem? I suspect it's an issue accessing the share containing the config file. Ages ago I set a password on the Guest account, I've since reset it but does MVPMC try to connect with a password? Thanks for any help with this.
Typically the logs would be on your windows machine since it would be rejecting the login

If you can telnet to you mvp there are a couple of things try. I'm going to add this to the web interface but it is not there yet.

1. telnet to your mvp
2. enter root as user id when prompted.

This should get to your command line from there enter the following. If you have a model H machine this is probably not an issue.

cat /etc/tftp.config

You will see the IP of your gbpvr server. If it is not, you haven't loaded a new dongle with the Hauppauge software of your gbpvr machine. gbpvr doesn't ever set the flash on older machines.

If it is your IP try a manual login as follow. mvpmc currently does not use a password.

mount.cifs //yourip/mvpmc /etc/mvpmc -o username=guest,ro

If this fails record the error and let me know.

If this works enter the following

ls -lt /etc/dongle.config


If it exists your dongle.config is wrong. Please let me know the contents.

Martin

tkgafs
2007-02-20, 10:28 PM
I could only get the system to auto start using the dongle.bin.config file once I had changed the permissions on the share to allow network users to change my files.

once I did that it picked the file straight away

my file contains the following

mvpmc -o svideo --startup emulate --emulate 192.168.0.1

now for some playing to see how well it works

tkgafs

mvallevand
2007-02-20, 11:17 PM
I could only get the system to auto start using the dongle.bin.config file once I had changed the permissions on the share to allow network users to change my files.

once I did that it picked the file straight away

my file contains the following

mvpmc -o svideo --startup emulate --emulate 192.168.0.1

now for some playing to see how well it works

tkgafs


Sorry my telnet example was wrong (I will add the ,ro) , but I definitely have mvpmc connect read0only to grab dongle.bin.config and that is how my c:\mvpmc is configured.

Martin

bluesxman
2007-02-21, 09:34 AM
Thanks for all the pointers. After telneting into the MVP, I did have problems mounting the mvpmc share - turned out I needed to update the local permissions on the folder too. Unfortunately, I'm still unable to get the config file to load, but I'll keep plugging away at it!

One thing that's puzzling me is this. You say that I need to load a recent hauppauge dongle to store the server address in the flash (I don't have a new H rev mvp btw). I have done this, but then after booting the mvpmc dongle I don't have the /etc/dongle/tftp.config file present. Does the flash memory remain intact following a power cycle? I'm assuming I need to power-cycle to get the mvpmc dongle to load, or am I missing something?

Thanks again for the help, as well as for the work you & the mvpmc project have put in to all this!

mvallevand
2007-02-21, 12:45 PM
One thing that's puzzling me is this. You say that I need to load a recent hauppauge dongle to store the server address in the flash (I don't have a new H rev mvp btw). I have done this, but then after booting the mvpmc dongle I don't have the /etc/dongle/tftp.config file present. Does the flash memory remain intact following a power cycle? I'm assuming I need to power-cycle to get the mvpmc dongle to load, or am I missing something?

Another yet another typo sorry, the file would be /etc/tftp.config

And yes to load the mvpmc dongle the power-cycle boot is the same as with the Hauppauge dongle. The only difference is that mvpmc rarely crashes, it will be typically be the emulation mode thread, so for the most part you will be restarting mvpmc instead of reloading it over the network.

Martin

ggee
2007-07-13, 04:10 AM
This is a good starter topic. Can we make it sticky?

Thanks,
Greg

mvallevand
2007-07-13, 04:14 AM
Sure my recommendation has changed since this one though!

Martin

ggee
2007-07-13, 04:19 AM
If so, please update please. This help to show that it is simple to setup.

Thanks,
Greg

mvallevand
2007-07-13, 04:26 AM
If so, please update please. This help to show that it is simple to setup.

Thanks,
Greg

I did already.

Martin

ram4x4nut
2007-07-16, 07:35 AM
Edited

petewxm
2008-02-29, 06:10 PM
Typically the logs would be on your windows machine since it would be rejecting the login

If you can telnet to you mvp there are a couple of things try. I'm going to add this to the web interface but it is not there yet.

1. telnet to your mvp
2. enter root as user id when prompted.

This should get to your command line from there enter the following. If you have a model H machine this is probably not an issue.

cat /etc/tftp.config

You will see the IP of your gbpvr server. If it is not, you haven't loaded a new dongle with the Hauppauge software of your gbpvr machine. gbpvr doesn't ever set the flash on older machines.

If it is your IP try a manual login as follow. mvpmc currently does not use a password.

mount.cifs //yourip/mvpmc /etc/mvpmc -o username=guest,ro

If this fails record the error and let me know.

If this works enter the following

ls -lt /etc/dongle.config


If it exists your dongle.config is wrong. Please let me know the contents.

Martin


Hi Martin,

I tried this and I get the following

Welcome to MediaMVP!

192.168.0.3 login: root


BusyBox v1.1.3 (2007.08.30-07:01+0000) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

# cat /etc/tftp.config
TFTP=192.168.0.2
MAC=00:0D:FE:00:27:CB
# mount.cifs //192.168.0.2/mvpmc /etc/mvpmc -o username=guest,ro
Password:

# ls -lt /etc/dongle.config
-rw------- 1 root root 0 Dec 31 18:00 /etc/dongle.config
# ls -lt /etc/dongle.config
-rw------- 1 root root 0 Dec 31 18:00 /etc/dongle.config
#


Just wondering if everything looks ok

Thanks

Pete

mvallevand
2008-02-29, 06:21 PM
What do you see if you do this command?

ls /etc/mvpmc

Martin

petewxm
2008-02-29, 06:39 PM
What do you see if you do this command?

ls /etc/mvpmc

Martin

Hi martin

Nothing happens after entering it

Welcome to MediaMVP!

192.168.0.3 login: root


BusyBox v1.1.3 (2007.08.30-07:01+0000) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

# ls /etc/mvpmc
#


Thanks

Pete

mvallevand
2008-02-29, 06:42 PM
Then the dongle.bin.config file doesn't have guest permissions set properly. Create another file in the mvpmc share now and see it shows up with the ls /etc/mvpmc command.

Martin

petewxm
2008-02-29, 06:45 PM
I`m using vista, I`ve enabled guest accounts and set permissions to share. I`ll delete the folder and try again, is there anything else I should do in vista.

Thanks

petewxm
2008-02-29, 06:53 PM
sorry martin I miss read your reply, I added a .txt file and did the ls /etc/mvpmc command and it didn`t show up

mvallevand
2008-02-29, 07:00 PM
If you right click the properties of the folder and the file on the security tab do you see Guest under the user names. If you do maybe you have a firewall in the way.

Martin

petewxm
2008-02-29, 07:14 PM
Hi Martin,

Yes guest is there and I havent got a firewall turned on at the mo

See pic

Any other ideas,

Thanks

Pete

mvallevand
2008-02-29, 07:26 PM
You vista machine is 192.168.0.2 correct? The only other tools is the command prompt programs

net share
this should show the mvpmc share name somewhere

cacls \mvpmc
cacls \mvpmc\dongle.bin.config

These both should have Guest on them.

Martin

petewxm
2008-02-29, 07:41 PM
Hi Martin,

It showed the info in the attached file

Which all looks ok, I think???

Can you please have a look

Thanks

Pete

mvallevand
2008-02-29, 08:12 PM
Those look just fine. Maybe the server just needs a reboot.

Martin

petewxm
2008-03-25, 11:35 AM
Hi Martin,

I`m still having problems with this, have you got any other suggestions?

Thanks

Pete

mvallevand
2008-03-25, 11:55 AM
Did you ever check to see if via telnet cat /etc/tftp.config gives the IP of your GBPVR server?

Martin

petewxm
2008-03-25, 10:30 PM
Hi Martin,

Yeah it gives the following

TFTP=192.168.0.2
MAC=00:0D:FE:00:27:CB

Thanks

Pete

mvallevand
2008-03-25, 10:38 PM
Thinks continue to look ok, the only other thing I can think of is a firewall block.

Martin

petewxm
2008-03-26, 07:07 PM
Hi Martin,

Thanks for taking the time to look at it,

Yeah its a strange 1, it should work, I`ve tried with the firewall turned off and still no joy.

Not to worry, I was liking the wol part of it, but I can live without it

Thanks

Pete

kerry6
2008-05-02, 10:47 AM
mount.cifs //yourip/mvpmc /etc/mvpmc -o username=guest,ro

If this fails record the error and let me know.

If this works enter the following

ls -lt /etc/dongle.config


If it exists your dongle.config is wrong. Please let me know the contents.

Martin

Mine returned the error message:
# mount.cifs //192.168.1.100/mvpmc /etc/mvpmc -o username=guest,ro
Password:
mount error 22 = Invalid argument
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

can you tell me what this message is?

mvallevand
2008-05-02, 11:52 AM
It isn't specific but it means that your mvpmc share on 192.168.1.100 is not supporting guest access right now.

Martin

kerry6
2008-05-02, 11:53 PM
It isn't specific but it means that your mvpmc share on 192.168.1.100 is not supporting guest access right now.

Martin

is this better? it is showing the contents of the dongle.bin.config file that I created on my vista share of c:/mvpmc :D

# mount.cifs //192.168.1.108/mvpmc /etc/mvpmc -o username=guest,ro
Password:
# ls -lt /etc/dongle.config
-rw------- 1 root root 0 Dec 31 18:00 /etc/dongle.config
# ls -lt /etc/tftp.config
-rw-r--r-- 1 root root 41 Dec 31 18:00 /etc/tftp.config
# ls /etc/mvpmc
dongle.bin.config
# cat /etc/mvpmc/dongle.bin.config
mvpmc --startup emulate --emulate ? &
#

mvallevand
2008-05-03, 12:09 AM
That looks ok, is cat /etc/tftp.config the correct IP for your GBPVR server? If not you need to load the Hauppauge software.

Martin

kerry6
2008-05-03, 12:11 AM
That looks ok, is cat /etc/tftp.config the correct IP for your GBPVR server? If not you need to load the Hauppauge software.

Martin

it is now.

mvallevand
2008-05-03, 12:30 AM
it is now.

So what is the problem?

Martin

kerry6
2008-05-03, 12:31 AM
That looks ok, is cat /etc/tftp.config the correct IP for your GBPVR server? If not you need to load the Hauppauge software.

Martin

the config is now working great and booting in emulation mode. gonna play tomorrow with other config files, and shares. thanks alot.:eek:

cakes
2008-12-06, 02:33 PM
Hi,

To startup in emulation mode, I've been using this line in my dongle.bin.config for a long time:
mvpmc -c 192.168.0.111 --startup emulate --emulate 192.168.0.111 &

Today, I've upgraded to 1.3.7 and removed the mvpmc share and tried this line in my config.xml
<MvpmcStartupConfig>mvpmc -c 192.168.0.111 --startup emulate --emulate 192.168.0.111 &amp;</MvpmcStartupConfig>

Now my mvp is still loading mvpmc but mvpmc does not start in emulation mode anymore. I've tried the default <MvpmcStartupConfig> line, but no result. I also tried removing "amp;" but that seems to be needeed, because if not present, the recordingservice is not even starting.

Am I overlooking something?

mvallevand
2008-12-06, 02:49 PM
Are you using the required new dongle too? http://forums.nextpvr.com/showthread.php?t=38574

Martin

cakes
2008-12-06, 03:25 PM
No, I was not, but now I do. Works great ! Thanks !

djhorv
2009-03-01, 07:37 PM
And it works great, but after powering off and powering back on the MVP goes blank for over a minute before coming up. Is this normal?

Thanks.

DJHorv

mvallevand
2009-03-01, 09:50 PM
From a true power off (unplugged state) it can take longer to load mvpmc because the dongle is bigger but you should see the MVP start loading mvpmc after about 15 seconds. One minute to get to emulation mode seems longer than it should be but it is also network related. The new method is slower because it is the third method the dongle tries.

If you do a power on just with the remote it should only be 5-10 seconds before you are fully functional.

Martin