PDA

View Full Version : Resume & stuttering issues



dfdario
2007-03-26, 09:29 AM
Just tried 0.3.3 version of mvpmc and found that resume function doesn't work and I'm experiencing stutters while playing standard MPEG recordings.
Same behaviour with last dongle available (2007-03-25).
Any suggestion?

mvallevand
2007-03-26, 11:39 AM
Just tried 0.3.3 version of mvpmc and found that resume function doesn't work and I'm experiencing stutters while playing standard MPEG recordings.
Same behaviour with last dongle available (2007-03-25).
Any suggestion?

First of all when you say the last dongle, do you mean the nightly on the mvpmc or my alpha? I suggest sticking with the alpha. See the first sticky thread.

Then could you explain what the resume function is.

Finally for stuttering do you mean the video slows down or there is pixelization at the bottom. For general stuttering in the alpha dongle you might need to hit the Go then Videos remote keys if there is OSD information. If the file plays fine with the Hauppauge dongle, could you give me details with a program like GSpot or Mediainfo.


Thanks,

Martin

dfdario
2007-03-26, 12:38 PM
First of all when you say the last dongle, do you mean the nightly on the mvpmc or my alpha? I suggest sticking with the alpha. See the first sticky thread.
I mean the Nightly builds


Then could you explain what the resume function is.

Resume is when you stopped playing a recording at a certain point and when you start playing it again you would resume from the point you were stopped.


Finally for stuttering do you mean the video slows down or there is pixelization at the bottom. For general stuttering in the alpha dongle you might need to hit the Go then Videos remote keys if there is OSD information. If the file plays fine with the Hauppauge dongle, could you give me details with a program like GSpot or Mediainfo.

Thanks,

Martin
For stutter I mean the video stops playing for a while at each second.
No pixelation.

Thanks for doing such superb program. First time I've been using it was two years ago with MythTV ad it was working fine!

mvallevand
2007-03-26, 03:32 PM
I mean the Nightly builds



Resume is when you stopped playing a recording at a certain point and when you start playing it again you would resume from the point you were stopped.


For stutter I mean the video stops playing for a while at each second.
No pixelation.

Thanks for doing such superb program. First time I've been using it was two years ago with MythTV ad it was working fine!

Ok, right now I recommend the alpha over the nightly for GBPVR testing, but for these issues the nightly should perform about the same.

I can't test the resume, my machine is running some long test, but when I did it is configured by the config program and it was working, ie the dialog opened and gbpvr positioned the file. Incidently I can't use the Hauppauge program dropoff value which allows auto restart because it is always the same in gbpvr.

Regarding the performance the stuttering looks like it is LAN bandwidth related. I couldn't play that file from a NAS but it would play fine from my Windows box. Does that file play ok with the Hauppauge dongle and GBPVR?

Martin

dfdario
2007-03-27, 06:27 AM
Ok, right now I recommend the alpha over the nightly for GBPVR testing, but for these issues the nightly should perform about the same.

I can't test the resume, my machine is running some long test, but when I did it is configured by the config program and it was working, ie the dialog opened and gbpvr positioned the file. Incidently I can't use the Hauppauge program dropoff value which allows auto restart because it is always the same in gbpvr.
I think I've to read more deeply how to configure it. Now I have a basic configuration file.


Regarding the performance the stuttering looks like it is LAN bandwidth related.
You're probably right. May be Half/Full Duplex related or something similar.


I couldn't play that file from a NAS but it would play fine from my Windows box. Does that file play ok with the Hauppauge dongle and GBPVR?
With GBPVR dongle all is working perfect. I'll give it one more try with different settings.

mvallevand
2007-03-27, 11:40 AM
You're probably right. May be Half/Full Duplex related or something similar.

If you are running with a dongle.bin.config file I can explain how to turn on half duplex.

With GBPVR dongle all is working perfect. I'll give it one more try with different settings.
If you could somehow make available a sample of one of your mpegs, a couple of minutes should suffice, I could see how it works for me.

Martin.

macgyver
2007-03-28, 09:04 PM
Hi

I am having a problem with resume also. It prompts me to select resume or restart but when I select resume I can see that the timeline briefly shows the restart time so it is attempting to do it but it then just starts again from the beginning.
I've just downloaded the lastest alpha. I've made no changes other than to load the mvpmc dongle (using gbpvr config), changed the settings to widescreen and selected emulation to load gbpvr. Running 99.12.

Everything else seems to work really well (including Music Library2), so thanks for all your great work.

mvallevand
2007-03-28, 09:35 PM
Hi

I am having a problem with resume also. It prompts me to select resume or restart but when I select resume I can see that the timeline briefly shows the restart time so it is attempting to do it but it then just starts again from the beginning.
I've just downloaded the lastest alpha. I've made no changes other than to load the mvpmc dongle (using gbpvr config), changed the settings to widescreen and selected emulation to load gbpvr. Running 99.12.

Everything else seems to work really well (including Music Library2), so thanks for all your great work.

Thanks for the confirmation of the problem. I must have broken something recently, I will have a look tonight, I think I can finally stop the long ML2 testing.

Martin

mvallevand
2007-03-29, 02:36 AM
Just tried 0.3.3 version of mvpmc and found that resume function doesn't work


I am having a problem with resume also. It prompts me to select resume or restart but when I select resume I can see that the timeline briefly shows the restart time so it is attempting to do it but it then just starts again from the beginning.

I've uploaded a new alpha with a small change that (I hope) fixes resume. It works for me without breaking live tv, which shares some of this logic, so feedback is welcome. It is certainly tough working on an undocumented protocol.

Martin

dfdario
2007-03-29, 06:42 AM
I've uploaded a new alpha with a small change that (I hope) fixes resume. It works for me without breaking live tv, which shares some of this logic, so feedback is welcome. It is certainly tough working on an undocumented protocol.

Martin

Yesterday I tested the 27/3 Alpha, same result, stuttering and no resume.
dongle.bin.Config have not been read so I had to select configuration from main menu.
Tonight I'll give a try to your last Alpha dongle.

macgyver
2007-03-29, 07:32 PM
Just downloaded and installed latest Alpha - so far so good, resume working well.
Mant thanks again.

dfdario
2007-03-30, 08:49 AM
Because of some disk errors on my Hard Disk I didn't test it yet. I'd to solve them before. Sorry.

macgyver
2007-03-30, 11:16 AM
Having used it for a while last night I did seem to have a fair few reboot to mvpmc menu problems, two or three times each when selecting what to watch next. Happens when navigating around the menus. Not a huge problem because within a few seconds I've selected 'Emulation' again and it's back, but thought I'd let you know as it is a tad annoying, WAF and all that...

mvallevand
2007-03-30, 01:34 PM
Having used it for a while last night I did seem to have a fair few reboot to mvpmc menu problems, two or three times each when selecting what to watch next. Happens when navigating around the menus. Not a huge problem because within a few seconds I've selected 'Emulation' again and it's back, but thought I'd let you know as it is a tad annoying, WAF and all that...

Thanks I will look at this, I assume you mean the main TV guide. If you have video open there could easily be a problem because of the stutter mode hack i've got in now. Also if you do have video open, are you using a skin that shows the inset video?

Martin

dfdario
2007-03-31, 06:56 AM
Brefly tested last night.
Resume works properly

Frequently annoying restarts while in idle (not playing anything)

dongle.bin.config is not red so everytime I need to select "Emulation" from main menu

My dongle.bin.config contains:
mvpmc --emulate 192.168.1.252 --startup emulate -m pal

Stuttering is still there but is my problem (I think)

mvallevand
2007-03-31, 11:22 AM
Frequently annoying restarts while in idle (not playing anything)

Are you running any plugins are a different skin?

Martin

dfdario
2007-04-02, 09:16 AM
No plugin at all and Basic Skin - Maximum.

Downloaded 1 Apr dongle, Config file is red, resume i OK, still stuttering on all files even if in Net card is set to full duplex mode while original dongle have no problem.

mvallevand
2007-04-02, 12:09 PM
No plugin at all and Basic Skin - Maximum.

Downloaded 1 Apr dongle, Config file is red, resume i OK, still stuttering on all files even if in Net card is set to full duplex mode while original dongle have no problem.

Very strange, the only thing I can do without the actual file is ask you to test the file in mvpmc native mode. This should not be hard if you can read a config file. Here are the steps

1. Place an mpeg in your mvpmc share folder
2. From the mvpmc main menu select Filesystem rather than Emulation.
3. Navigate to the /etc/mvpmc folder
4. Select your file with the ok.
5. While the file is playing hit the ok. This should show you the actual bit rate the file is playing at. If it is much slower then your file's real rate it like will stutter.

There's more testing you can do too if you want

1. While the file is playing hit the menu key. Check what audio video and subtitle streams are present.

2. Before selecting a file. Instead of hitting OK hit menu. From this select throughput test and let it run for about 30 seconds and hit ok. You should get a reading of the max. bit rate your mvp on your network gets.

3. While the file is playing in emulation mode telnet to your mvpmc and logon as root. The are two commands you can try.

a. ifconfig. Type this in a few times to see if you are getting lots of network errors.

b. top This command will show your cpu use. If it is more than 50% there is a good chance of stuttering. Use Ctrl-C to exit top

Sorry I can't be more help.

Martin

dfdario
2007-04-05, 01:29 PM
Very strange, the only thing I can do without the actual file is ask you to test the file in mvpmc native mode. This should not be hard if you can read a config file. ...
Before doing what you suggested I tested 3 Apr. dongle.
Here the results:
Some restarts
Stuttering. After the play is paused I've no stutters for 2 secods indicating it should be a buffer problem.

mvallevand
2007-04-05, 03:52 PM
Before doing what you suggested I tested 3 Apr. dongle.
Here the results:
Some restarts
Stuttering. After the play is paused I've no stutters for 2 secods indicating it should be a buffer problem.

It is related to throughput somehow the network is either not keeping up with the demuxer, or something in your files is causing the demuxer to slow down. That is why I really need 5 min sample.

Martin

dfdario
2007-04-05, 05:25 PM
It is related to throughput somehow the network is either not keeping up with the demuxer, or something in your files is causing the demuxer to slow down. That is why I really need 5 min sample.

Martin

Adding the following Windows registry subkey to the registry solve the stuttering problem but only on some recordings.

\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servi ces\LanmanServer\Parameters
Create a SizReqBuf value using the following information:

ValueName: SizReqBuf
DataType: REG_DWORD
Value(Decimal): 33000

As suggested at http://www.mvpmc.org/windows/mvpmc_windoze_howto.html#s11

mvallevand
2007-04-05, 05:54 PM
Adding the following Windows registry subkey to the registry solve the stuttering problem but only on some recordings.

\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servi ces\LanmanServer\Parameters
Create a SizReqBuf value using the following information:

ValueName: SizReqBuf
DataType: REG_DWORD
Value(Decimal): 33000

As suggested at http://www.mvpmc.org/windows/mvpmc_windoze_howto.html#s11

This is an odd problem. Those recommendations are for accessing files through a Windows share, and emulation mode uses Hauppauge protocol with gbpvr as a media server. I guess it could help if the files you were streaming with gbpvr were actually coming from a share or a NAS.

Martin

dfdario
2007-04-06, 08:29 AM
I didn't share anything yet (I've some problem in doing that).
Anyway I show you what ifconfig is reporting.

media_mvp2 login: root


BusyBox v1.1.3 (2007.03.10-14:02+0000) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

# ifconfig
eth0 Link encap:Ethernet HWaddr 00:0D:FE:00:6B:1C
inet addr:192.168.1.242 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:70785 errors:0 dropped:0 overruns:0 frame:0
TX packets:37897 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:104471754 (99.6 MiB) TX bytes:0 (0.0 B)
Interrupt:27 Base address:0xd300 DMA chan:1

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

#
The lowest value I've seen is 27.x

mvallevand
2007-04-06, 09:17 AM
I didn't share anything yet (I've some problem in doing that).

The lowest value I've seen is 27.x

The MiB is another standard for MB ensuring that it binary and not base 10..... you know linux stuff ....
It should grow fast with your high bit rate files. I'm looking to see if you get lots of overrun errors the others will likely stay 0.

Martin

dfdario
2007-04-06, 09:49 AM
Very strange, the only thing I can do without the actual file is ask you to test the file in mvpmc native mode. This should not be hard if you can read a config file. Here are the steps

1. Place an mpeg in your mvpmc share folder
2. From the mvpmc main menu select Filesystem rather than Emulation.
3. Navigate to the /etc/mvpmc folder
4. Select your file with the ok.
5. While the file is playing hit the ok. This should show you the actual bit rate the file is playing at. If it is much slower then your file's real rate it like will stutter.

3.57 Mbps as lowest value



There's more testing you can do too if you want

1. While the file is playing hit the menu key. Check what audio video and subtitle streams are present.

Audio
Stream ID 0xc0 - MPEG
Video
Stream ID 0xe0 - MPEG
Subtitles
--


2. Before selecting a file. Instead of hitting OK hit menu. From this select throughput test and let it run for about 30 seconds and hit ok. You should get a reading of the max. bit rate your mvp on your network gets.

Seconds: 36.28
mb/s: 3.84



3. While the file is playing in emulation mode telnet to your mvpmc and logon as root. The are two commands you can try.

a. ifconfig. Type this in a few times to see if you are getting lots of network errors.

b. top This command will show your cpu use. If it is more than 50% there is a good chance of stuttering. Use Ctrl-C to exit top

I've already posted that
Sorry the value at b. is
Mem: 13380K used, 304K free, 0K shrd, 3916K buff, 4193208K cached
Load average: 0.27, 0.15, 0.06 (State: S=sleeping R=running, W=waiting)

PID USER STATUS RSS PPID %CPU %MEM COMMAND
96 root S 8648 94 7.3 63.1 mvpmc
97 root S 8648 94 5.3 63.1 mvpmc
107 root R 8648 94 5.1 63.1 mvpmc
95 root S 8648 94 0.5 63.1 mvpmc
113 root R 376 111 0.5 2.7 top
93 root R 8648 85 0.1 63.1 mvpmc
50 root S 280 1 0.1 2.0 telnetd
109 root S 8648 94 0.0 63.1 mvpmc
100 root S 8648 94 0.0 63.1 mvpmc
101 root S 8648 94 0.0 63.1 mvpmc
98 root S 8648 94 0.0 63.1 mvpmc
99 root S 8648 94 0.0 63.1 mvpmc
108 root S 8648 94 0.0 63.1 mvpmc
110 root S 8648 94 0.0 63.1 mvpmc
94 root S 8648 93 0.0 63.1 mvpmc
102 root S 8648 94 0.0 63.1 mvpmc
85 root S 776 1 0.0 5.6 mvpmc
111 root S 404 50 0.0 2.9 sh
1 root S 344 0 0.0 2.5 init
77 root S 316 1 0.0 2.3 udhcpc
8 root SW 0 1 0.0 0.0 mtdblockd

mvallevand
2007-04-06, 10:27 AM
Seconds: 36.28
mb/s: 3.84


Did it stutter in native mode too? Although test two is an indicator of your share speed, that maximum cifs throughput seems low. Some have hit 13 on this. I am going to do some digging and get back to you.

Thanks a lot.

Martin

mvallevand
2007-04-07, 11:05 PM
As an update on this problem, I've "had" to upgrade my gbpvr server to a modern machine (dual core, sataII etc) and Vista, all completely unfragmented, and I too get stuttering on some files that worked just fine before. Hopefully as I diagnose this I'll be able to pass on some tips and modify emulation mode to resolve this.

Martin

mvallevand
2007-04-10, 05:00 AM
Seconds: 36.28
mb/s: 3.84


I did some network testing and I hit 11.5 mb/s so your throughput is a bit low in comparision, but here is my latest stuttering update

If you've been following this thread I'm having trouble with one file that just won't play without stuttering on Vista but worked fine on XP. It is VBR 3-8.5 and when it gets to the higher bit rate areas noticeable stuttering. I've tried every network tweak to mvpmc I can imagine. The file plays fine from a Vista share on mvpmc natively and with 11.5 mbs I'd expect that.

The odd thing about this file is that sometimes it has worked in emulation. What I did tonight is set this value in GBPVR's config.xml (default is true)

<MvpHighPriority>false</MvpHighPriority>

Since then I haven't had a problem in some limited testing. It might be interesting if you tried this test.

Martin

mvallevand
2007-04-11, 02:33 AM
As discussed yesterday changing the config.xml setting to a lower priority
<MvpHighPriority>false</MvpHighPriority> for me has effectively eliminated my one stuttering problem.
As this might not be your problem, it might be specific to me and or to Vista and want to try something else.

I have therefore uploaded a new dongle 0410 which gives a bit more control over networking, the rt_window network variable in emulation mode tunable, it seem to have the most impact on the mvp's network performance (and potential for stuttering). The command line option is --em-rtwin and you can use any up to 64k. The default is 4096 but I suggest trying variables between 2048 and 8192.

FWIW, the Hauppauge dongle default has been 0 which means default to the kernel value, except in the most recent dongle where they have chosen 8192. I personally find too many errors rx overruns reported in ifconfig with either of these.

Feel free to try various settings and report your findings especially if you find you can reduce stuttering.

This really should be tested my telnet. You only need killall mvpmc once, if you load mvpmc from the command line you can kill it with ctrl-c. Also there is a command line history in mvpmc. Use the cursor keys to restore and earlier commands.

Martin

dfdario
2007-04-11, 06:29 AM
You are right. Changing the config.xml setting to set MVP to a lower priority doesn't solve the stuttering. Tonight I'll try the settings you suggested.

dfdario
2007-04-11, 05:02 PM
As discussed yesterday changing the config.xml setting to a lower priority
<MvpHighPriority>false</MvpHighPriority> for me has effectively eliminated my one stuttering problem.
As this might not be your problem, it might be specific to me and or to Vista and want to try something else.

I have therefore uploaded a new dongle 0410 which gives a bit more control over networking, the rt_window network variable in emulation mode tunable, it seem to have the most impact on the mvp's network performance (and potential for stuttering). The command line option is --em-rtwin and you can use any up to 64k. The default is 4096 but I suggest trying variables between 2048 and 8192.


It seems 8192 is the best value even if it remains some tendency to stutter but immediately recovered.
Lower values than 8192 make mvp stutter higher values get some problem whith repeated skips (you see previous video position while sound reflects the current position and after video recover the position audio and video result out of sync).

mvallevand
2007-04-12, 12:49 AM
It seems 8192 is the best value even if it remains some tendency to stutter but immediately recovered.
Lower values than 8192 make mvp stutter higher values get some problem whith repeated skips (you see previous video position while sound reflects the current position and after video recover the position audio and video result out of sync).

Thanks, I will change the default to 8192 for the next alpha, to see how it works for others.

Martin