PDA

View Full Version : slow startup in video archive



pastro
2007-04-18, 05:11 PM
I just installed the beta of video archive and when I enter the recordings screen, I get a please wait in the right top corner and after 10 minutes it's still sitting there.. Is this normal for the first startup of the plugin?

EDIT: And if I hit any buttons, I get a popup "Please wait for initialization to complete."
I ran the config but the only thing I did was uncheck the auto fetch info check box.
I ran it again and added a user. The first time I entered the recordings it asked for the pin, and I typed it in. An error message popped up with something was set to the instance. I entered the recordings again and now I get the please wait forever.
Any help appreciated.

Jeff
2007-04-18, 05:33 PM
No, that sounds like a bug. Can you zip up and post the log files from your jeff subdirectory.

Jeff

pastro
2007-04-18, 05:45 PM
Ok here they are.
I did notice it was trying to convert my database. I'm already on sqlite so it converted an empty database.

thanks

Jeff
2007-04-20, 05:58 AM
The problem is that your directory list includes the root drive c:. The video archive plug-in scans and monitors all subdirectorries under the root video directories you specify. Since c: is the root of your disk that is a lot to scan and monitor, and will take a very long time to startup. If you create a subdirectory for your recordings (e.g., c:\my recordings) and use that instead then startup should be fast.

Jeff

pastro
2007-04-21, 04:58 AM
The problem is that your directory list includes the root drive c:. The video archive plug-in scans and monitors all subdirectorries under the root video directories you specify. Since c: is the root of your disk that is a lot to scan and monitor, and will take a very long time to startup. If you create a subdirectory for your recordings (e.g., c:\my recordings) and use that instead then startup should be fast.

Jeff

Which directory list? The dirs that I setup in config for the main app are:

Video Library c:\myvideos and e:\my videos 2
recordings directory c:\myvideos
Live TV buffer c:\myvideos

In VA I have archive directory
c:\archivevideos

Paths for DVDs
c:\archivevideos


Nothing that I can see is c:\