PDA

View Full Version : New alpha dongle Sept. 11



mvallevand
2007-09-11, 12:12 PM
I have uploaded a new alpha dongle that includes changes from the nightly to hopefully address a/v sync in mpeg files. I would be very interested in finding out if this is successful from from anyone who has this problem. If this proves to work as planned then it very well could be a solution for AC3 audio too. The code is experimental right now but looks promising unfortunately I don't have this problem. It will not address stuttering audio that results from network bandwidth issues.

The only other change from dongle2xa.zip is jksmurf's EventGhost change. I am however working on Go keys for 0-9 which will duplicate Hauppauge's percentage skip by calculating the time forward or backward.

Finally as a reminder since 1.x has been released for best results with mvpmc and 99.12 and earlier you need to use the command line option --em-safety 3 to get around a GBPVR bug that has been fixed in both GBPVR and PVRX2

Martin

jksmurf
2007-09-11, 12:55 PM
I have uploaded a new alpha dongle that includes changes from the nightly to hopefully address a/v sync in mpeg files. I would be very interested in finding out if this is successful from from anyone who has this problem. If this proves to work as planned then it very well could be a solution for AC3 audio too. The code is experimental right now but looks promising unfortunately I don't have this problem. It will not address stuttering audio that results from network bandwidth issues.

Cool.


The only other change from dongle2xa.zip is jksmurf's EventGhost change. I am however working on Go keys for 0-9 which will duplicate Hauppauge's percentage skip by calculating the time forward or backward.

Sounds cool. Will you be doing a Go <other colours as well as green?>


Finally as a reminder since 1.x has been released for best results with mvpmc and 99.12 and earlier you need to use the command line option --em-safety 3 to get around a GBPVR bug that has been fixed in both GBPVR and PVRX2 Martin

Hmmm ... so what was the bug .... (and is it fixed in a patches or in sub's NEXT build?)

k.

mvallevand
2007-09-11, 04:17 PM
Sounds cool. Will you be doing a Go <other colours as well as green?>

These seem to the logical place for adding some other mvpmc functionality such as selecting audio/video/subtitle streams


Hmmm ... so what was the bug .... (and is it fixed in a patches or in sub's NEXT build?)

Sorry I wasn't clearer. Sub fixed the problem in 1.x (both GBPVR and PVRX2) The problem related to collsions in communication between the client and server causing some commands to get lost or corrupt. The earlier "alpha" mvpmc dongles took steps to reduce the risk of, at the price that the remote response was slightly interrupted at times. I changed the default when 1.0.8 came out because this interruption was no longer necessary.

With 99.12 the new default is actually no worse than with the Hauppauge dongle but --em-safety 3 should be as stable as the round IV dongle, although I must say it has been a long time since I have tested GBPVR thoroughly.

There still is one conflict possible with 1.0.8/16 but it happens very rarely. This can be eliminated with --em-safety 1 but no one has really identified this as a problem yet. The symptom is continuous playing music will just stop between songs. Maybe when tkgafs gives mvpmc and PVRX2 1.x a full workout, I will see the need to make this a default.

Martin

HarryH3
2007-09-11, 04:59 PM
There still is one conflict possible with 1.0.8/16 but it happens very rarely. This can be eliminated with --em-safety 1 but no one has really identified this as a problem yet. The symptom is continuous playing music will just stop between songs.

Interesting... I occasionally see this happen using mvpmc and 99.12. I can select a folder of songs and then "play all", but only the first song plays. Reloading mvpmc makes it start working correctly again. :confused: It rarely happens though, perhaps 2 times per month.

pz1
2007-09-11, 09:01 PM
With 99.12 the new default is actually no worse than with the Hauppauge dongle but --em-safety 3 should be as stable as the round IV dongle, although I must say it has been a long time since I have tested GBPVR thoroughly.


hmmmm, added the switch today and observed quite a few restarts while moving through the program guide.

mvallevand
2007-09-11, 09:52 PM
hmmmm, added the switch today and observed quite a few restarts while moving through the program guide.

That's odd I can't remember anything changing on the GUI processing code since round IV, as was --em-safety 3. I assume your problem was with the first alpha from today and 99.12

Martin

mvallevand
2007-09-11, 09:53 PM
Interesting... I occasionally see this happen using mvpmc and 99.12. I can select a folder of songs and then "play all", but only the first song plays. Reloading mvpmc makes it start working correctly again. :confused: It rarely happens though, perhaps 2 times per month.

It should happen less often with --em-safety 3.

Martin

mvallevand
2007-09-11, 09:55 PM
Note I just updated today's alpha with another change from the mvpmc repo. More sync logic changes.

Martin

pz1
2007-09-12, 07:42 AM
That's odd I can't remember anything changing on the GUI processing code since round IV, as was --em-safety 3. I assume your problem was with the first alpha from today and 99.12

Martin
No this time I did not upgrade. I should have mentioned that. I am still using the 20070819 dongle.

mvallevand
2007-09-12, 11:55 AM
No this time I did not upgrade. I should have mentioned that. I am still using the 20070819 dongle.

Ok, I'll try --em-safety 3 with gbpvr (not pvrx2) 1.0.16. There are so few changes in this newer version of gbpvr (the mvp fix, and broken inset video), that I should experience the same behaviour.

Martin

Sheik Yerbouti
2007-09-12, 06:11 PM
Hi Martin,

I've been trying this latest dongle, hoping it would play the files I record with Mediaportal (FloppyDTV with CAM), but it's not working. Your previous dongle (08-30-07) could play them, but with the same problem as the Hauppauge dongle. The problem is skipping: there seems to be something wrong with the timestamps in these files. But that's probably something that won't get solved using another dongle.

The current dongle plays these files for a short while or not at all, and I have no sound. The files recorded with my Hauppauge PVR500 play fine.

mvallevand
2007-09-12, 08:41 PM
Hi Martin,

I've been trying this latest dongle, hoping it would play the files I record with Mediaportal (FloppyDTV with CAM), but it's not working.

Is there are way you could provide me one of these files?

Martin

mvallevand
2007-09-13, 04:25 AM
hmmmm, added the switch today and observed quite a few restarts while moving through the program guide.

Pieter I couldn't duplicate this with gbpvr 1.0.16 and --em-safety 3 and I was pretty aggressive in trying to break it. If I have a chance over the weekend I might re-install 99.12 but I couldn't find any code difference to even try and exercise.

Martin

pz1
2007-09-13, 07:43 AM
Pieter I couldn't duplicate this with gbpvr 1.0.16 and --em-safety 3 and I was pretty aggressive in trying to break it. If I have a chance over the weekend I might re-install 99.12 but I couldn't find any code difference to even try and exercise.

Martin
Martin don't bother. This was just the experience of two hours or so. I just thought I give some feedback to see if others experience the same. This apparantly did not happen. So, I should test more thoroughly to see the patterns.
Spend your time on better things for the moment.

Pieter

mvallevand
2007-09-13, 11:59 AM
Martin don't bother. This was just the experience of two hours or so. I just thought I give some feedback to see if others experience the same. This apparantly did not happen. So, I should test more thoroughly to see the patterns.
Spend your time on better things for the moment.

It's no bother and also using GBPVR I can enable logging again which is a lot better for me. Emulation mode shouldn't be version specific anyway and I want to see if there is a server or client side problem.

Martin

TobyO
2007-09-13, 03:50 PM
mvallevand

I like the dongle featues to my mvp. I have been using the mvpmc dongles for the past 2 months. My MVP with the latest 9/11 dongle seems to lose communication in 2 ways. The first if I ff in a movie more than 3 times and the other is if I watching a video (including live TV) for more than 25 mins. I orginally though my computer was going a sleep , but I cheked and the computer is set never go to sleep. I have no problems getting a respose after 2 days of inactivity on the server or mvp. It only happend during video play. If I wait until the movie is over the MVP show the PVR2X GUI , but fails to respond to the remote. With the pevious dongles I see this happing as well. I think this dongle is is worth while and am willing to help us any way I can. Is there somthing I can try or log files somewhere to help you understand the issue?

PS somthing unique with this dongle is when watch live TV show runs past the hour (i.e.1:00pm, 2:00 pm etc...) the screen goes blank for less than a second and continues on.

Toby

The MVP are rev D and D3a
the server is an XP pro with an X2 4200 CPU and 2 gb ram,300 GB drive, 2 x Raid 0 700GB and 1 TB raid 5. In addition to 3 TV Tuners 1 150,350 and a 500 PVR Happ.

mvallevand
2007-09-13, 04:59 PM
mvallevand

I like the dongle featues to my mvp. I have been using the mvpmc dongles for the past 2 months. My MVP with the latest 9/11 dongle seems to lose communication in 2 ways.

Which version of the dongle and GBPVR were you using previously. Emulation mode didn't change for this alpha.


The first if I ff in a movie more than 3 times and the other is if I
Do you use the FF or Short Skip option?


watching a video (including live TV) for more than 25 mins.

Are you running wired or wireless. While watching video it is a loop so there is no difference between 5 and 25 minutes (except when programs change).


If I wait until the movie is over the MVP show the PVR2X GUI , but fails to respond to the remote.

Do you have the Hauppauge Media service turne off? This would happen in that situation.


I think this dongle is is worth while and am willing to help us any way I can. Is there somthing I can try or log files somewhere to help you understand the issue?

There will be but let's address these things first.


PS somthing unique with this dongle is when watch live TV show runs past the hour (i.e.1:00pm, 2:00 pm etc...) the screen goes blank for less than a second and continues on.

That's a PVRX2 change, I don't like it as much as GBPVR but I don't think there's anything I can do about it.

Thanks for the input.

Martin

Sheik Yerbouti
2007-09-13, 07:24 PM
Is there are way you could provide me one of these files?

Martin

No problem. What size do you want the file to be? I'll make a new recording for you. I can host about 200MB on my webspace.

mvallevand
2007-09-13, 07:36 PM
No problem. What size do you want the file to be? I'll make a new recording for you. I can host about 200MB on my webspace.

I can accept up to 20MB on my email account on my profile. If you find another site I don't really care about the size 50-100MB, as long as it has broadband speed.

Martin

TobyO
2007-09-13, 08:23 PM
Which version of the dongle and GBPVR were you using previously. Emulation mode didn't change for this alpha.

dongle 2A

Do you use the FF or Short Skip option?

Short skip

Are you running wired or wireless. While watching video it is a loop so there is no difference between 5 and 25 minutes (except when programs change).

Wired

Do you have the Hauppauge Media service turne off? This would happen in that situation.

I'm not sure what you mean, but I donot have any of the Hauppauge software for the MVP installed jut GBPVR.

There will be but let's address these things first.



That's a PVRX2 change, I don't like it as much as GBPVR but I don't think there's anything I can do about it.

Thanks for the input.

Martin

thank you for the time and effort

mvallevand
2007-09-13, 08:45 PM
thank you for the time and effort

TobyO sorry I need a bit more info. For dongle 2a can you give me the time and date from mvpmc's About screen. Also can you confirm you are running PVRX2 1.0.16 and give me the date of PVRX2.exe.

Martin

Sheik Yerbouti
2007-09-13, 09:27 PM
I can accept up to 20MB on my email account on my profile. If you find another site I don't really care about the size 50-100MB, as long as it has broadband speed.

Martin
I'm uploading the file at this moment: http://www.xs4all.nl/~degit/test.mpg

TobyO
2007-09-14, 02:24 AM
The dongle currently is Sept.12 at 3:00. The previously I was using Jul 20. The one on the 12th is the one I'm writting about.

I am running 1.0.16

Tobyo

mvallevand
2007-09-14, 02:46 AM
I'm uploading the file at this moment: http://www.xs4all.nl/~degit/test.mpg

It's size is 136MB and it should be there in 30 minutes. I'm going to bed now, so if something's wrong with the upload, you'll have to wait till tomorrow. Thanks for checking it out!

That really high bit rate file which is probably the real problem. I'm having trouble getting PAL to work with my HVR 1600 I forgot about that so it will be a couple of days before I can view PAL files.

Martin

Sheik Yerbouti
2007-09-14, 02:51 AM
That really high bit rate file which is probably the real problem. I'm having trouble getting PAL to work with my HVR 1600 I forgot about that so it will be a couple of days before I can view PAL files.

Martin
OK, but your previous dongle does play the file.

mvallevand
2007-09-14, 03:02 AM
OK, but your previous dongle does play the file.

Right, I have to check and see if the code that was added is now slowing done the demux on high bit rate files.

Martin

mvallevand
2007-09-14, 03:44 AM
The dongle currently is Sept.12 at 3:00. The previously I was using Jul 20. The one on the 12th is the one I'm writting about.

I am running 1.0.16

Tobyo

Thanks, if you have a chance could you try this dongle that has the same code as the 11th without the sync changes. It's not zipped so you might need to click save as.

http://www.mvpmc.org/builds/dongle.bin.mvpmc-20070824

Martin

mvallevand
2007-09-14, 04:22 PM
I have been using the mvpmc dongles for the past 2 months. My MVP with the latest 9/11 dongle seems to lose communication in 2 ways. The first if I ff in a movie more than 3 times and the other is if I watching a video (including live TV) for more than 25 mins.

Regarding the FF problem I tried several files FF'ing 18, 20 time and lots of test with 5+ and I couldn't duplicate this. The only issue was on a file with an SRT. Do you use something extra like SRT or com skip files?

For the 25 minute issue, I've had it on the same live tv station for 1 hr 20 minutest into the fourth 1/2 hour show with no problem so as I suspected there isn't anything special about 25 minutes.

Martin

TobyO
2007-09-14, 10:32 PM
mvallevand,

I don't know what the differents is between the dongles , but everthing works fine. I tried it with 2 movies on each MVP and skipped aroung 20 times each trying to get it to lock up. I plan on testing the blank sceen on the hour for live TV later tonight, I'll let you know how it goes.


Thanks :)
This really enhance GBPVR for me.
Toby

mvallevand
2007-09-15, 05:19 AM
OK, but your previous dongle does play the file.

I've confirmed this problem on a PAL setup and will report it to the mvpmc mailing list.

Martin

Sheik Yerbouti
2007-09-15, 09:12 AM
I've confirmed this problem on a PAL setup and will report it to the mvpmc mailing list.

Martin

Thanks! I hope you get this dongle working, since your talking about solving the AC3 troubles. That would definitly be a reason to use mvpmc permanently.

LewE
2007-10-07, 04:25 PM
I have uploaded a new alpha dongle
Forgive my ignorance but where can I find this file to download?

Nevermind. I found the answer.

mvallevand
2007-10-07, 04:45 PM
Forgive my ignorance but where can I find this file to download?

Nevermind. I found the answer.

I am not recommending this dongle in fact I am going to be coding around this new change, given that I haven't received any positive comments.

Martin