PDA

View Full Version : Vista wakeup



Lindsay
2007-09-16, 11:35 PM
Martin, I now have Vista going to sleep properly but there is a problem with mvpmc waking it up. I seem to need to soft power toggle the mvp to get a WOL sent. The WOL will wake it and pvrx2 comes up fine. If I then put Vista into sleep mode the mvp continues to show the pvrx2 menu but there is no response from key presses. The mvp registers the keys (light flashes) but nothing happens.

As an aside, this behaviour seems to have changed after loading the latest alpha. Previously, if Vista was asleep, I got a loop - loaded and setup mvpmc, showed correct IP# of my server, said "Pinging", went back to start of loop.

NB I am using the latest alpha. I don't power my mvp off in normal operation.

Do I need to pwr toggle my mvp every time?

mvallevand
2007-09-17, 12:27 AM
Martin, I now have Vista going to sleep properly but there is a problem with mvpmc waking it up. I seem to need to soft power toggle the mvp to get a WOL sent. The WOL will wake it and pvrx2 comes up fine. If I then put Vista into sleep mode the mvp continues to show the pvrx2 menu but there is no response from key presses. The mvp registers the keys (light flashes) but nothing happens.

I'm surprised at this behaviour, when Vista shuts down mvpmc should see the sockets die. Maybe the way you are putting Vista to sleep somehow keeps the some part of the connection alive. If you hit Go Back does that work?


As an aside, this behaviour seems to have changed after loading the latest alpha. Previously, if Vista was asleep, I got a loop - loaded and setup mvpmc, showed correct IP# of my server, said "Pinging", went back to start of loop. Nothing changed in this part of the code since 1.0.x


NB I am using the latest alpha. I don't power my mvp off in normal operation.

Do I need to pwr toggle my mvp every time?

The WOL is sent on a reconnect so it will be either from a soft power going into emulation mode on startup or by entering emulation mode from the main menu.

Martin