PDA

View Full Version : Problem with VA on MVP under 1.0.16



ecorbin
2007-09-19, 07:24 PM
Jeff, I just upgraded to 1.0.16 today and installed the beta test version of VA from the wiki. VA is working fine on my PC, but when I try to access it on the MVP, the MVP reboots. Below are the last few lines from MVP-PVRX2.exe:


2007-09-19 13:14:44.671 VERBOSE [6] MVP sending frame
2007-09-19 13:14:44.733 VERBOSE [6] Skinhelper loading image from file: C:\Program Files\devnz\gbpvr\skin\blue\background.jpg
2007-09-19 13:14:44.780 ERROR [6] handleMVPConnection() exception: Object reference not set to an instance of an object.
2007-09-19 13:14:44.780 VERBOSE [6] at ArchiveVideosPlugin.ArchiveVideosTask.render(Boole an& requiresMoreRendering)
at GBPVRX2.MenuTask.xd2a3a83a17aec615.GetRenderList()
at GBPVRX2.MVP.x3ca133dee7547455.x19e39e0d5aeedfb8()
at GBPVRX2.MVP.x3ca133dee7547455.x3d75adb3418c5c9e()
2007-09-19 13:14:44.780 ERROR [6] handleMVPConn

Any thoughts? If more logs are needed, I'll send 'em right away.

Thanks

Edit: Hmmm...VA is not working fine on the PC after all. I can at least open the plugin (unlike on the MVP), but the list of files is not working right. Only the "What's New" shows up. When I press F11 to re-scan, items show up and disappear. If I try to click on one, it disappears when clicked on. After just a few seconds, the list is empty again.

Jeff
2007-09-24, 02:29 PM
I posted a new version last night. Can you give it a try?

Jeff

ecorbin
2007-09-24, 02:40 PM
I have just tried the new version and, unfortunately, that's not working for me. It doesn't even appear in the menu in PVRX2. This seems to be a relevant portion of the pvrx2.exe.log file:


2007-09-24 09:30:51.626 ERROR [1] Error initializing menu plugin: C:\Program Files\devnz\gbpvr\plugins\Jeff\Video Archiver.dll
2007-09-24 09:30:51.626 ERROR [1] Exception has been thrown by the target of an invocation.
2007-09-24 09:30:51.641 ERROR [1] at System.RuntimeTypeHandle.CreateInstance(RuntimeTyp e type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck)
at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache)
at System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache)
at System.Activator.CreateInstance(Type type, Boolean nonPublic)
at GBPVR.Backend.Common.xc4f12ec3a8a4c96b.xd1ccdef346 e6a297(Boolean x8bae2a88590d8cc0)
2007-09-24 09:30:51.641 ERROR [1] Inner exception: System.IO.FileNotFoundException: Could not find file 'C:\Program Files\devnz\gbpvr\skin\archive\BulletBall_red.png' .
File name: 'C:\Program Files\devnz\gbpvr\skin\archive\BulletBall_red.png'
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access)
at GBPVR.Public.SkinHelper.getNamedImageNonCached(Ima ge image, Boolean fillWithBackgroundColour, Color backgroundColour, String name, Hashtable parameters)
at GBPVR.Public.SkinHelper.getNamedImageNonCached(Str ing name, Hashtable parameters)
at GBPVR.Public.SkinHelper.getNamedImage(String name, Hashtable parameters)
at GBPVR.Public.SkinHelper.getNamedImage(String name)
at ArchiveVideosPlugin.ArchiveVideosTask..ctor()
2007-09-24 09:30:51.641 ERROR [1] at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access)
at GBPVR.Public.SkinHelper.getNamedImageNonCached(Ima ge image, Boolean fillWithBackgroundColour, Color backgroundColour, String name, Hashtable parameters)
at GBPVR.Public.SkinHelper.getNamedImageNonCached(Str ing name, Hashtable parameters)
at GBPVR.Public.SkinHelper.getNamedImage(String name, Hashtable parameters)
at GBPVR.Public.SkinHelper.getNamedImage(String name)
at ArchiveVideosPlugin.ArchiveVideosTask..ctor()


On the MVP, the plugin shows up in the menu, but still restarts the MVP when I try to open it. I'm not sure what logs to send you, but I'd be glad to help you test this. Feel free to PM me with a link to any test versions you want me to try to help debug, or any other way I can help!

Thanks,
Eric

Turas
2007-09-24, 04:07 PM
i tried the installer from http://gbpvr.com/pmwiki/uploads/Plugin/VATestVersion.zip
seems that the files are not copied into correct folders for pvxr2 (this should be the version for it?)
- plugin instead of plugin/jeff
- skin instead of skin2

if you try to start videos with blue skin mvp restarts.
using community3 skin let video plugin start correctly.

br turas
---

Jeff
2007-09-24, 04:32 PM
I forgot to include some of the needed skin files in the setup. I've updated the install program and reposted it on the wiki site. You can also grab just the skin files from the attached zip file.

Jeff

Turas
2007-09-24, 07:34 PM
startup is ok now.
thx turas
---

ecorbin
2007-09-25, 03:34 AM
Hmmm...I'm still not having too much luck. Under the old interface (gbpvr.exe), it seems to be working. If I set <mvpserver> to gbpvr.exe in config.xml, it will work on the MVP and it works on the PC if I open gbpvr.exe. So, that's what I'm doing for now...

However, when the MVP is using the PVRX2 interface, "Videos" shows up in the menu, but when I try to go to it, the MVP restarts. Using the PVRX2 interface on the PC, "Videos" doesn't even show up in the menu at all.

All of the above was using the default "Blue" skin, including the additions from above (VAPVRX2BlueSkin.zip). I also tried using the new Community3 skin and got identical results.

I'll be glad to help troubleshoot anything, if you'd like.

Thanks for all your work on this plugin, Jeff!

Jeff
2007-09-25, 05:05 AM
Can zip up and post the log files from the logs and jeff subdirectories?

Thanks

Jeff

ecorbin
2007-09-25, 05:17 AM
Can zip up and post the log files from the logs and jeff subdirectories?

Thanks

Jeff

Here ya go. I'm not sure if I've done anything since the last time it crashed, so if I need to reproduce and immediately zip the logs, let me know. At this point, I've switched back to the old UI, so you'll probably see that in the logs.

THANKS!

ecorbin
2007-09-27, 02:38 AM
I tried the new test version (September 25, 2007) from the wiki, and am experiencing the same thing as before: with GBPVR.exe, it works on the MVP & the PC. With PVRX2, the plugin doesn't show up on the PC. It shows up on the MVP, but the MVP restarts itself when I try to access it.

Sorry -- I hoped the new version would do the trick...

Jeff
2007-09-27, 03:51 AM
Can you zip the entire contents of your gbpvr\logs directory next time you try this and get an error. I didn't see anything in your last set of logs.

Jeff

ecorbin
2007-09-27, 04:06 AM
Attached are zips of my logs and Jeff folders. I cleared both prior to restarting the service and attempting to launch Video Archive, first on the MVP and then on the PC. On the MVP, when I attempt to select "Videos" from the menu, the MVP restarts itself. There is no error message -- just an immediate restart. On the PC, the plugin does not show up at all. There is a section of the file PVRX2.exe.log that begins with "Error initializing menu plugin: C:\Program Files\devnz\gbpvr\plugins\Jeff\Video Archiver.dll". It doesn't make sense to me, but I'm hoping you'll find something useful there.

This is all using the PVRX2 interface. Using the GBPVR interface, I can launch the plugin both on the PC and the MVP.

Thanks for all your work on this!

Jeff
2007-09-27, 06:04 AM
The pvrx2 log shows that it is still missing a skin file (C:\Program Files\devnz\gbpvr\skin\archive\BulletBall_red.png) .

I don't know why it is not looking in C:\Program Files\devnz\gbpvr\skin\blue\archive\BulletBall_red .png

Can you look to see if this file is in the skin\blue\archive folder? it was not included in my original update but was added to the later ones.

Jeff

Turas
2007-09-27, 06:23 AM
isn't pvrx2 looking at C:\Program Files\devnz\gbpvr\skin2\blue\archive\BulletBall_re d.png?

ecorbin
2007-09-27, 02:41 PM
Interesting...the BulletBall_red.png file was in both C:\Program Files\devnz\gbpvr\skin\blue\archive and C:\Program Files\devnz\gbpvr\skin2\blue\archive ...Just for fun, I copied the archive folder from C:\Program Files\devnz\gbpvr\skin\blue to C:\Program Files\devnz\gbpvr\skin and now Video Archive now shows up on the PC and opens. It also now opens on the MVP (doesn't restart the MVP). So, it does seem to be checking the wrong folder for the skin.

I haven't done much testing on it yet, but it seems to be working. The only thing I've found that isn't working is under the "Show Free Space" option, there is no number next to "Pending". Total Space and Free Space both show up fine, but nothing is there for Pending.

UncleJohnsBand
2007-10-06, 12:23 AM
I tried the new test version (September 25, 2007) from the wiki, and am experiencing the same thing as before: with GBPVR.exe, it works on the MVP & the PC. With PVRX2, the plugin doesn't show up on the PC. It shows up on the MVP, but the MVP restarts itself when I try to access it.

Sorry -- I hoped the new version would do the trick...

Same behavoir here.... :(

Jeff
2007-10-06, 02:46 AM
Can you post your pvrx2 logs?

Jeff

UncleJohnsBand
2007-10-08, 01:20 AM
Can you post your pvrx2 logs?

Jeff

Attached.

Jeff
2007-10-08, 03:26 AM
It looks like the problem is a missing skin file for the VA panel. If you are using Blue-MVP as your skin maybe you should copy the panel from the blue skin.


2007-10-07 20:43:04.395 VERBOSE [6] VAPanelDisplay constructor parameter count: 0
2007-10-07 20:43:04.395 VERBOSE [6] Skin file not found: C:\Program Files\devnz\gbpvr\skin\panels\VApanel.xml
2007-10-07 20:43:04.395 VERBOSE [6] ...about to check default skin
2007-10-07 20:43:04.395 VERBOSE [6] Arrrggh!! not found there either...mayday mayday...going down.... C:\Program Files\devnz\gbpvr\skin\Blue-MVP\panels\VApanel.xml
2007-10-07 20:43:04.395 ERROR [6] Error initializing menu plugin: C:\Program Files\devnz\gbpvr\plugins\Jeff\Video Archiver.dll


and also it looks like some of the core image files are missing


2007-10-07 20:43:04.660 VERBOSE [6] file not found: C:\Program Files\devnz\gbpvr\skin\archive\..\_CoreImages\Butt onPopup_Normal.png
2007-10-07 20:43:04.660 VERBOSE [6] Skinhelper loading image from file: C:\Program Files\devnz\gbpvr\skin\archive\..\_CoreImages\Butt onPopup_Normal.png
2007-10-07 20:43:04.660 ERROR [6] Error initializing menu plugin: C:\Program Files\devnz\gbpvr\plugins\Jeff\Video Archiver.dll


Jeff

UncleJohnsBand
2007-10-10, 01:44 AM
It looks like the problem is a missing skin file for the VA panel. If you are using Blue-MVP as your skin maybe you should copy the panel from the blue skin.


2007-10-07 20:43:04.395 VERBOSE [6] VAPanelDisplay constructor parameter count: 0
2007-10-07 20:43:04.395 VERBOSE [6] Skin file not found: C:\Program Files\devnz\gbpvr\skin\panels\VApanel.xml
2007-10-07 20:43:04.395 VERBOSE [6] ...about to check default skin
2007-10-07 20:43:04.395 VERBOSE [6] Arrrggh!! not found there either...mayday mayday...going down.... C:\Program Files\devnz\gbpvr\skin\Blue-MVP\panels\VApanel.xml
2007-10-07 20:43:04.395 ERROR [6] Error initializing menu plugin: C:\Program Files\devnz\gbpvr\plugins\Jeff\Video Archiver.dll
and also it looks like some of the core image files are missing


2007-10-07 20:43:04.660 VERBOSE [6] file not found: C:\Program Files\devnz\gbpvr\skin\archive\..\_CoreImages\Butt onPopup_Normal.png
2007-10-07 20:43:04.660 VERBOSE [6] Skinhelper loading image from file: C:\Program Files\devnz\gbpvr\skin\archive\..\_CoreImages\Butt onPopup_Normal.png
2007-10-07 20:43:04.660 ERROR [6] Error initializing menu plugin: C:\Program Files\devnz\gbpvr\plugins\Jeff\Video Archiver.dll
Jeff

Well....I tried a couple of things but it appears it is looking for files in folders that don't exist (panels in blue-mvp)....I am using blue-mvp and pvrx2 which means all skins should come from the skin2 directory.....I am seeing entry request for folders in the root of skin (old gbpvr directory) and being in the root it is not using a skin name....

I'll just hold off until this skin thing gets straightend out. I really love the archiver.....I'll just have to wait some more until this all gets worked out.....:(

Jeff
2007-10-10, 04:42 AM
Even though you are using pvrx2, the VA plug-in is still using the old UI mechanism, which means its skins come from the skin folder tree, not skin2. If you copy the skin files into skin\blue-mvp\... instead of skin2\blue-mvp\... that should fix your problem.

Jeff

UncleJohnsBand
2007-10-13, 03:36 AM
Even though you are using pvrx2, the VA plug-in is still using the old UI mechanism, which means its skins come from the skin folder tree, not skin2. If you copy the skin files into skin\blue-mvp\... instead of skin2\blue-mvp\... that should fix your problem.

Jeff

I have copied over the panels, archive and _Coreimages from blue to the blue-mvp directory under gbpvr\skin....still crashes.....I am recording now so I don't want to recreate to get the logs.

I'll post them when I get a chance.

UncleJohnsBand
2007-10-13, 10:07 PM
I have copied over the panels, archive and _Coreimages from blue to the blue-mvp directory under gbpvr\skin....still crashes.....I am recording now so I don't want to recreate to get the logs.

I'll post them when I get a chance.

Attached are the logs.....I had to copy common dialogs and main menu folders to get further in the process....

After doing that I could get in and got a please wait message....then nothing...restarted and got a message about a newer version of the archiver....

dowloaded beta version from 10/8 and now when I go into archiver there is a long pause and it never makes it to the opening screen for archiver and the MvP crashes....

logs attached....