PDA

View Full Version : New alpha dongle Dec 28.



mvallevand
2007-12-29, 12:42 AM
I've updated the alpha dongle with a minor change so those with the older remote could benefit a bit from hot keys. The following Go + Keys are new I tried to match a letter to the function

Go Chan Up Previous Channel

Go 4 G - Guide
Go 5 L - Live TV
Go 6 M - Music
Go 7 P - Pictures
Go 8 V - Videos
Go 9 - Radio

Although I didn't make any other changes from the previous alpha I tested this for two hours straight with video and livetv and was severe on the remote and I could not duplicate the dead remote. I checked my logs and I hit the remote 952 times

Martin

Lindsay
2008-01-02, 12:06 AM
Hi, Martin, still working hard, I see!

Did you find a likely culprit for the dead remote problem? I sure was getting the problem but haven't had a chance to try this latest version. Fingers crossed for a solution. You would be glad to see the end of it I bet.

Thanks again for your superb work.

Lindsay.

mvallevand
2008-01-02, 12:46 AM
No, and there might not even be problem in emulation mode logic. SageTV says there is a Vista problem impacting both their MVP and HD Extender that even SP1 won't fix. Do you run the Vista fix that turns of the TCP autotuning?

Arne's logs are great, but I have to write a utility to convert the time there is a 12 second difference between the three logs but to be honest for the last few days I have been distracted with my new toy. It does looks like the data arrives when mvpmc sends it.

Martin

Lindsay
2008-01-02, 10:54 PM
That's interesting re the TCP auto tuning. No, I have not turned it off. If I get the freeze again I will try this. I am somewhat reluctant to do this, however, as it will probably drop the speed to my ISP. Vista is WAY more efficient than XP. For example, I get 4200 kbps with Vista and around 2800 kbps under XP.

Cheers,
Lindsay.

mvallevand
2008-01-02, 11:08 PM
I didn't see any change at all with the Internet speeds and it stayed faster than xp for me too. I consider it a painless test, it doesn't even require a reboot.

Martin

Lindsay
2008-01-03, 08:16 AM
You are quite right - as usual! No difference at all. Wonder what it is for, then??

Keep you posted.

Lindsay.

HtV
2008-01-03, 09:38 AM
I run xp, I remember running a little program called TCPOptimiser, that improved my internet connection with at least 25%. Could be that vista is doing a better job from the start.

Hans

JonRoyle
2008-01-05, 04:30 PM
I finally got chance to do some testing and with the latest MVPMC software I am still getting the dead remote. Observations is that this happens only after I am quite a way into the programme. All remote pressess for the first 15mins or so are promptly responded to but not toward the end of the programme. Also when the programme completes play and returns to the menu I am not able to navigate it. I will continue to do some more testing but attached are the (I hope) relevant logs uses Subs debug version of PVRX 2.exe.

Jon

mvallevand
2008-01-05, 04:49 PM
Sub I've the same question I asked here because I found the same situation

http://forums.gbpvr.com/showpost.php?p=246244&postcount=64

In the server side log, when the problem occurred I noticed a message on the rfb stream that I don't recognize, DisplayStillInUse. What is this message?

It's possible that mvpmc isn't returning something gbpvr wants and so gbpvr stops processing the gui stream.

Martin

Lindsay
2008-01-08, 08:06 AM
Martin, in spite of disabling the TCP variable feature I am still getting frequent MVP hassles. I have had lockups during net radio sessions, live TV channel changes and video playback file skips.

Interestingly, I am seeing plenty of 'DisplayStillInUse' messages as reported above.

Problem times are 1659, 1718, 1740 and 1745. Logs attached.

Lindsay.

mvallevand
2008-01-08, 11:24 PM
Lindsay,

Since none of these are the dead keyboard problem and I don't think they are necessarily mvpmc related either I don't see it as bad as it sounds

1. for the Internet radio problems, I don't see any attempt to contact mvpmc on the media stream [7] My first instinct is the recording service isn't able to get the data to create the temp file. however if you look at the logs I notice the Shoutcast text data logged. I don't know how the Shoutcast parser works, but I now am speculating that this is a problem with this stream..

2. Live starts really breaks starting at 17:17:15.229 I don't know if the client or server is at fault, but there definitely is a missing end of stream from the server for Flight 29 which for now will lock mvpmc if a new media stream starts.

3. Here is one log snippet for sub to review

2008-01-08 17:45:13.738 VERBOSE [7] Request completed. 200000 bytes sent
2008-01-08 17:45:13.740 VERBOSE [6] MVP data read: 1 (9)
2008-01-08 17:45:13.740 VERBOSE [6] MVP request processed
2008-01-08 17:45:13.740 VERBOSE [6] MVP waiting for data
2008-01-08 17:45:13.740 VERBOSE [6] MVP data read: 1 (7)
2008-01-08 17:45:13.740 VERBOSE [6] Got ACK

a. mvpmc would have send a request to read right here on the media stream. There is no blocking in the mvpmc code and the pings are working fine so think it networking is working
...
2008-01-08 17:45:31.599 VERBOSE [6] DisplayStillInUse
b. Interesting
...

2008-01-08 17:45:43.888 VERBOSE [7] Request 200000 bytes (file size:1933850496 file location: 70274353)

c. Finally the data gets read. The fact that the timeout issue often seems to be thirty seconds might be relevant to Vista problems

4. Sub, there's another new log message that I'd like explained if you have time.

VERBOSE [7] MVP media connection recycle requested

Martin

Lindsay
2008-01-14, 01:20 AM
Martin, I have been experimenting a bit since my last problem report. I am now of the opinion that Vista owners should disable the TCP auto tuning. I think the data stream to the MVP was not being handled properly. The sure sign of this was the micro pauses I was getting in Live TV. These seem to have gone now and I can't get the channel changes to mess up and the Net Radio station changes seem reliable as well.

I can't be sure just yet that my system is completely cured but I can live in hope! But since there are no disadvantages to switching off the auto tuning, we may as well do it. There are many reports of problems with routers as well.

I have switched both auto tuning and rss off. I think both are necessary for me.

In case others are interested, at the command prompt, with admin privileges, execute these commands.

netsh interface tcp set global autotuninglevel=disabled
netsh interface tcp set global rss=disabled

The first cmd can be reversed by replacing disabled with normal. The second, use enabled instead of disabled.

This cmd displays the status

netsh interface tcp show global

Interested in feedback, folks.