PDA

View Full Version : WOL Trouble



gms
2008-01-27, 11:23 PM
I'm having trouble getting wake on lan to work with the mvpmc dongle & could use some advise on where to start looking for a solution. I'm using the recommended dongle (Nov '07 I think) with a basic config file - mvpmc --startup emulate --emulate xxx.xxx.xxx.xxx &

MVPMC says it is "sending WOL" and pinging the server, but returns to the main mvpmc screen after multiple unsuccessful attempts.

This is very strange since I can telnet to the MVP from another PC and and wake the server from S3 using the ether-wake xx:xx:xx:xx:xx:xx MAC command I found in the forum. I can also wake it up by sending a magic packet directly from another pc.

Is it possible that the MVP has the wrong MAC address for the server? How can I check that? Is there something additional needed in the config file? Are there any troubleshooting steps I can take? Note: I am NOT linux literate so any suggested telnet commands will need to be pretty explicit.

gms
2008-01-27, 11:54 PM
I telneted to the mvp & entered the cat /etc/tftp.config command. The response provided me with the correct ip adress of the server (192.168.123.xxx) but the MAC address of the MVP (00:0D:FE:03:02:xx).

mvallevand
2008-01-28, 12:17 AM
When you start mvpmc for the first time does it enter into emulation mode properly? That is were it stores the mac address.

Unfortunately to test this could be a challenge. Do you have more than one PC? That will make it easier.

Martin

gms
2008-01-28, 01:49 AM
Emulation mode starts fine. When the gbpvr server is up, mvpmc boots into pvrx2 in a couple of seconds.

I have another pc I can use to test.

mvallevand
2008-01-28, 02:11 AM
Ok, to test this, with a telnet from the other machine issue these two commands

killall mvpmc

mvpmc (with all your normal options)

Go to your tv and exit emulation mode to the main mvpmc menu with Go Back and power off your gbpvr server. Once it is off go back into emulation mode

Your telnet screen should show the mac address with a line like

"Emulation server mac address is xxx" This is what is passed to ether-wake.

Martin

gms
2008-01-28, 03:11 AM
Seems simple enough. Unfortunately, it's past my bedtime & she who must be obeyed is recording Masterpiece Theater on the server. I'll give it a try tomorrow.

Thanks for your help.

ww4397
2008-01-28, 05:53 PM
MVPMC says it is "sending WOL" and pinging the server, but returns to the main mvpmc screen after multiple unsuccessful attempts.



I'm follwoing this thread with interest. I've had the same problem, and powered down both the GBPVR server and the MVP and then restarted. All was well after that.

gms
2008-01-28, 11:42 PM
I don't know what to say. After following your instructions, telnet came up with the correct MAC. I rebooted everything, put the server to sleep, turned on the MVP & WOL worked! I did it five times to make sure it wasn't a fluke. I can't tell you how many times I went through the same reboot process before posting. Maybe the killall command flushed something out of the system. At least now I know how to troubleshoot the problem if it reoccurs.

I almost wish it didn't miraculously fix itself so I'd know what the problem was.

Thanks for your help Martin.

mvallevand
2008-01-29, 12:28 AM
Thanks, this was a tough one! Seriously whatever caused it to work wasn't killall mvpmc but I'm glad that you can be a little "greener" now.

Martin

HarryH3
2008-02-14, 02:56 AM
Reviving this thread... :( I have two MVP's on my 100Mb wired LAN. I have the NIC in my server set to wake up when it gets a magic packet, and it does this beautifully when I send the magic packet from another PC on the LAN. However I can't get either of the MVP's to wake the server. Is there a difference between what magic packet and ether-wake (which I think is what mvpmc uses) send onto the net to wake the server?

Using Wireshark, I can see the MVP sending out a WOL request and the MAC is the correct one for the NIC in my server.

One oddity noted. The settings for the "Wake Up Capabilites" for my NIC have "Magic Frame" or "Wake Up Frame", but when I select "Wake Up Frame" the system wakes up within 2 seconds of going into standby. When I select "Magic Frame" it stays in standby until I send the magic packet from another PC. (NIC is a built-in Broadcom 440x 10/100)

Any ideas?

mvallevand
2008-02-14, 04:19 AM
I'm not an export on WOL in fact if it wasn't for OscarL's help it probably wouldn't work for anyone, but I wanted to confirm mvpmc uses the ether-wake that is built into busybox. This protocol is supposed to wake a machine from S3 state so if you hibernate to disk (S4) you might have a problem

Martin

HarryH3
2008-02-14, 01:37 PM
I'm just using S3 standby mode, as hibernate takes much longer to come back to life. When I send the system a wake up command using the Magic Packet app from http://www.depicus.com/wake-on-lan/wake-on-lan-gui.aspx it springs to life instantly. But it seems that my NIC ignores the request from ether-wake. I suppose there is some difference in the protocol that each uses to send the request.

I think that the Spanning Tree Protocol requests on my LAN cause the NIC to wake up instantly when I change the NIC's setting to Wake Up Frame the system won't stay in standby at all. I wonder if ether-wake is sending out that type of WOL instead of the Magic Packet?

Ain't technology grand! ;)

Dava
2008-06-21, 02:15 PM
I telneted to the mvp & entered the cat /etc/tftp.config command. The response provided me with the correct ip adress of the server (192.168.123.xxx) but the MAC address of the MVP (00:0D:FE:03:02:xx).

Hi,
I have an issue where I have built a new gbpvr machine and the MVP seems to be stuck looking at the old one for WOL. The old one does not start any MVP servers but still has the recording service running.

using:

cat /etc/tftp.config

shows the old server details however if the new HTPC is on, the MVP does boot up.

How do I change these settings? ISTR that you had to use the original Hauppauge utilities to commit to NVRAM. Is this still the case?

mvallevand
2008-06-21, 02:35 PM
You have to use the Hauppauge dongle and if you don't have a revision H MVP you will have to start their server too (disabling the GBPVR Recording Service).

When you power up you should be see a table with the IP you want, select it and that updates the flash. You don't need to go to the Setup screen.

Martin

Dava
2008-06-21, 04:33 PM
Thanks for the quick response. I have a rev D by the looks of the bottom so will try your suggestion.