PDA

View Full Version : Problem playing ISO after playing MKV



dirkomatic
2008-05-10, 03:18 AM
I have some short videos in HD MKV format that I hadn't tried playing with GB-PVR yet. I finally got around to it... They played fine when I selected them, but after watching an MKV clip, I tried to watch a DVD ISO and it returned to the Video Library screen without playing the movie.

I exited GB-PVR and attempted the same thing just using the standard PCH software and it worked just fine.

Is there anything I can do to play both formats without restarting GB-PVR?

Thanks.

sub
2008-05-10, 03:34 AM
Reproduce the problem, then zip and attach the logs and I'll take a look.

dirkomatic
2008-05-10, 04:19 AM
Here you go. I played the MKV, stopped, then played the ISO and I got the Popcorn logo. It never went any further. I pressed stop, got a black screen, then pressed the power and exited GBPVR.

It went back to the PCH home screen.

16722

sub
2008-05-10, 04:40 AM
I dont think you managed to capture it in those logs. Have you got your mvp server count to something more than '1'? If so, you'll need to drop it back to '1' then reproduce the problem and repost the logs.

dirkomatic
2008-05-10, 04:58 AM
I have an istar and a popcorn, so it is set to 2. I set it to 1 for this capture.

I see my attempt to play the ISO near the bottom of MVP-PVRX2.exe-1.log in this one...16723

sub
2008-05-10, 05:03 AM
Everything looks ok in the GB-PVR side of your logs.

You might need to run mvpmcx2 from a telnet session and capture the output.

mvallevand
2008-05-10, 05:03 AM
I just did a quick test and I think there is a problem in mvpmcx2 which I will have to look into over the weekend.

Martin

dirkomatic
2008-05-10, 05:06 AM
Thanks, Martin.

Can one of you post what I need to do to capture the output in a telnet session?

It is late (early?) here and I need to get to bed. Hopefully, I can help troubleshoot a little later.

dirkomatic
2008-05-10, 11:11 PM
Thanks, Martin!

The new version solved this. Wonderful job!

Although, the new screen saver option takes me to the Net Radio screen when playing music from my Music Library. Kind of strange...

mvallevand
2008-05-10, 11:20 PM
Although, the new screen saver option takes me to the Net Radio screen when playing music from my Music Library. Kind of strange...

For --no-nmt-gui I do tell it to go to the Net Radio Screen, otherwise GBPVR didn't do a screen refresh, but it shouldn't impact --nmt-gui-ss. Did you download a new version since UJB's post about the problem?

Martin

dirkomatic
2008-05-11, 12:55 AM
I guess I got it before UJB's post. I'll give this newer one a try. Thanks!