PDA

View Full Version : 'Slimm GB-PVR Helper error'



Safwaan
2008-12-14, 03:05 PM
Hi Guys

I've got a slight problem with GB-PVR or Slimm GB-PVR, when the computer is loading up after a restart a window with an error message pops up:

'Slimm GB-PVR Helper error, Could not start GB-PVR Recording service'

The recording service is definitely running. I have uninstalled Slimm GB-PVR and then re-installed it but the error still pops up. I have completely uninstalled GB-PVR and reinstalled it from scratch but the error message still pops up.

I've had a look through the logs and I think this line in the log may have something to do with it:

[2008-12-14 13:56:02.317 ERROR [4] Exception whilst restarting recording service
System.InvalidOperationException: Cannot start service GB-PVR Recording Service on computer '.'. ---> System.ComponentModel.Win32Exception: An instance of the service is already running]

I've attached the full log, has anyone come across this error before I have searched the forums but I couldn't find anything.

I've been running GB-PVR on my XP pc for over a year and this has never come up I've just installed GB-PVR on my Vista pc and it pops up everytime I turn the computer on or when I restart it.

Any help would be appreciated

Mister Slimm
2008-12-15, 10:04 AM
Hi Guys

I've got a slight problem with GB-PVR or Slimm GB-PVR, when the computer is loading up after a restart a window with an error message pops up:

'Slimm GB-PVR Helper error, Could not start GB-PVR Recording service'

The recording service is definitely running. I have uninstalled Slimm GB-PVR and then re-installed it but the error still pops up. I have completely uninstalled GB-PVR and reinstalled it from scratch but the error message still pops up.

I've had a look through the logs and I think this line in the log may have something to do with it:

[2008-12-14 13:56:02.317 ERROR [4] Exception whilst restarting recording service
System.InvalidOperationException: Cannot start service GB-PVR Recording Service on computer '.'. ---> System.ComponentModel.Win32Exception: An instance of the service is already running]

I've attached the full log, has anyone come across this error before I have searched the forums but I couldn't find anything.

I've been running GB-PVR on my XP pc for over a year and this has never come up I've just installed GB-PVR on my Vista pc and it pops up everytime I turn the computer on or when I restart it.

Any help would be appreciated

Is the message in a balloon or a window?

Mister Slimm
2008-12-15, 10:19 AM
I've done a small update, try downloading this (http://mrslimm.googlepages.com/SlimmGBPVRSetup.exe) and trying again.

b00sfuk
2008-12-16, 06:58 PM
I'm going to try this version as well. I wrote in the wishlist thread about trying to suppress these messages (windows not popups) as they occur occasionally on reboots/wake and there never seems to be a problem with the tuner or recording service.

thanks

Mister Slimm
2008-12-16, 08:33 PM
I'm going to try this version as well. I wrote in the wishlist thread about trying to suppress these messages (windows not popups) as they occur occasionally on reboots/wake and there never seems to be a problem with the tuner or recording service.

thanks

Yeah, I responded to that...

HarryH3
2009-01-27, 05:24 PM
I just downloaded and installed this patched version. I don't get the window any longer, it seems to have just changed the message to a balloon popup. Is there a setting somewhere to change how long Slimm GB-PVR waits before checking the tuner status during a restart? It seems to check too quickly for my PC. On nearly every restart I get the "service not started" message, but the service does start and work fine. If I could add another second or two before the check I think all would be well. :)

Mister Slimm
2009-01-27, 05:33 PM
I just downloaded and installed this patched version. I don't get the window any longer, it seems to have just changed the message to a balloon popup. Is there a setting somewhere to change how long Slimm GB-PVR waits before checking the tuner status during a restart? It seems to check too quickly for my PC. On nearly every restart I get the "service not started" message, but the service does start and work fine. If I could add another second or two before the check I think all would be well. :)

Is this when coming out of standby or when starting the machine for the first time or restarting? If it is from start or restart, you can employ a startup delayer to delay items as you need them. Though if you do use one of these, you'll need to uncheck the startup options in Slimm GBPVR's configuration as it will automatically put itself back in the Startup folder if it's not there.

HarryH3
2009-01-27, 08:25 PM
It's when I restart the recording service. After watching it closely, I think it has something to do with MVPTrayIcon.dll loading on the restart. That dll lets me monitor MVP activity from my PC, so I don't reboot while someone is watching something via one of the two MVP's in other rooms. Perhaps that dll is delaying things just enough so that Slimm GB-PVR doesn't see the recording service started in time?

I nearly always get the warning, but the recording service does restart and all is well.

BTW, Slimm GB-PVR Rocks! :)

Mister Slimm
2009-01-28, 01:48 PM
It's when I restart the recording service. After watching it closely, I think it has something to do with MVPTrayIcon.dll loading on the restart. That dll lets me monitor MVP activity from my PC, so I don't reboot while someone is watching something via one of the two MVP's in other rooms. Perhaps that dll is delaying things just enough so that Slimm GB-PVR doesn't see the recording service started in time?
Please could you zip up your logs or let me know how many times Slimm GB-PVR is trying to restart the recording service?

To zip up the logs, go to Slimm GBPVR/Tools/Report Error.
Or to find the information yourself in the logs, goto Slimm GBPVR/Tools/Tray Configuration/Logging/View Current Log and look for "has GB-PVR recording service crashed? IsRunning=". I want the highest ever number after the equals sign.


BTW, Slimm GB-PVR Rocks! :)

Thanks!

HarryH3
2009-01-28, 03:32 PM
All I see is "has GB-PVR recording service crashed? IsRunning=True" and something about count=0. Logs attached for your review. :-)

Thanks!

Mister Slimm
2009-01-28, 04:49 PM
Thank you. I've altered how the auto-restart recording service logic works and, if i've done my sums correctly, you shouldn't get any warning or action now unless the recording service running check fails five times.

Download Slimm GBPVR (http://mrslimm.googlepages.com/SlimmGBPVRSetup.exe).

Please let me know if it has worked.

HarryH3
2009-01-28, 08:44 PM
GB-PVR Recording Service restarted successfully. :-) :-) :-)

Excellent (and FAST!) work. :-)

Thanks!

Mister Slimm
2009-01-28, 09:07 PM
So, no balloon?

HarryH3
2009-01-29, 01:55 AM
There is a balloon, but it is a happy balloon that says "GB-PVR Recording Service restarted successfully". :)

HarryH3
2009-01-31, 09:07 PM
I put GB-PVR in Maintenance Mode to install a PVRX2 patch. On restart, I got the popup box telling me that the recording service wasn't started (but it was running). Does the restart function in Maintenance Mode call a different set of restart code than the "restart recording service" link calls?

No biggie, but just thought I'd mention it while the fix is fresh in your mind. ;)

Mister Slimm
2009-01-31, 11:15 PM
I put GB-PVR in Maintenance Mode to install a PVRX2 patch. On restart, I got the popup box telling me that the recording service wasn't started (but it was running). Does the restart function in Maintenance Mode call a different set of restart code than the "restart recording service" link calls?

No biggie, but just thought I'd mention it while the fix is fresh in your mind. ;)

Um, no, it's the same restart function and should have displayed the same "service restarted successfully balloon."

I just tried it on mine. I entered Maintenance Mode, then unchecked Maintenance Mode. Then I entered Maintenance Mode, then Tools/Restart recording service. Both displayed the "service restarted successfully" balloon.

If, by restart, you mean you restarted the computer, then Slimm GBPVR performs two checks when it first runs. These are a separate check to the auto-restart-service feature. I suspect you saw the first balloon because auto-restart-service is disabled by Maintenance Mode and you have to turn it back on by unchecking Maintenance Mode.


If the recording service is not running and auto-restart is disabled when Slimm GVPVR is run then the balloon reads: "The recording service is not running. You can restart the recording service from the Tools menu by selecting the Restart Recording Service option or by unchecking Maintenance Mode."
If the recording service is running but auto-restart-service feature is disabled the balloon reads: "Auto-restart recording service not active. You can enable this feature by unchecking Maintenance Mode on the Tools menu."

HarryH3
2009-02-01, 01:38 PM
I didn't restart the PC, just the service. I had entered maintenance mode to replace pvrx2.exe with a patched version. Afterwards I just selected maintenance mode again and the service restarted, but I got the popup window saying something about the service not running, even though it was. Alas, I just tried entering and exiting maintenance mode again and everything worked fine, so I'm at a loss to explain it now. :(