PDA

View Full Version : Nlite being blocked until NPVR service is restarted



lost@c
2017-09-08, 07:05 PM
I've been using NLite on and off since it first came out and I really like it. However I have this pesky issue that prevents me from using it more.

If NextPVR has been on for a while, NLite will not connect to it. Even a PC reboot (which I do automatically daily) will not resolve it. However a "Stop" and "Start" of the recording service fixes it every time. I can see from the NLite output that "Found server, but login failed". When it fails I see a white screen box where NextPVR would normally show

Attached is the NLite output before the service restart and after the service restart as well as the other logs. I tried this all around 06:50.

sub
2017-09-08, 07:28 PM
Was nlite on Windows or Linux/Other?

lost@c
2017-09-08, 07:33 PM
It's on a Win 7 machine

sub
2017-09-08, 09:57 PM
It seems to be something to do with the IP address being detected: (IPv4 vs IPv6)

curl_easy_perform(http://10.1.1.3:8866/services/service?method=session.initiate&ver=1.0&device=sdl)

vs

curl_easy_perform(http://fe80:75/services/service?method=session.initiate&ver=1.0&device=sdl)

If you run nlite with the following command line, does it work?

nlite.exe -server 10.1.1.3:8866:0000

(where 0000 is the pin)

lost@c
2017-09-09, 01:52 AM
I'll need to wait till next time it won't connect (probably tomorrow morning then I'll test and let you know.

lost@c
2017-09-09, 07:07 PM
"If you run nlite with the following command line, does it work?

nlite.exe -server 10.1.1.3:8866:0000

(where 0000 is the pin) "

Yes it does. Happy to use that command to access it. Thanks Sub :)

sub
2017-09-20, 04:32 PM
Great!