Page 11 of 13 FirstFirst ... 910111213 LastLast
Results 101 to 110 of 122

Thread: pvr150 picture quality

  1. #101
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    90,876
    Take a look at your untitled-b.jpg screenshot. Can you click the 'video decoder settings' button, then post a screenshot of that screen?

    You probably also want to remove the 'Use FFDShow post-processing' setting while you're trying to get to the bottom of this.

  2. #102
    ya it was a mistake, i noticed after i posted it, check it now

  3. #103
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    90,876
    Can you first try setting it to 'force bob' in the decoder settings. If that doesnt work, leave it on force bob and also try disabling hardware accelleration.

  4. #104
    ill try it later as i'm on my way out, thanks for the time though

  5. #105
    Join Date
    Dec 2005
    Location
    Ireland
    Posts
    214
    Quote Originally Posted by Chris.Day
    By default, the Hauppauge Intervideo codecs don't use DXVA.
    Right. Okay I changed the directX file back to version 9.0b and that fixed the problem with the PureVideo. Thanks. BTW: Whoever added the replacer.cmd utility to the wiki.. well done. Much easier than having to reboot in safe mode and very handy for remote admin. Windows AutoUpdate mode is now disabled!

    Now... if I could get my football games to look good... I would be a very happy man! Very slow motion frames look as good as via the TV, but when the camera pans quickly.. it all get a bit fuzzy/grainy. I am using an ATI 9550, with the latest drivers, PureVideo set to VMR9 default, and the ATI card set to video mode (resolution matching PAL) as recommended in an earlier post.. but it is still not as good as via TV. I have also played around with the shaprness settings on the encoder (PVR-150) with the hauppauge tweak utility. I guess svideo out to a CRT SDTV is the problem?
    AMD Sempron 3000, XP Home SP3, Maxtor 200GB SATA, 512MB, PVR-150, NOVA-T-500, ATI 9550, Silverstone LC13

  6. #106
    Join Date
    Jul 2005
    Location
    Christchurch, New Zealand
    Posts
    494
    @Jep4444

    Just to expand on how LiveTV works, - when you go into GBPVR config, Misc tab, you will notice the settings for "Live Preview Mode". This determines how LiveTV works.

    When "Live preview Mode" is unticked, then LiveTV is operating in timeshift mode. This means the TV capture card is encoding the video into MPEG2 and recording to the harddrive, to which the harddrive is buffering, then the software decoders are reading the recording off the harddrive, decoding the MPEG2 and forwarding to the renderer (VMR9/VMR7/Overlay) which places the video frames into the video card memory for display.

    When "Live Preview Mode" is ticked, and de-interlacing method is "encoder pass-through", then it is the same as above except the hardrive buffering is skipped, ie the encoder output is directly coupled to the decoder input.

    When "Live Preview Mode" is ticked, and de-interlacing method is "none", then the raw captured video (interlaced) is fed directly to the renderer, ie skipping then encoder and decoder. This means the display is showing all the interlacing artifects.

    When "Live Preview Mode" is ticked, and de-interlacing method is "Alparysoft deinterlace filter", then the raw captured video (interlaced) is fed directly to the renderer via Alparysoft de-interlacing, PROVIDING Alparysoft is installed.

    When "Live Preview Mode" is ticked, and de-interlacing method is "FFDSHow raw video filter", then the raw captured video (interlaced) is fed directly to the renderer via FFDShow de-interlacing, PROVIDING FFDShow is installed and the "raw video filter" option of FFDShow was also installed. Caution, by default FFDShow is transparent and does nothing, and you have to manually configure FFDShow to perform de-interlacing.

    So in conclusion, if you have "Live Preview Mode" ticked and you are not using "encoder pass-through", then you are not using any video decoder, and hence the video decoder itself and its settings are irrevelent.

    Now, the video card de-interlacing (hardware de-interlacing) is only works if you are using a software video decoder in combination with hardware acceleration enabled, and VMR rendering. So it is only works in timeshift mode or Live Preview Mode with Encoder Pass-through.

    And finally, the Cyberlink video decoder settings do not work in GBPVR Config "Video Decoder Settings". Changing those settings on the Cyberlink decoder will not make any changes to the decoder itself. the Cyberlink decoder has to be manually configured in the registry. The Registry settings for the Cyberlink video decoder are:

    [HKEY_LOCAL_MACHINE\SOFTWARE\CyberLink\Common\CLVSD]
    "UIUseHVA"=dword:00000001
    "EnableVMR"=dword:00000001
    "EnableVMR9"=dword:00000001
    "PV_FOR_MCE"=dword:00000001
    "TwinViewDXVA"=dword:00000001

    [HKEY_CURRENT_USER\Software\Cyberlink\Common\CLVSD\ GBPVR]
    "UIUseHVA"=dword:00000001
    "EnableVMR"=dword:00000001
    "EnableVMR9"=dword:00000001
    "PV_FOR_MCE"=dword:00000001
    "TwinViewDXVA"=dword:00000001
    AMD Athlon X2 4200+ CPU, Gigabyte GA-MA770-DS3 mobo, 2GB RAM, 1TB SATA HDD, DigitalNow Dual Hybrid PCIE S2 and Hauppauge HVR2200 capture, ATI HD4670 video with HDMI-HDMI to 32" LCD TV at 1360x768, Win7 Home Premium 64bit, GBPVR 1.4.7, EVR renderer

  7. #107
    Join Date
    Jul 2005
    Location
    Christchurch, New Zealand
    Posts
    494
    @danIrl,

    I suggest using Graphedit and open lastgraph.grf in the GBPVR program directory to see if the Purevideo decoder is actually being used.
    (note when the trial-key expires or you re-install Purevideo with the trial-key for a second time, then the Purevideo filter is available however its output pin is disabled, resulting in DirectShow falling-back to a differnet decoder).

    And just confirming Purevideo config:
    Harware Acceleration ticked,
    Deinterlace Control: Automatic
    Deinterlace method: VMR Default
    (note VMR Default will be shown but not necessarily applied, so you have to actually click "OK" to apply this setting)

    I have no other ideas, sorry.
    AMD Athlon X2 4200+ CPU, Gigabyte GA-MA770-DS3 mobo, 2GB RAM, 1TB SATA HDD, DigitalNow Dual Hybrid PCIE S2 and Hauppauge HVR2200 capture, ATI HD4670 video with HDMI-HDMI to 32" LCD TV at 1360x768, Win7 Home Premium 64bit, GBPVR 1.4.7, EVR renderer

  8. #108
    Join Date
    Dec 2005
    Location
    Ireland
    Posts
    214
    Hi Csy,

    Yes settings are as you suggest. LastGraph reports that Purevideo decoder is being used. I am actually using the Retail version, which is older that the trial version! (v150 I think)
    AMD Sempron 3000, XP Home SP3, Maxtor 200GB SATA, 512MB, PVR-150, NOVA-T-500, ATI 9550, Silverstone LC13

  9. #109
    as to subs suggestion, it didn't work but now instead of getting an interlaced picture, the picture shakes when i move in the game and because of encoder pass through also lags once again making games unplayable

    today i booted up WinTV32(i dont know how to turn on composite source in 2000, i prefer 32s interface anyways) and it doesn't interlace or shake but it does lag

    finally i dont know how to edit my registry to enter what you told me to csy, i can use intervideo decoder if it doesnt involve registry editing aswell

    PS just tested intervideo and their is no interlacing happening there either

    also if i were to use FFDShow(its installed), how would i configure it?
    Last edited by Jep4444; 2006-07-10 at 03:07 PM.

  10. #110
    Join Date
    Jul 2005
    Location
    Christchurch, New Zealand
    Posts
    494
    Quote Originally Posted by Jep4444
    i dont know how to edit my registry to enter what you told me to csy, i can use intervideo decoder if it doesnt involve registry editing aswell
    Copy the registry entries (incl the bracket lines) to notepad and save it. Then change the file extension to .reg, and double-click on it.

    Note the registry entries I showed, enable DXVA and VMR on the Cyberlink decoder. The de-interlacing is enabled by default.

    Intervideo need to be configured via the registry as well. It also has de-interlacing enabled by default, but again does not have DXVA or VMR enabled by default.


    also if i were to use FFDShow(its installed), how would i configure it?
    FFDShow is relatively complex, and I would not recommend it to a beginner. I recommend downloading and installing the Alparysoft de-interlace filter, which works without any configuration.

    I also agree with Sub, that GBPVR is not designed for real-time gaming, and may not be suitable for what you are trying to achieve.
    AMD Athlon X2 4200+ CPU, Gigabyte GA-MA770-DS3 mobo, 2GB RAM, 1TB SATA HDD, DigitalNow Dual Hybrid PCIE S2 and Hauppauge HVR2200 capture, ATI HD4670 video with HDMI-HDMI to 32" LCD TV at 1360x768, Win7 Home Premium 64bit, GBPVR 1.4.7, EVR renderer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •