Page 3 of 13 FirstFirst 12345 ... LastLast
Results 21 to 30 of 122

Thread: pvr150 picture quality

  1. #21
    Join Date
    Oct 2005
    Location
    Waveland, MS USA
    Posts
    54

    Csy

    I found the decoder settings! Nvidia is sneaky. The settings box is only accessible when an mpeg2 file is being played. A little icon shows up in the tray at the bottom right.

    1) Hardware acceleration was already checked.
    2) De-interlace control had 4 options: automatic, film, video, and smart. I picked smart.
    3) De-interlacae mode had 3 options: VMR default, VMR pixel adaptive, VMR vertical stretch. I picked VMR default.
    4) Enhanced nView support had 3 settings: Prefer Overlay, Prefer VMR 7, and Prefer VMR 9. I picked VMR 9.
    5) Display type had 4 options: Content default, Letterbox, Pan and scan, and Anomorphic/Raw aspect. Content default was chosen.

    That sums up the decoder settings I think. There were some more settings folders that were unrelated. They were Color, Audio, and Karaoke.

    The numbers 1-5 above were obviously under the Video settings folder.

    Tell me what you think.

    Thanks.
    SirJYK

    Win XP Pro, SP2, PVR-150 capture card, Antec Solution Series case - NSK2400, Athlon 64 3Ghz, socket 754 90 nm, Asus K8N-VM, 2 gigs of ram, integrated audio, Nvidia 8800GT
    Waveland, MS USA

  2. #22
    Join Date
    Jan 2006
    Location
    Marin County, California
    Posts
    764
    Quote Originally Posted by SirJYK
    I found the decoder settings! Nvidia is sneaky. The settings box is only accessible when an mpeg2 file is being played.
    As csy mentioned earlier in the thread, you can actually access this settings dialog from within the GBPVR config app in the playback tab by clicking on 'video decoder settings' button. This button becomes available once you have picked the Nvidia decoder from the drop down above.

    2. De-interlace control had 4 options: automatic, film, video, and smart. I picked smart.
    My settings are the same as yours except for this one. I think csy said to set this to automatic. I've tried with smart also and couldn't detect any difference on my system.

    Do you get very high cpu use when using the Nvidia decoder? I seem to clock between 85% and 100% during playback with this decoder which heats up the cpu more than I'd like.
    GBPVR v1.3.11 HVR-1250, ES7300, 4GB, GeForce 9300, LianLi, Vista.
    GBPVR v1.0.08 PVR-150, P4 2.26GHz, 1GB, GeForce 6200, Coupden, XP

    Author: UbuStream plugin, UbuRadio plugin, EPGExtra utility.

  3. #23
    Join Date
    Jul 2005
    Location
    Christchurch, New Zealand
    Posts
    494
    Well where do I start

    I’ll reply to SirJYK in this post and UBU in the next post. I’ve edited this off-line and just now noticed you have answered some of your own questions, so please excuse the overlap in my replies.

    Please take into consideration this is my own opinions based on my own experiences.

    Quote Originally Posted by SirJYK
    How do I find out what decoder is being used? Where in the registry would I find this?
    The video decoder used is what you specified in the GBPVR playback tab and DVD tab. If you are using the default decoder and want to know what it is, then download and install GraphEdit and run it, and select menu: File>Render Media File. This will graphically represent all the Directshow default filters (default decoders, renderers, etc). Or better still use GraphEdit to open lastgraph.grf (or lastdvdgraph.grf for DVD playback) in the GBPVR program directory to see exactly what filters GBPVR is using. For those decoders that cannot be configured correctly in GBPVR ‘video decoder settings’ button (eg Cyberlink and Intervideo), there are registry settings which differ depending on the specific decoder. I won’t fill this post with all the various decoder registry settings (they are actually well documented in other threads), but let me know which decoder you are using and I will supply those registry settings if I know them.

    Quote Originally Posted by SirJYK
    Purevideo Bronze has standard surround stereo; gold adds digital 5.1; and platinum adds DTS. Which would you recommend?
    TV is only stereo, however DVD is DD5.1 and DTS, so it depends if you will use the Purevideo decoder for DVD or not. This link may help you (it works on the latest Purevideo version).
    http://www.9down.com/modules.php?nam...print&sid=5676

    Quote Originally Posted by SirJYK
    I have archived a show twice to DVD; one at medium and one at high recording resolution. I am still experiencing the fuzziness and low light loss of detail equally as bad at either recording setting. Is this related to my settings/decoder or is it the lack of resolution integrity by the software?
    The low bandwidth recording will contribute to the fuzziness and low light loss of detail, but will not be as noticeable if you already suffer from fuzziness and low light loss of detail.

    Quote Originally Posted by SirJYK
    Is the analog cable signal feeding my TV and my PVR vastly superior to the signal that can be sent via an s-video cable? If it isn't, then I am experiencing, either signal/detail losses through the capturing process, or, my TV is more sensitive to the cable signal, resulting in better quality.
    It is all a matter of bandwidth – (more bandwidth = less analogue compression = higher quality)
    RF channels are narrowband of approx 6MHz video analogue bandwidth containing both luminance and chrominance (very high analogue compression)
    Composite is single baseband (meaning full available bandwidth over one coaxial cable) however the composite signal only uses part of the baseband spectrum (not sure how much), and contains both luminance and chrominance
    S-video is 2x baseband (2 coaxial cables) with luminance (Y) on one coax and chrominance (C) on other coax.
    Component is 3x baseband (3 coaxial cables) with luminance (Y) on one coax and chrominance difference signals (Y-R also called Pr) and (Y-B also called Pb) on the other 2 coax’s.

    RF is obviously the lowest quality, however it is your TV source and therefore have no choice but use it as your source. Once you have received your source into your TV-tuner or TV-card, you need to process and distribute the signal with minimal degradation of picture and sound (A/V) quality, hence why you use the highest bandwidth interfaces available to distribute the A/V between devices.

    Quote Originally Posted by SirJYK
    On another note, my vid card, Nvidia 7600gs, came with a s-video to rgb output dongle. I do not think this will help me at all since the dongle uses the s-video out on the vid card.
    Nvidia cards normally have a 9-pin mini-DIN socket (similar but not S-video) which in conjunction with the dongle, individually breaks-out composite/S-video/component, and no conversion inside the dongle.

    Quote Originally Posted by SirJYK
    When I installed PureVideo, I changed the software settings in GBPVR to use it. I did not know how to change the dxva stuff that you mentioned.
    GBPVR playback tab, and click on ‘video decoder settings’ button.

    Quote Originally Posted by SirJYK
    On another note, I think there were some interlacing settings on the Miscellaneous tab in GBPVR setup.
    Please refer to my reply to UBU covering the same topic.

    Quote Originally Posted by SirJYK
    I also noticed that the GBPVR window for video is about 10-15 % smaller than the TV picture. When I change the settings to match, that is enlarge the TV output from the vid card, the GBPVR menu is truncated by the amount I enlarged the output. It really doesn't matter except it cuts off the left side of the menu items and we cannot have that! Is it doing some sort of scaling that it shouldn't be doing?
    Make sure you have GBPVR ‘show in windowed mode’ unticked

    If it is occurring both vertically and horizontally then it is an underscan problem. Go into Nvidia driver TV-out Device Settings and click ‘restore to default’ button (and remember to readjust anti-flicker again). That should fix the underscan problem.

    But if it is only one-way (vertical or horizontal) then it is an aspect ratio problem. Something I forgot to mention on my recommendations earlier when viewing on a SDTV with the resolution matching the source video, you should disable aspect ratio correction on the video decoder settings (use ‘stretch’ or ‘raw aspect’). Leave the aspect ratio correction to GBPVR to perform.
    Last edited by csy; 2006-05-19 at 07:03 AM.

  4. #24
    Join Date
    Jul 2005
    Location
    Christchurch, New Zealand
    Posts
    494
    Quote Originally Posted by ubu
    there's no obvious way to turn on hardware acceleration with the Intervideo decoder
    Intervideo has DXVA disabled by default. You can only configure the Intervideo decoder in the registry. These are the registry tweaks for the Intervideo video decoder to enable and maximise hardware acceleration:
    [HKEY_CURRENT_USER\Software\InterVideo\Common\VIDEO DEC\GBPVR]
    "BOBWEAVE"=dword:00000000
    "DXVA"=dword:00000001
    "HWMC"=dword:00000001
    "NVMCP"=dword:00000001
    "VMR"=dword:00000002
    "HwColor"=dword:00000001

    EDIT:
    The registry path should show "VIDEODEC" as one word with no spaces (the forum server keeps adding a space?)
    Quote Originally Posted by ubu
    what is the difference between "Encoder pass-through" and "None" in the Deinterlacing field in the Live Preview Mode section of the Misc tab in GBPVR config?
    None = Take the TV-card ‘preview’ output (raw uncompressed YUV prior to being MPEG2 encoded) directly to the renderer without MPEG2 encoding/decoding
    Encoder pass-through = Take the TV-card ‘MPEG2’ output directly to the decoder (skipping the harddrive), then to renderer.

    A key point here is ‘none’ has no deinterlacing. Note however the GBPVR “VMR9 custom renderer” does appear to apply hardware BOB deinterlacing under such circumstances, therefore giving you a false impression that you are not deinterlacing when in-fact you are.

    Quote Originally Posted by ubu
    Do you know if/when they will enable the Purevideo post-processing feature?
    1.02-184 has it available has a hidden settings tab that can be enabled via a registry setting:
    [HKEY_LOCAL_MACHINE\SOFTWARE\NVIDIA Corporation\Filters\Video]
    "EnablePropPage"=dword:00000001
    "PureVideoPropPage"=dword:00000001
    However the registry settings on latest version 1.02-196 unhide all the other hidden tabs except for the post-processing tab, and I have no idea if future versions will have it.

    Quote Originally Posted by ubu
    I've just upgraded from 1.02-184 to 1.02-196 in the hope that it would solve the problems I experience with this decoder. It certainly produces an immaculate picture with my new 6200 card (better, in some ways, than my TV's tuner) - sharp, clear and with natural colors. But it takes 20 to 30 seconds for live TV or a recording playback to start, CPU shoots up to 100% initially and then bounces between 80% and 100% and playback will suddenly start stuttering and audio will cut in and out. My reliable old Intervideo non-CSS decoder doesn't produce as nice a picture but its pretty bullet-proof in other ways. Life seems full of trade-offs.

    Have this enabled for Purevideo so I'd expect to see less CPU load, not more.
    I suspect you have fallen into the same trap I fell into. The Purevideo 30-day trial key only works once, irrespective of the number of days remaining! When you upgraded it would have accepted the trial key (again) and installed, however the video decoder output pin is disabled. When Directshow attempts to use the filter it will try for 20seconds then fallback to using the default filter (decoder). So what I’m saying is you are more than likely using whatever is the default video decoder and not Purevideo. You can prove this by using GraphEdit to open lastgraph.grf (assuming video not DVD) in the GBPVR directory, which will show you exactly what filters are being used.

    Quote Originally Posted by ubu
    I don't experience overscan when using the Purevideo decoder but, instead, the picture is too narrow (black bars at each side). The height is OK though so it doesn't seem to be "underscan".
    Aspect ratio correction is being performed probably by the video decoder(s). This is something I forgot to mention on my recommendations earlier. When viewing on a SDTV with the resolution matching the source video, you should disable aspect ratio correction on the video decoder settings (use ‘stretch’ or ‘raw aspect’ display mode). Leave the aspect ratio correction to GBPVR to perform.
    Last edited by csy; 2006-06-11 at 08:01 AM.

  5. #25
    Join Date
    Jul 2005
    Location
    Christchurch, New Zealand
    Posts
    494
    Quote Originally Posted by upspace
    the problem is the tv out (s-vhs) you are using. unless you don't go digital (dvi/hdmi) or using a (analog) rgb cable you will never get something similar as you are used with normal tv or from even the cheapest dvd player. all the tweaks, codecs or different graphic cards/tv out chips won't help. it is wasted time and money. it is s-vhs which is not as good as any $30 dvd player with rgb out - believe me.
    This is a matter of opinion, and I challenge that statement. There is no question that an HDTV (dvi/hdmi) gives superior picture quality to an SDTV based on both display pixel resolution and interface type (dvi/hdmi). However with respect to comparing composite, S-video, and component (YPrPb) interfaces on an SDTV, there is a noticeable difference but it is not huge, because SDTV is low resolution by definition. I encourage everyone to prove this for yourselves by connecting your VCR to the SDTV via a composite (or S-video) cable and use the TV tuner in the VCR. This way you can do a direct comparison between the TV itself or TV via the composite (or S-video) interface. There is a little loss of sharpness but not great.

  6. #26
    Join Date
    Jan 2006
    Location
    Marin County, California
    Posts
    764
    Quote Originally Posted by csy
    These are the registry tweaks for the Intervideo video decoder to enable and maximise hardware acceleration:
    [HKEY_CURRENT_USER\Software\InterVideo\Common\VIDEO DEC\GBPVR]
    That's really interesting. I have been using the CaskOfAmontillado tweak guide which suggests different values for some of these keys. Also I'm setting them in HKEY_LOCAL_MACHINE\SOFTWARE\IviSDK4Hauppauge\Commo n\VideoDec (which the tweak guide claims to be the newest Hauppauge location for thes key values). So I'll try these instead. I can't find a Software\Intervideo node under HKEY_CURRENT_USER (maybe because I'm logged on remotely as a different user?) but I guess I can create one.

    Does the existence of the GBPVR key as the final node mean that GBPVR itself is actually setting something at run time and that these settings are not simply instructions for the Intervideo decoder?

    Note however the GBPVR “VMR9 custom renderer” does appear to apply hardware BOB deinterlacing under such circumstances, therefore giving you a false impression that you are not deinterlacing when in-fact you are.
    Thanks for explaining the deinterlacing settings. I notice a few folks are using the “VMR9 custom renderer” option. Is the "hardware BOB deinterlacing" giving them better results than regular VMR9 with "Encoder pass through?

    However the registry settings on latest version 1.02-196 unhide all the other hidden tabs except for the post-processing tab, and I have no idea if future versions will have it.
    Bummer! Another example of vapour-ware, I guess.

    I suspect you have fallen into the same trap I fell into. The Purevideo 30-day trial key only works once, irrespective of the number of days remaining! When you upgraded it would have accepted the trial key (again) and installed, however the video decoder output pin is disabled. When Directshow attempts to use the filter it will try for 20seconds then fallback to using the default filter (decoder). So what I’m saying is you are more than likely using whatever is the default video decoder and not Purevideo. You can prove this by using GraphEdit to open lastgraph.grf (assuming video not DVD) in the GBPVR directory, which will show you exactly what filters are being used.
    I'll check with GraphEdit. I'll be interested to find out which decoder GBPVR was actually using because it sure had a terrific picture. (Pity about the CPU clocking, etc. though.) Wouldn't the trial key "switch" likely be stored in the registry? If so, I have reinstalled XP and then reinstalled Purevideo from the original install file several times (faulty disk drives and other fun stuff), assuming that it would think it was the first time it had been installed. I didn't do this when I upgraded to 1.02-196 however, so probably fell into the "trap". I'm about to reshuffle drives again so I'll try installing 1.02-196 over a clean XP install and see if I fool it. (I'm not too keen on shelling out $30 until I can be sure it actually does the job).
    GBPVR v1.3.11 HVR-1250, ES7300, 4GB, GeForce 9300, LianLi, Vista.
    GBPVR v1.0.08 PVR-150, P4 2.26GHz, 1GB, GeForce 6200, Coupden, XP

    Author: UbuStream plugin, UbuRadio plugin, EPGExtra utility.

  7. #27
    Join Date
    Oct 2005
    Location
    NJ
    Posts
    28
    I am able to get a as clear or even maybe alittle clearer picture on my sdtv using component output. the resolution of a tv is so low I don't think the cable matters that much, until you go to HDTV
    The tv encoder that is on your card matters alot I have a older geforce 3 ti 200 128mb card that has the CX25871 tv chipset and I use tv tool to enable Enhance Text option and run the tv at 720x480 and use window mode in gbpvr and move/resize the window until it fits correctly.

    It took alot of steps and trials to figure this all out but in the end I am left with a picture that exceeds the quality of my normal tv tuner.
    SYSTEM SPECS
    Shuttle AN31 MB
    Athlon XP 2100+
    512 MB OCZ DDR @ 333Mhz
    Gainward Geforce 3 Ti 200 128 MB
    PVR-150 & PVR-150 MCE
    WD 80 GB IDE & 16x DVD-RW
    GBPVR 96.12

  8. #28
    Join Date
    Jul 2005
    Location
    Christchurch, New Zealand
    Posts
    494

    Video card capabilities

    A key limiting factor regarding video quality is the capability of you video card to support MPEG2 hardware acceleration (DXVA) and hardware deinterlacing.

    On ATI cards, DXVA+deinterlacing starts on the 9550 and upwards.

    I did some research on the Nvidia cards this morning and found that the Purevideo features (DXVA+deinterlacing) officially starts on the GeForce6 series and upwards.
    The GeForceFX series does support DXVA but not hardware deinterlacing.
    The GeForceMX series does not support DXVA or hardware deinterlacing.
    (that I'm aware of)

    The key point being that hardware deinterlacing is required to provide a sharp and clear video. If your card does not support hardware deinterlacing then you will not be able you obtain a sharp and clear video unless you use a dedicated 3rd party software deinterlace filter (eg FFDshow), and software deinterlacing is very CPU intensive.

  9. #29
    Join Date
    Jul 2005
    Location
    Christchurch, New Zealand
    Posts
    494
    Quote Originally Posted by SirJYK
    I found the decoder settings! Nvidia is sneaky. The settings box is only accessible when an mpeg2 file is being played. A little icon shows up in the tray at the bottom right.

    1) Hardware acceleration was already checked.
    2) De-interlace control had 4 options: automatic, film, video, and smart. I picked smart.
    3) De-interlacae mode had 3 options: VMR default, VMR pixel adaptive, VMR vertical stretch. I picked VMR default.
    4) Enhanced nView support had 3 settings: Prefer Overlay, Prefer VMR 7, and Prefer VMR 9. I picked VMR 9.
    5) Display type had 4 options: Content default, Letterbox, Pan and scan, and Anomorphic/Raw aspect. Content default was chosen.
    Tell me what you think.
    ‘Display Type’ is the decoder aspect ratio correction. You should disable this by selecting Anomorphic/Raw aspect. The rest looks good.

    Note the ‘Deinterlace Control’ specifies the method of detection of progressive vs. interlaced content within the video. If the Deinterlace Control method detects interlaced content, then it applies the deinterlacing method specified in ‘Deinterlace Mode’. ‘Automatic’ works by reading the MPEG2 information field in the headers, whereas ‘Smart’ actually interrogates the video frames themselves. ‘Smart’ is known to cause problems by switching deinterlacing on and off randomly while the video is running. ‘Video’ forces deinterlacing permanently on. ‘Film’ forces deinterlacing permanently off.

    Quote Originally Posted by ubu
    I have been using the CaskOfAmontillado tweak guide which suggests different values for some of these Intervideo keys. Also I'm setting them in HKEY_LOCAL_MACHINE\SOFTWARE\IviSDK4Hauppauge\Commo n\VideoDec (which the tweak guide claims to be the newest Hauppauge location for thes key values).
    Does the existence of the GBPVR key as the final node mean that GBPVR itself is actually setting something at run time and that these settings are not simply instructions for the Intervideo decoder?
    Good point. Hauppauge do package these decoders into its own registry keys (I use the decoders from WinDVD7 which use the registry keys I mentioned). Please note however that GBPVR overrides the HKEY_LOCAL_MACHINE settings because the Intervideo decoder automatically generates a GBPVR key in HKEY_CURRENT_USER with default values which you need to edit.

    Note the registry key differences will also occur with the Hauppauge Cyberlink decoders compared to the PowerDVD decoders.

    Quote Originally Posted by ubu
    I notice a few folks are using the “VMR9 custom renderer” option. Is the "hardware BOB deinterlacing" giving them better results than regular VMR9 with "Encoder pass through?
    Nobody has commented on any differences (that I’m aware of). The only difference I’m aware of is this unusual side-affect of applying BOB deinterlacing when no deinterlacing is specified. No deinterlacing should provide very sharp picture, so people will be disapointed with the resulting fuzzy picture due to BOB deinterlacing being applied when it shouldn't be. I believe the custom renderer provides the functional advantage of allowing ‘inset’ to work.

    Quote Originally Posted by ubu
    I didn't do this when I upgraded to 1.02-196 however, so probably fell into the "trap".
    This will help you (it works for me on 1.02-196)
    http://www.9down.com/modules.php?nam...print&sid=5676

  10. #30
    Join Date
    Oct 2005
    Location
    Waveland, MS USA
    Posts
    54

    Csy

    Would you happen to have one of those for the latest version? I was thinking of uninstalling it and trying something cheaper or free. My head is spinning from all the help you and everyone has given me. I think I am going to take the weekend off and get back on it next week. Who knows, though, I might get industrious!

    Thanks for your help!

    Edit - I am so weary, I didn't comprehend what you said. Please disregard that last question. I tried it and it works for me as well. Thanks
    Last edited by SirJYK; 2006-05-19 at 06:38 AM.
    SirJYK

    Win XP Pro, SP2, PVR-150 capture card, Antec Solution Series case - NSK2400, Athlon 64 3Ghz, socket 754 90 nm, Asus K8N-VM, 2 gigs of ram, integrated audio, Nvidia 8800GT
    Waveland, MS USA

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •