Page 1 of 6 123 ... LastLast
Results 1 to 10 of 59

Thread: Playing TS files with mvpmc

  1. #1
    Join Date
    Sep 2006
    Location
    Frankfurt, Germany
    Posts
    151

    Playing TS files with mvpmc

    Hi Martin,

    just wondering about streaming my TS Mux files out to the mvpmc without transcoding them first -- do you know of any way to handle this yet?

    Moving to TS Mux is godsend, but the remuxing (see other post from today) has always been a big issue.

    I never knew mvpmc had a web front-end -- would it be possible to set the dongle to boot directly into emulation mode without going thru the 1st boot menu first?

    Thanks,
    Dane

    (spending a LOT more time in mvp logfiles with the umlaut bug and ffmpeg upgrade)
    - Dane

    Cheap Medion Minitower, but it's quiet enough
    - Windows 10x64
    - Digital Devices dual DVB-C PCIe
    - TerraTec Cinergy C PCI HD on a PCIe x1 Adapter (yes, it works!)
    - Kodi front end, NPVR back end

  2. #2
    Join Date
    Jul 2006
    Location
    Schagen, the Netherlands
    Posts
    920
    Quote Originally Posted by daneo View Post
    would it be possible to set the dongle to boot directly into emulation mode without going thru the 1st boot menu first?
    Check out this thread: http://forums.nextpvr.com/showthread.php?t=38574

    Chris
    i5 750 4GB RAM, Windows 10 Home, HDHomeRun HDHR3-4DC, Digital Devices Cine CT, OSCam on a Raspberry Pi with a Smargo Smartreader+, Raspberry Pi 2 OpenElec Kodi client, Gigabyte Brix 2807 OpenElec Kodi client

  3. #3
    Join Date
    May 2006
    Location
    Canada
    Posts
    29,127
    Dane in config.xml you need to set

    <MvpTranscodeTS> false</MvpTranscodeTS>

    It is a per MVP setting you it needs to go in the <MVP-....> section.

    Martin

  4. #4
    Join Date
    Sep 2006
    Location
    Frankfurt, Germany
    Posts
    151
    Hi Martin,

    found it -- works like a charm!

    I'll see if I can discover any unpleasant side-effects otherwise well done for both Sub and Martin.

    Regards,
    Dane
    - Dane

    Cheap Medion Minitower, but it's quiet enough
    - Windows 10x64
    - Digital Devices dual DVB-C PCIe
    - TerraTec Cinergy C PCI HD on a PCIe x1 Adapter (yes, it works!)
    - Kodi front end, NPVR back end

  5. #5
    Join Date
    May 2006
    Location
    Canada
    Posts
    29,127
    Thanks for the update, I am pleasantly surprised.

    Martin

  6. #6
    Join Date
    Dec 2004
    Location
    West Yorkshire, UK
    Posts
    4,543
    @Martin - I was wondering if you could shed some light on the way things work with <MvpTranscodeTS> set to false. Some background to the problem I'm trying to solve is in posts #1 and #3 of this thread...

    http://forums.nextpvr.com/showthread.php?t=38632

    To summarise, I get no sound on playback of .ts files in pvrx2 (on PC not MVP) regardless of audio decoder I use. I do, however, get sound with any decoder if I render the .ts file in Graphedit then create my own mpeg1 audio pin on the demux.

    So (coming to the point)... I spotted this thread and decided to see what happened with mvpmc and <MvpTranscodeTS> set to false. Video is faultless but, again, no audio.

    The common denominator is obviously the audio stream in the ts file but why wouldn't mvpmc be able to handle it when it's clearly OK when I create my own demux audio pin in Graphedit?

    Cheers,
    Brian

  7. #7
    Join Date
    May 2006
    Location
    Canada
    Posts
    29,127
    Try and hit the GO key followed by the Mute to tell emulation mode to try other other audio stream. If that doesn't work I suggest trying the file in mvpmc native mode directly from the mvpmc share folder. In the Filesystem mode you should be able to navigate to your file hit play and then the menu key will allow you to see what audio and video streams are in the ts.

    Martin

  8. #8
    Join Date
    Dec 2004
    Location
    West Yorkshire, UK
    Posts
    4,543
    Thanks - will try later when I have access to the tv/mvp again. I'm new to mvpmc so have yet to explore various features - I'll do some reading on native mode etc.

    Cheers,
    Brian

  9. #9
    Join Date
    Jun 2005
    Location
    Cambridge, UK
    Posts
    181
    I got very excited (sad, I know) when I read here that we could play ts files on the MVP without transcoding and went to try it straight away. It did work too, sound and everything, but - skip just starts the file from the beginning again - is that expected?
    Dual Pentium 1.8GHz, 4GB, 5TB, Colossus, NOVA-T, NOVA-HD-S2, W10 NPVR 4.2.4, 3 PCH A100, 2 PCH A110

  10. #10
    Join Date
    May 2006
    Location
    Canada
    Posts
    29,127
    macgyver, that is the kind of thing I expected. In emulation mode GBPVR is responsible for navigating the file and I don't think sub has updated any of the parsing logic to actually deal with a ts, it is pass through only.

    Martin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •