Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 53

Thread: Movie Library (alpha)

  1. #21
    Join Date
    Jan 2008
    Location
    Ireland/UK
    Posts
    865
    Seems I was a bit eager deleting the Haali splitter. I tried to watch a full bluray film and the video was awfully jerky. I spent ages messing about with resolutions and refresh rates on the off chance it couldn't cope with 1080p film shown at 720p or something but nothing would work. Until I reinstalled the Haali splitter then it played it perfectly. I installed the MPC splitter as suggested by the other thread, but I have no idea if it's using it, despite setting the priority. Either way it was crap without the Haali splitter. No idea why! The only reason I reinstalled it was cause the default sound track was French and I wanted to choose an English one!! However with that installed and an English DTS track selected, it played the thing perfectly! I was very impressed or the wife would no doubt have refused to watch another bluray!!

  2. #22
    Join Date
    Aug 2005
    Location
    Houston
    Posts
    4,796

    ju rock dude!

    been playin with a few movies and your plugin, so far seems really stable...
    one wishlist feature tho, multiple source directories.. these things are so large i have to keep them on different servers, much less same drive/path...
    or does it support the links feature like video library?
    oh yea, one glitch,total time says only for current segment,not whole movie..so can't tell how far in i am, and wondering if resume will work..
    ok, trying resume now, and it's having to re-analyze...maybe cache those? not a biggie tho..resume not working..
    oh and it plays fine from network path..
    [it's a bdrom folder i'm playing]

    So, was just trying a real killer bd, Hancock Unrated-Special. Ed....has alternate ending, about 200 m2ts, alternate data stream,[commentary vid is on full length video track1,movie on track 2] plus trueHD, [tho not on main audio like problem ones]
    and after about a full minute of analysis, it played fine with right audio!! tho strangely on occasion it wigged out on aspect ratio in middle of movie[confused auto aspect, but cycling thru n back to auto fixed it] and occasional glitches when changing m2ts files...[probably same issue]
    that may be my decoder tho, changed to mpc decoder, but cyberlink may be more stable on h264.
    [EDIT: osd says only 20 parts, want bdinfo dump?]
    but it looks very watchable, glitches only on occasion,maybe 20 or so..plays thru by itself..

    btw, it plays the default ending...

    how far away from audio track changing beta?

    oh and 'Live Free, Die Hard' is an excellent example of TrueHD audio obscuring...won't play audio without conversion to ac3...and only 1 m2ts file for movie...
    [and not a bad movie either]
    thanks for gettin the ball rolling..!
    Last edited by pBS; 2008-12-28 at 01:12 PM.
    Hardware: HDHR Prime, HDPVR 1212, Raspberry pi2, VFD display w/LCDSmartie

  3. #23
    Join Date
    Aug 2005
    Location
    Houston
    Posts
    4,796

    update

    hancock plays well now with cyberlink decoder and mpc demux, funny thing was, it would change demux depending on what type of video...vc1 always used mpc,h264 always used cyberlink...weird..
    played with the merits and all is playing well again..

    but halfway thru the movie [on 3rd file change] it changed languages! only when playing full disk folder...and i noticed a bit of a lag when changing files..and inability to rewind to previous parts if in another file...[if in segment 4 and wish to rewind to segment 2 it won't, just back to beginning of current segment]
    it happens consistantly...not sure why...my remuxed version works fine..
    i bet they switch up the audio track order in one of the files..

    oh and did you mention that xp users need a udf 2.5 driver to read disks natively?
    Hardware: HDHR Prime, HDPVR 1212, Raspberry pi2, VFD display w/LCDSmartie

  4. #24
    Join Date
    Nov 2006
    Location
    Louisville, KY, USA
    Posts
    7,870
    Quote Originally Posted by pBS View Post
    been playin with a few movies and your plugin, so far seems really stable..
    one wishlist feature tho, multiple source directories.. these things are so large i have to keep them on different servers, much less same drive/path...
    or does it support the links feature like video library?
    Yeah, I want this feature too so it's definitely on the todo list. I just wanted to get out a "proof of concept" plugin so it's lacking a lot of the planned features. I haven't added anything to specifically support links but Windows may handle them natively. I haven't tried it though.
    Quote Originally Posted by pBS View Post
    oh yea, one glitch,total time says only for current segment,not whole movie..so can't tell how far in i am, and wondering if resume will work..
    ok, trying resume now, and it's having to re-analyze...maybe cache those? not a biggie tho..resume not working..
    oh and it plays fine from network path..
    [it's a bdrom folder i'm playing]
    I'm currently using GBPVR's native PlayVideoFile(). For movies that are split into multiple files, it then tells GBPVR to queue up the remaining parts. To GBPVR, it's a playlist of different video files and not a single video with multiple parts. This is one of the things where I will need something from sub to get it handled properly. I just want to make sure I have all my ducks in a row before making my requests. (all of us chipping in and getting him a BD drive might be a good idea too)
    Quote Originally Posted by pBS View Post
    So, was just trying a real killer bd, Hancock Unrated-Special. Ed....has alternate ending, about 200 m2ts, alternate data stream,[commentary vid is on full length video track1,movie on track 2] plus trueHD, [tho not on main audio like problem ones]
    and after about a full minute of analysis, it played fine with right audio!! tho strangely on occasion it wigged out on aspect ratio in middle of movie[confused auto aspect, but cycling thru n back to auto fixed it] and occasional glitches when changing m2ts files...[probably same issue]
    that may be my decoder tho, changed to mpc decoder, but cyberlink may be more stable on h264.
    [EDIT: osd says only 20 parts, want bdinfo dump?]
    but it looks very watchable, glitches only on occasion,maybe 20 or so..plays thru by itself..
    I've still got some work to do on movies with multiple parts. the 20 or so glitches you see are when GBPVR switches to the next file.

    Quote Originally Posted by pBS View Post
    btw, it plays the default ending...
    Right now, I'm just selecting the longest playlist so if the alternate ending caused the movie to be longer, that's the one it would select. This is one of the things I need to work on.

    Quote Originally Posted by pBS View Post
    how far away from audio track changing beta?
    I'd like to say "soon" but I'm about to start "end of year" stuff for one of my jobs as well as switching over accounting/hr software so this month is going to be rough.


    Quote Originally Posted by pBS View Post
    but halfway thru the movie [on 3rd file change] it changed languages! only when playing full disk folder
    I was wondering if I would come across a disc with this problem. I'll get it so I can figure out how to work around it.

    Quote Originally Posted by pBS View Post
    ...and i noticed a bit of a lag when changing files..and inability to rewind to previous parts if in another file...[if in segment 4 and wish to rewind to segment 2 it won't, just back to beginning of current segment]
    it happens consistantly...not sure why...my remuxed version works fine..
    i bet they switch up the audio track order in one of the files..
    That's because of the GBPVR playlist function that I mentioned above.

    Quote Originally Posted by pBS View Post
    oh and did you mention that xp users need a udf 2.5 driver to read disks natively?
    Nope, forgot about that. Thanks for reminding me.

  5. #25
    Join Date
    Aug 2005
    Location
    Houston
    Posts
    4,796

    one more note

    one more note, trying to play a real disk in drive i get slowdowns..we may have to specify a minimum read rate for drives as anydvd adds a bit of latency to an already taxing job and mine seems to be just a hair behind needed speed...plays 2-3 secs smooth then a bit of stutters waiting for data...i can see it trying to keep up but it can't...
    tho it may just be my system/codecs etc..they play fine as folder or file from hd tho...

    kinda like a disk buffer is needed...but maybe i just have too slow a drive?
    Pioneer pdc-s02bk it's a 5x sl reader but only 2x DL! which i assume most disks are...
    probably need a 4x Dual-Layer reader to play disks natively...can you confirm?

    btw, after playing that disk again a couple of times it went to Spanish on a different changeover this time so not totally consistent where it happens..

    here's a link to Toshibas driver for udf 2.5 http://files.digital-digest.com/down...-BluePrint.rar
    just unrar and right click on .inf and select 'install' and reboot...
    Last edited by pBS; 2008-12-29 at 04:47 PM.
    Hardware: HDHR Prime, HDPVR 1212, Raspberry pi2, VFD display w/LCDSmartie

  6. #26
    Join Date
    Nov 2006
    Location
    Louisville, KY, USA
    Posts
    7,870
    I haven't experienced the slowdown but I have an LG drive so I couldn't tell you for sure what the issue is.

  7. #27
    Join Date
    Aug 2005
    Location
    Houston
    Posts
    4,796
    what BD double layer speed is yours?
    i tried with both kids of video to be sure it wasn't a codec problem and both same..
    then again it may be something simple like unchecking 'remove adverts' in anydvd..
    tho i think it is probably the xp udf driver slowing things down..not built in like vista..

    finally got vc1 working in transcodes...did you know there's a vc1 codec in wmp11/wmfdist11.exe ? works great...[it should, it's Microsofts codec invention]
    only it's a DMO, but it works like regular directshow filter in graphs...
    couldn't get cyberlink vc1 filter to work ever, they probably piggyback on MS's like ffdshow..lol

    the mpc codec is surprisingly good and accelerated for vc1 and h264..but kinda buggy on vc1...biggest letdown is it can only connect to video card's dxva decoder directly on vc1/h264 when using dxva..to convert need to use ffmpeg support which isn't very good..

    elecvard demux is also weird, i'd stick with mpc demux...very stable, plays everything so far..
    Hardware: HDHR Prime, HDPVR 1212, Raspberry pi2, VFD display w/LCDSmartie

  8. #28
    Join Date
    Nov 2006
    Location
    Louisville, KY, USA
    Posts
    7,870
    Quote Originally Posted by pBS View Post
    what BD double layer speed is yours?
    i tried with both kids of video to be sure it wasn't a codec problem and both same..
    then again it may be something simple like unchecking 'remove adverts' in anydvd..
    tho i think it is probably the xp udf driver slowing things down..not built in like vista..
    Actually, I did experience this last night with Death Race. I'll see if I can figure out what's causing it.

    Quote Originally Posted by pBS View Post
    finally got vc1 working in transcodes...did you know there's a vc1 codec in wmp11/wmfdist11.exe ? works great...[it should, it's Microsofts codec invention]
    only it's a DMO, but it works like regular directshow filter in graphs...
    couldn't get cyberlink vc1 filter to work ever, they probably piggyback on MS's like ffdshow..lol
    Yeah, I knew that. It's been so long since I used XP that I can't remember what's included with it and what needs an additional download.

    Quote Originally Posted by pBS View Post
    the mpc codec is surprisingly good and accelerated for vc1 and h264..but kinda buggy on vc1...biggest letdown is it can only connect to video card's dxva decoder directly on vc1/h264 when using dxva..to convert need to use ffmpeg support which isn't very good..

    elecvard demux is also weird, i'd stick with mpc demux...very stable, plays everything so far..
    I agree, the MPC demux and ArcSoft demuxes are the best in my opinion. MPC having an upper hand due to the ability to stream switch, which I still have to figure out how to do with ArcSoft.

  9. #29
    Join Date
    Aug 2005
    Location
    Houston
    Posts
    4,796

    couple of thoughts on multi-files

    possible fixes for multi file playlists: somewhere i saw a multi-file source filter that should produce a smooth stream from many files..will have to find that again and see if its opensource or free....fairly simple to implement...

    and if you can build graphs, a demux/mux/render-result would make a smooth stream as well...not much overhead either because it's only splitting and recombining as a stream with no files...
    just have to get to where the stream that's played is only one joined part...

    a very interesting page here:http://www.gdcl.co.uk/articles/
    Hardware: HDHR Prime, HDPVR 1212, Raspberry pi2, VFD display w/LCDSmartie

  10. #30
    Join Date
    Nov 2006
    Location
    Louisville, KY, USA
    Posts
    7,870
    Quote Originally Posted by pBS View Post
    possible fixes for multi file playlists: somewhere i saw a multi-file source filter that should produce a smooth stream from many files..will have to find that again and see if its opensource or free....fairly simple to implement...
    I've been looking for a good multisource filter but never could find one. If you find it let me know.

    Quote Originally Posted by pBS View Post
    and if you can build graphs, a demux/mux/render-result would make a smooth stream as well...not much overhead either because it's only splitting and recombining as a stream with no files...
    just have to get to where the stream that's played is only one joined part...

    a very interesting page here:http://www.gdcl.co.uk/articles/
    GBPVR takes care of building the graph and handling the file switches. I'm sure sub is just changing the source filter.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •