Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 40

Thread: XRecord-Fonts and password protection

  1. #11
    Join Date
    Jan 2006
    Location
    Oklahoma, USA
    Posts
    241
    Quote Originally Posted by stustunz View Post
    yeah thats different than what i was talking about
    mine was really blocky steps on any diagonal lines in text
    I used to get the major blocky letters too (almost hurt the eyes it was so hard to read), but something in this latest released changed that...that is what got me interested in the plugin again. Now I'm just being spoiled and wanting everything.

    Seriously though, thanks to you guys (especially you Fla) who have resurrected this plugin from its crash-prone unusable state a couple versions back when the new X2 interface came on the scene. It is a great little plugin and I'm pleased to have it available (spoiled font wishes aside...)!

  2. #12
    Join Date
    Mar 2006
    Location
    Montreal, Canada
    Posts
    765
    Glad to hear all the bugfixes I made didn't go unnoticed.

    Let us know how the fonts look in the HD community skin when it's ready. I still use gbpvr (not pvrx2) on an SD TV.
    2 Hauppauge PVR-150's, Celeron 2.93GHz, 1GB RAM, 1TB Maxtor HD, Cooler Master Cavalier 2, Radeon HD 2400 Pro, gbpvr 1.1.5 Blue Skin

  3. #13
    Join Date
    Jan 2006
    Location
    Oklahoma, USA
    Posts
    241
    I've been working with the CS4-HD version of the XRecord plugin. It looks very nice (many thanks to Fatman do!), but still has the jagged font issue. It sounds like this is likely a problem in how the utility was originally coded (combination of using the legacy rendering engine and perhaps some hard coding done in the original utility). See http://forums.gbpvr.com/showpost.php...9&postcount=92. I just wanted to update you (and anyone following the thread). I will probably play with this some more as Fatman do had suggested...trying different base fonts, but so far it looks like we will be out of luck unless someone can figure out the root cause of the problem that makes the skinn scale so poorly. I'll let you know if I get lucky and hit on something that works.

    I want to thank you again for getting this plugin back in action...even with lower quality fonts, it is nice to have its functionality available in the current GBPVR version...your efforts are appreciated!

  4. #14
    Join Date
    Mar 2006
    Location
    Montreal, Canada
    Posts
    765
    Quote Originally Posted by dshoup View Post
    ...
    Second, I really like the idea of password protection. Is there a way to set up the keys.txt file so that all shows taped have a password unless I specifically unprotect them?
    I just uploaded a new version with default password support. If you look in XRecord's skin.xml, a new defaultPassword attribute was added right next to the existing passwordLength attribute. It's empty by default but you can assign a value to it. You might want to backup your current password file before trying this new version.

    If you set a default password, all (existing and future) password-less shows will have it as a password. You can unlock individual shows as usual with the blue button. You can still lock individual shows with specific passwords as before but you'll have to first unlock a show's default password then relock it with an individual password.
    2 Hauppauge PVR-150's, Celeron 2.93GHz, 1GB RAM, 1TB Maxtor HD, Cooler Master Cavalier 2, Radeon HD 2400 Pro, gbpvr 1.1.5 Blue Skin

  5. #15
    Join Date
    Jan 2006
    Location
    Oklahoma, USA
    Posts
    241
    Very nice! Thank you so much . It works great.

  6. #16
    Join Date
    Mar 2006
    Location
    Montreal, Canada
    Posts
    765
    Super. The only thing I think might be missing is a visual cue letting you know if its asking for the default or a regular password. "Enter Password" or "Enter Password (Default)". Then again if you use the same password for both it doesn't matter.
    2 Hauppauge PVR-150's, Celeron 2.93GHz, 1GB RAM, 1TB Maxtor HD, Cooler Master Cavalier 2, Radeon HD 2400 Pro, gbpvr 1.1.5 Blue Skin

  7. #17
    Join Date
    Jan 2006
    Location
    Oklahoma, USA
    Posts
    241
    I'm planning on the same password, so it is no problem for me...I just want some way to ensure the kids can't watch something I have not approved ahead of time.

    If there were any way to change the way the plugin renders so the fonts would look sharper, that would be top on my wish list. But from what I understand, this is rooted in the history of the plugin on the old rendering engine such that it likely would take a complete re-write, so don't worry...I'm not expecting anything . I'm very happy with the changes you've already made getting this plugin working in the newer version of GBPVR and enhancing the password and such. Thanks for your work!

  8. #18
    Join Date
    Dec 2004
    Location
    Canada
    Posts
    121
    WOW! I'm totally amazed. I've never seen (in pvrx2) xrecord look even remotly clear.

    I'll I get on my screen is so poor you can't read it if you didn't already know what it said.

    How did you get it to looks so clear.

  9. #19
    Join Date
    Mar 2006
    Location
    Montreal, Canada
    Posts
    765
    Did you try the community skin especially if you have an HDTV? The blue skin that comes with XSuite is low res SD. The community skin has an HD version of the XSuite skin. The fonts don't scale that well since it's a legacy plugin not a PVRX2 plugin. I'm still using an SDTV and GB-PVR (not PVRX2).
    2 Hauppauge PVR-150's, Celeron 2.93GHz, 1GB RAM, 1TB Maxtor HD, Cooler Master Cavalier 2, Radeon HD 2400 Pro, gbpvr 1.1.5 Blue Skin

  10. #20
    Join Date
    Dec 2004
    Location
    Canada
    Posts
    121
    I'm running on a clean install of Windows 2000 (since that's all the computer does). I just uninstalled everything deleted the gbpvr directory and reinstalled everything thinking that would fix it. it didn't.

    I tried the Community skin 4.02..... No luck.
    Basically everything on the computer looks fine including gb-pvr but XRecord is unreadable. I wish I could post it here but the file size limits for posting means I can't. I'm not talking about... "Oh it would be better if the font's were rounded" What I see is the bottom part of the font is just gone some time. A capitle O sometimes just looks like an upside down L. Many lines that make up the letters are just missing and it's not consistent.

    I looks like what would happen if you took a really big font (say 64x64) with a stroke width of 1 and then scaled it down (say to 8x8) as a bit map. thereby loosing a lot of it.
    What remains is unreadable.

    I'm thinking that since it's a stock Windows 2000 (pro) that the XRecord is using a font that Win2k doesn't have and it's picking a substitute and trying to scale it (and failing horribly).

    I can't however find where to change the Font in Community Skin (SD) 4.02. I did find the size changing i.e. +1 +2 +3 +4 but that didn't have much of an affect.

    I frankly assumed that XRecord was dead an was no longer compatible. I was so shocked to see a post where it was even remote readable.

    I would love some help on getting it to work. Any Ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •