Results 1 to 7 of 7

Thread: Very long start-up time for TV Recordings or TV Listings

  1. #1
    Join Date
    Jul 2007
    Location
    USA
    Posts
    135

    Very long start-up time for TV Recordings or TV Listings

    When I try to start TV Listings or TV Recordings from the NMT I get a ~2.5 minute delay. There are no apparent errors in the logs, but the wait happens prior to TV Listings saying it is about to update recordings schedule (about 10:04 in the attached log file).
    2009-10-14 10:02:20.923 VERBOSE [6] Adding: ^K RECORDINGS_DELETE
    2009-10-14 10:04:54.033 VERBOSE [6] TV Listings: About to update recording schedule...
    2009-10-14 10:04:54.439 VERBOSE [6] TV Listings: Finished updating recording schedule.

    Any ideas?

    Attachment 24388

    I was playing around a bit today and saw that TV Listings gives a little more in the logs:

    2009-11-03 14:46:30.428 VERBOSE [6] User pressed@2: 13
    2009-11-03 14:46:30.428 VERBOSE [6] about to call OnKeyDown()
    2009-11-03 14:46:30.428 VERBOSE [6] Key pressed: Return
    2009-11-03 14:46:30.428 VERBOSE [6] TV Listings: Activating...
    2009-11-03 14:46:30.428 INFO [6] TV Listings: v2.10.3572.17427 initialising.
    2009-11-03 14:46:30.521 VERBOSE [6] TV Listings: Backend initialised.
    2009-11-03 14:46:30.537 VERBOSE [6] Skinhelper loading image from file: C:\Program Files\Devnz\GBPVR\skin2\Community-WS\TV Listings\..\_CoreImages\Detail_Normal.png
    2009-11-03 14:46:30.599 VERBOSE [6] Skinhelper loading image from file: C:\Program Files\Devnz\GBPVR\skin2\Community-WS\TV Listings\down.png
    2009-11-03 14:46:30.599 VERBOSE [6] Skinhelper loading image from file: C:\Program Files\Devnz\GBPVR\skin2\Community-WS\TV Listings\up.png
    2009-11-03 14:48:58.084 VERBOSE [6] getValue cached value: /settings/ActiveMVPSkin : Community-WS
    2009-11-03 14:48:58.303 VERBOSE [12] TV Listings: Client identifier is MVP 0006DC4233E0, assuming MVP.
    2009-11-03 14:48:58.303 VERBOSE [12] TV Listings: Listings loader thread started.
    2009-11-03 14:49:00.349 VERBOSE [6] UiStatic.SetArgs() is setting forceRefresh, and will return true to needsRendering()
    2009-11-03 14:49:00.365 VERBOSE [6] TV Listings: About to update recording schedule...
    2009-11-03 14:49:02.365 VERBOSE [6] TV Listings: Finished updating recording schedule.
    2009-11-03 14:49:02.381 VERBOSE [6] TV Listings: activated.
    2009-11-03 14:49:02.381 VERBOSE [6] OnKeyDown() complete
    2009-11-03 14:49:02.381 VERBOSE [6] MVP sending frame

    Thanks,
    Leaded
    Last edited by leaded1; 2009-11-03 at 07:59 PM. Reason: another example
    Server - AMD 6 Core windows 10 with Hauppage WINTV-PVR2 USB2, HDHomerun Dual, and WINTV-HVR 1600 tuners | Clients -PCH A-100 and iOS

  2. #2
    Join Date
    Apr 2005
    Posts
    976
    Hi,

    is this only happening on your nmt/mvp or also on the pc? It would also be helpful if you set "LogSQL" to "true" in config.xml, and post a complete set of logs.

    -alibert

  3. #3
    Join Date
    Jul 2007
    Location
    USA
    Posts
    135

    Thanks for taking a look

    Here is the whole set of logs with LogSQL set to true (running from NMT), I don't see much to go on though:
    Attachment 24408

    My server cannot run PVRX2, so I only use the NMT and/or MVP. Also, this only happens the first time I select TV Listings or TV Recordings, all subsequent selections of either plugin start up quickly.

    Thanks again,
    leaded
    Last edited by leaded1; 2009-11-05 at 04:07 PM.
    Server - AMD 6 Core windows 10 with Hauppage WINTV-PVR2 USB2, HDHomerun Dual, and WINTV-HVR 1600 tuners | Clients -PCH A-100 and iOS

  4. #4
    Join Date
    Apr 2005
    Posts
    976
    Hi,

    sorry, I don't know at the moment what could cause the delay.

    Some points that could help me debugging the issue would be: Has it always been like this or did the problem just occur recently? How large is your database, how many recordings do you have stored? Are the recordings stored on a local harddisk connected directly to your server? Are the default recordings / tv guide plugins opening normally? When you enable the tv recordings panel (in your main menu skin file, see the wiki for details), is the delay already there when the panel fetches the recordings information?

    -alibert

  5. #5
    Join Date
    Jul 2007
    Location
    USA
    Posts
    135
    I didn't notice the long delay until this summer when I got the NMT (~august). The way I initially noticed it was when I had the Recordings Panel enabled it would take a long time (2+ minutes) to get to the main menu on the NMT after starting up mvpmcx2. sub's Guide and Recordings start up normally. My TV Listings database is 207 KB. My gbpvr.db3 database is 328 MB. I have about 110 recordings spread between a local (to the server) harddrive (~60 recordings) and a USB external drive (~50 recordings) attached to the server. I think I'll try removing all of my existing recordings (I can re-import them later) and see if it changes the startup time.

    I'll let you know what I find out.
    Thanks for giving this some thought,
    leaded
    Server - AMD 6 Core windows 10 with Hauppage WINTV-PVR2 USB2, HDHomerun Dual, and WINTV-HVR 1600 tuners | Clients -PCH A-100 and iOS

  6. #6
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,174
    Looking at the logs thread [13] is definitely blocking the other threads. When the PCH is connected every 10 seconds you should see a regular log message

    [6] MVP data read: 1 (8)

    Martin

  7. #7
    Join Date
    Jul 2007
    Location
    USA
    Posts
    135

    Thanks Martin!

    Just to clarify, this would be something internal to the plugin, and not something peculiar about my set up, right?

    -leaded
    Server - AMD 6 Core windows 10 with Hauppage WINTV-PVR2 USB2, HDHomerun Dual, and WINTV-HVR 1600 tuners | Clients -PCH A-100 and iOS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •