Results 1 to 9 of 9

Thread: UltraXMLTV Won't Detect GB-PVR

  1. #1
    Join Date
    Jan 2010
    Location
    United States
    Posts
    8

    UltraXMLTV Won't Detect GB-PVR

    I'm using the newest version of GB-PVR (1.4.7) and am having trouble getting UltraXMLTV Post-Process Renamer working on my Windows 7 64 bit system.

    When I try to launch the program it states that it cannot locate GB-PVR. I'm thinking this is because it is in Program Files (x86) instead of the standard Program Files directory, but I cannot change it when installing GB-PVR (I've tried, it just ignores me and installs to the x86 directory).

    Is there a way to get this program running on a 64 bit copy of Windows or am I stuck and have to use a 32 bit copy?
    Last edited by hackman20007; 2010-01-30 at 05:53 PM.

  2. #2
    Join Date
    Aug 2005
    Location
    Houston
    Posts
    4,796
    you can probably get away with copying the registry bits from the 46bit registry to the x86 one..
    [it's probably determining the gbpvr dir from the registry entry, which it can't find..]
    i think HKLM\software\devnz\
    Hardware: HDHR Prime, HDPVR 1212, Raspberry pi2, VFD display w/LCDSmartie

  3. #3
    Join Date
    Feb 2006
    Location
    Calgary, Alberta, Canada
    Posts
    5,105
    Quote Originally Posted by pBS View Post
    you can probably get away with copying the registry bits from the 46bit registry to the x86 one..
    [it's probably determining the gbpvr dir from the registry entry, which it can't find..]
    i think HKLM\software\devnz\
    THanks pbs... I think you're right. It's been a long time, but I'm sure Ultra gets the path from the reg
    Code:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Devnz]
    "LastKnownVersionInUse"="GB-PVR v1.4.7"
    "MVPs"="000DFE38386C"
    "GBPVR InstallDir"="C:\\Program Files\\Devnz\\GBPVR\\"
    Frank Z

    I used to ask 'why?' Now I just reinstall...
    ______________________________________________
    Author: ZTools: ZProcess, MVPServerChecker; UltraXMLTV Enhancer, Renamer, Manager;


  4. #4
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,048
    This could very well be the worst hack I have read since tipstir was here. What about plugins and setup programs that use the registry legitimately and think they are running 32 bit?

    Martin

  5. #5
    Join Date
    Nov 2006
    Location
    Louisville, KY, USA
    Posts
    7,870
    Frank, if you set the target machine as "x86" instead of "AnyCPU" for your project, it should always run as a 32 bit project and therefore always read the 32 bit registry keys. If you want to target AnyCPU so that the app runs as 64/32 bit depending on the machine, do a fallback registry search so that if it doesn't find it in the main location, it checks the SysWow3264 location.

  6. #6
    Join Date
    Feb 2006
    Location
    Calgary, Alberta, Canada
    Posts
    5,105
    Quote Originally Posted by whurlston View Post
    Frank, if you set the target machine as "x86" instead of "AnyCPU" for your project, it should always run as a 32 bit project and therefore always read the 32 bit registry keys. If you want to target AnyCPU so that the app runs as 64/32 bit depending on the machine, do a fallback registry search so that if it doesn't find it in the main location, it checks the SysWow3264 location.
    Actually, this is starting to ring a bell. I had trouble with this before, and I did set my projects to use x86 only.
    Frank Z

    I used to ask 'why?' Now I just reinstall...
    ______________________________________________
    Author: ZTools: ZProcess, MVPServerChecker; UltraXMLTV Enhancer, Renamer, Manager;


  7. #7
    Join Date
    Feb 2006
    Location
    Calgary, Alberta, Canada
    Posts
    5,105
    Quote Originally Posted by mvallevand View Post
    This could very well be the worst hack I have read since tipstir was here. What about plugins and setup programs that use the registry legitimately and think they are running 32 bit?

    Martin
    Ouch
    Frank Z

    I used to ask 'why?' Now I just reinstall...
    ______________________________________________
    Author: ZTools: ZProcess, MVPServerChecker; UltraXMLTV Enhancer, Renamer, Manager;


  8. #8
    Join Date
    Dec 2008
    Location
    Chicago, USA
    Posts
    9
    I have the same issue with ultraxmltv_post not finding GBPVR. I run windows 7 64 bit and gbpvr 1.4.7.

    My registry has the info in HKLM\wow6432node\devnz

    GBPVR InstallDir = C:\Program Files (x86)\Devnz\GBPVR\
    LastKnownVersionInUse = GB-PVR v1.4.7

    Did anyone figure out the fix for this? The registry shows the correct path so what is the problem with ultraxmltv_post?

  9. #9
    Join Date
    Jan 2010
    Location
    United States
    Posts
    8
    I apologize for not responding earlier. I was busy being an idiot and not realizing that I made a typo in my username (too many 0's, supposed to be hackman2007, not hackman20007).

    Anyways, I just decided to switch to a different plugin. Could never figure out how to get this to work. The plugin I switched to was WizRenameRecording, seems to work fine, but not as automated as I would like.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •