Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: UltraXMLTV - Windows Interactive Serices Message

  1. #1
    Join Date
    Jul 2005
    Location
    New York
    Posts
    146

    UltraXMLTV - Windows Interactive Serices Message

    I just started getting a windows interactive services message that says it has a message that can not be shown on the desktop. When i click show message, my screen goes dark and then comes up light blue with a message from UltraXMLTV_Enhancer that says "The file has already been enhanced. We can't do it again." This interactive services window will continue to show up on my desktop until i restart the machine. Any ideas how to stop this from happening?

  2. #2
    Join Date
    Aug 2005
    Location
    Houston
    Posts
    4,796
    hmmm,sounds like somthing broken in your epg update...
    it should only be run after a fresh epg .xml grab, and yours is telling you it's already processed that file, so doesn't need to do it again..
    kill ultra from task man, then shouldn't get those messages...
    but make sure that ultra only runs after a fresh .xml grab...

    it may be that your xmltv grabber didn't complete successfully..[and ultra is trying to process old file]
    Hardware: HDHR Prime, HDPVR 1212, Raspberry pi2, VFD display w/LCDSmartie

  3. #3
    Join Date
    Jul 2005
    Location
    New York
    Posts
    146
    It doesn't seem to happen everyday. Almost like every other day. Could it be my epg data is not changing everyday but every other day? Is there a way to make the epg do an update every 2 days instead of every day in order to test that out?

  4. #4
    Join Date
    May 2005
    Posts
    224
    ive been having this the last few days also
    2.6quadcore,4gbddr2,(2)hvr1600,(2)pvr150,a-100,mvp, windows7

  5. #5
    Join Date
    Feb 2006
    Location
    Calgary, Alberta, Canada
    Posts
    5,105
    Ultra will only try to enhance what it's given. If the downloader is not getting new information each day, it will error...

    Though I should say, I did not originally design it to error silently like what you guys are seeing.

    Personally, even though I have been by the author that it's totally uncool... I force a new update with mc2xml each day... I don't have a problem because, it appears as fresh data...

    Another thing you could do is work with your batch file, so that the downloaded file is copied to a file that Ultra will enhance.

    eg:

    Downloader creates xmltv1.xml
    Batch file copies xmltv1.xml to xmltv2.xml
    Ultra enhances xmltv2.xml
    GB-PVR updates with xmltv2.xml

    In this way, if the downloader does not give new info, the batch file will keep going and overwrite xmltv2.xml, thus, Ultra won't trip
    Frank Z

    I used to ask 'why?' Now I just reinstall...
    ______________________________________________
    Author: ZTools: ZProcess, MVPServerChecker; UltraXMLTV Enhancer, Renamer, Manager;


  6. #6
    Join Date
    May 2005
    Posts
    224
    i found the message again this morning but i also found my c drive was full so im hoping that was the reason but il know soon
    2.6quadcore,4gbddr2,(2)hvr1600,(2)pvr150,a-100,mvp, windows7

  7. #7
    Join Date
    Jul 2005
    Location
    New York
    Posts
    146
    Thanks for the info zehd, I will try forcing mcxml to update first and then try the copying the xml file second and see what happens.

  8. #8
    Join Date
    Jul 2005
    Location
    New York
    Posts
    146
    Forcing MC2XML to update daily produces the same problem.

    Using a batch script to copy the xmltv.xml to xmltv2.xml and then run Ultra creates a real message box on the desktop with the same "The file has already been enhanced. We can't do it again." instead of a windows interactive services message.

    Any other ideas to try?

  9. #9
    Join Date
    Feb 2006
    Location
    Calgary, Alberta, Canada
    Posts
    5,105
    Quote Originally Posted by persim View Post
    Forcing MC2XML to update daily produces the same problem.

    Using a batch script to copy the xmltv.xml to xmltv2.xml and then run Ultra creates a real message box on the desktop with the same "The file has already been enhanced. We can't do it again." instead of a windows interactive services message.

    Any other ideas to try?
    You have to check things again. Somehow, Ultra IS receiving an already enhanced file.

    Each time mc2xml downloads an epg (and there's either new information or it has been forced) it creates a new xml file. Ultra would not ever complain about that file. Open the new xml in notepad. A fresh download would NOT have any reference to me, 'zehd' in the first few lines.

    It seems that within your batch file, Ultra is being told to enhance the wrong file. It's really easy to overlook something small in your batch file...

    You might have something like

    mc2xml >> download to file1
    Ultra >> enhance file2

    In this case file2 would never be changed, because there's no logic to rename or copy file1 to file2
    Frank Z

    I used to ask 'why?' Now I just reinstall...
    ______________________________________________
    Author: ZTools: ZProcess, MVPServerChecker; UltraXMLTV Enhancer, Renamer, Manager;


  10. #10
    Join Date
    Jul 2005
    Location
    New York
    Posts
    146
    Double checked the batch file and I have mc2xml creating xmltv.xml, then i copy it to same place and rename it to xmltv2.xml. Last I have ultra enhancing xmltv2.xml and updating with that file for my tuners. Everything appears to be right in my batch file.

    I have actually been looking for an excuse to try out windows 7, so I'm probably just gonna format and try 7. Thanks for the help and I'll let you know if I have any issues with the new install.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •