Results 1 to 4 of 4

Thread: SearchWiz config crash

  1. #1

    SearchWiz config crash

    With SearchWizX1 1.0.16.1, if I run config and bring up the plug-in settings, then do a "Save", config crashes:

    ************** Exception Text **************
    System.NullReferenceException: Object reference not set to an instance of an object.
    at WizUtilities.WizInfo.cfgCreateOrUpdatePluginProper ty(String section, String property, Object value)
    at WizPlugin.SearchWizConfigForm.cmdSaveSettings_Clic k(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnMouseUp(MouseEventAr gs mevent)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ButtonBase.WndProc(Message& m)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.O nMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.W ndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    This seems to have started after I used the config to delete a filter.

  2. #2
    Join Date
    Dec 2006
    Location
    St. Johns, Florida USA
    Posts
    2,448
    Ok, I'll take a look. I am on the road right now for about another 2 weeks. Make sure you have the most current version of the WizDLLs (see WizUtilities wiki page). If that corrects the problem, let me know, otherwise I will research when I get back.
    NPVR Server: Win10 / AMD Phenom II X4 965 / 8gRAM / ATI Radeon 7700 Series / Hauppauge 2250
    Misc: HDHR Prime, rPI LibreElec & Amazon FireStick Kodi clients

  3. #3
    Quote Originally Posted by JavaWiz View Post
    Ok, I'll take a look. I am on the road right now for about another 2 weeks. Make sure you have the most current version of the WizDLLs (see WizUtilities wiki page). If that corrects the problem, let me know, otherwise I will research when I get back.
    Thanks! I was already using the latest DLLs as of the day I posted that. It didn't happen when I just tried it, something subtle must be different right now that is just not causing it to trigger.

  4. #4

    Recurrence

    FWIW it happened again. Backtrace looks similar.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •