Page 2 of 19 FirstFirst 123412 ... LastLast
Results 11 to 20 of 190

Thread: New NMTInstall2 for N-PVR

  1. #11
    Join Date
    Aug 2005
    Location
    Houston
    Posts
    4,796
    nrecord will delete which files?
    Hardware: HDHR Prime, HDPVR 1212, Raspberry pi2, VFD display w/LCDSmartie

  2. #12
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,048
    Sub has already provided a test version that fixes this so I assume a public release isn't too far off. I suspect the problem only relates to files accessed through NPVR's NMT web interface, but currently it will delete any file that the web server opens if they aren't locked somehow. Fortunately by the nature of the protocol mvpmcx2/gbpvr use, most media files will be locked.

    Martin

  3. #13
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,048
    NMTInstall2 is now online again, sub has released a patch available here http://forums.gbpvr.com//showthread....395#post380395 and it can also be installed with NMTInstall2 as an update.

    One way or the other please apply sub's patch if your are using 1.5.21 with an NMT

    Martin

  4. #14
    Join Date
    Oct 2004
    Location
    The Big Easy
    Posts
    3,692
    Very strange. I added the patch and noticed my channel logos disappeared. I went to the directory where the logos were installed and I found was the zip file for the patch (which was downloaded to my desktop). How could it possibly remove all my channel logos? This did not happen another system. Man, I have a freaky-deaky system that does the strangest things that I can't even blame on me! Glad I had copied all the logos over to GBPVR last night.


    Paul
    Custom ASUS Maximus X Hero, 16 GB Memory-ASUS GeForce 1050 Ti, H115i Pro AIO, 850W PS, CM H500P case, Corsair Vengeance RGB Ram, Samsung 970 EVO, HDHomerun Prime & Extend Tuners- running Windows 10 (and other goodies)
    #2--P877WS- Core i7 3770k, 16GB Memory-GeForce GTX 650Ti, SATA III SSD, H100i cooler, 750W PS, Windows 10

  5. #15
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,048
    Did you just run the update or did you do a full install?

    Martin

  6. #16
    Join Date
    Oct 2004
    Location
    The Big Easy
    Posts
    3,692
    Just the update. Things are working fine. I copied over the logos from GBPVR and it's working. So is the PCH. It's running extremely smooth and the new Wave skin on the PCH is mega nice too!


    Paul
    Custom ASUS Maximus X Hero, 16 GB Memory-ASUS GeForce 1050 Ti, H115i Pro AIO, 850W PS, CM H500P case, Corsair Vengeance RGB Ram, Samsung 970 EVO, HDHomerun Prime & Extend Tuners- running Windows 10 (and other goodies)
    #2--P877WS- Core i7 3770k, 16GB Memory-GeForce GTX 650Ti, SATA III SSD, H100i cooler, 750W PS, Windows 10

  7. #17
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,048
    Quote Originally Posted by pcostanza View Post
    Just the update. Things are working fine. I copied over the logos from GBPVR and it's working. So is the PCH. It's running extremely smooth and the new Wave skin on the PCH is mega nice too!
    If your media folder lost the channel logo's I can't this being an NMTInstall2 problem. You should check the details the next time you run it to see if any error comes up.

    The logic on an update,

    - stops the NPVR service
    - kill the ntray and nextpvr exe's
    - create mvpmc\temp
    - download the update to mvpmc\temp
    - copy patch files to program files\
    - remove mvpmc\temp
    - restart NPVR service

    I ran it several times and if you look at the details (which you should always do in case of error)

    Code:
    ComputureName : EMVEEPEE
    NPVR Data Directory : C:\Users\Public\NPVR
    NPVR Program Directory : C:\Program Files\NPVR
    Output folder: C:\mvpmc
    Installing to C:\Users\Public\NPVR
    Download C:\mvpmc\NMTInstall.xml OK
    NPVR Data Directory : C:\Users\Public\NPVR
    NPVR Program Directory : C:\Program Files\NPVR
    1.5 1.5.20
    NRecord.zip 0
    C:\mvpmc\NRecord.zip
    20100702 20100702
    Create folder: C:\mvpmc\Temp
    Extracting contents of C:\mvpmc\NRecord.zip to C:\mvpmc\Temp
      Extracting 1 files and directories
      Extract : NRecord.exe
    Copy to C:\Users\Public\NPVR
    Delete file: C:\mvpmc\Temp\NRecord.exe
    Remove folder: C:\mvpmc\Temp\
    Completed
    Martin

  8. #18
    Join Date
    Oct 2004
    Location
    The Big Easy
    Posts
    3,692
    Just reran it again, no errors and channel logos are still intact.
    Guess it was just another freak of nature for this particular machine.


    Paul
    Custom ASUS Maximus X Hero, 16 GB Memory-ASUS GeForce 1050 Ti, H115i Pro AIO, 850W PS, CM H500P case, Corsair Vengeance RGB Ram, Samsung 970 EVO, HDHomerun Prime & Extend Tuners- running Windows 10 (and other goodies)
    #2--P877WS- Core i7 3770k, 16GB Memory-GeForce GTX 650Ti, SATA III SSD, H100i cooler, 750W PS, Windows 10

  9. #19
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,048
    I'm glad we had this discussion. As it turned out there was a bug in that NMTInstall2 it copied updates to the User folder (a remnant from GBPVR) and so the update wasn't being performed anyway Now this looks better.

    Code:
    Extracting contents of C:\mvpmc\NRecord.zip to C:\mvpmc\Temp
      Extracting 1 files and directories
      Extract : NRecord.exe
    Copy to C:\Program Files\NPVR
    Delete file: C:\mvpmc\Temp\NRecord.exe
    Remove folder: C:\mvpmc\Temp\
    Completed
    Martin

  10. #20
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,048
    I have uploaded a new version of NMTINstall2 to remove the need to patch NextPVR.exe. This will be a configurable item in future versions of NPVR in config.xml (thanks sub) and this version does the update for you.

    Martin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •