Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 38

Thread: NEWA Auto-Search Command Line Interface (CLI)

  1. #21
    Join Date
    Dec 2004
    Location
    West Yorkshire, UK
    Posts
    4,541
    Thanks Alex - I couldn't work out which log to look at (the wiki docs for the EWA version of the CLI suggested it created a separate log but I couldn't find anything like it for the NEWA version). Your pointer meant I did find this in npvr.log.1 however...

    Code:
    2011-06-17 20:59:50.041	[INFO][1]	Auto Search has not yet been executed today.... 
    2011-06-17 20:59:51.681	[INFO][1]	Setting last auto search date to today so this routine does not run again until tommorow.... 
    2011-06-17 20:59:51.697	[INFO][1]	 
    2011-06-17 20:59:51.697	[INFO][1]	Processed search: Agatha Christie
    2011-06-17 20:59:51.697	[INFO][1]	 
    2011-06-17 20:59:51.697	[INFO][1]	    Set 0 reminders
    2011-06-17 20:59:51.697	[INFO][1]	    Scheduled 0 events to record
    2011-06-17 20:59:51.697	[INFO][1]	 
    2011-06-17 20:59:51.697	[INFO][1]	 
    2011-06-17 20:59:51.697	[INFO][1]	Processed search: Doctor Who
    2011-06-17 20:59:51.697	[INFO][1]	 
    2011-06-17 20:59:51.697	[INFO][1]	    Set 0 reminders
    2011-06-17 20:59:51.697	[INFO][1]	    Scheduled 0 events to record
    I had a look in config-web.xml and saw...

    Code:
    <autoSearchDays>2</autoSearchDays>
    but can confirm running those saved searches in NEWA shows results for tomorrow so they're within that window.

    I did notice the following as well though...

    Code:
    <autoShowRecord>False</autoShowRecord>
    but both searches in the web-saved-searches.xml show
    Code:
    autoRecordSearch="True"
    Hmmm.

  2. #22
    Join Date
    Jun 2007
    Location
    Scotland
    Posts
    2,691
    From my config-web.xml
    Code:
          <autoShowSearch>True</autoShowSearch>
          <autoShowRecord>True</autoShowRecord>
          <autoSearchDays>2</autoSearchDays>
    and from my web-saved-searches.xml
    Code:
      <Search id="Match of the Day">
        <SearchVersion>3.0</SearchVersion>
        <SearchName autoShowSearch="True" autoRecordSearch="True" caseSensitiveSearch="False">Match of the Day</SearchName>
        <SearchTitle>True</SearchTitle>
        <SearchSubTitle>False</SearchSubTitle>
        <SearchDescription>False</SearchDescription>
        <MatchTitle>False</MatchTitle>
        <MatchSubTitle>False</MatchSubTitle>
        <MatchDescription>False</MatchDescription>
        <StartTitle>False</StartTitle>
        <StartSubTitle>False</StartSubTitle>
        <StartDescription>False</StartDescription>
        <SearchPhrase>match of the day</SearchPhrase>
    Maybe have a look in your web-saved-searches.xml to see how each search is set up?

    Alex

  3. #23
    Join Date
    Dec 2004
    Location
    West Yorkshire, UK
    Posts
    4,541
    Thanks again Alex.

    I'm wondering if the config-web.xml entry for
    Code:
    <autoShowRecord>False</autoShowRecord>
    is overriding the
    Code:
    autoRecordSearch="True"
    attribute in the web-saved-searches.xml <Search Name> elements.

    I'll wait until after midnight and try again with it set to true.

  4. #24
    Join Date
    Dec 2004
    Location
    West Yorkshire, UK
    Posts
    4,541
    Yep...the
    Code:
    <autoShowRecord>...</autoShowRecord>
    setting in config-web.xml is the 'master switch' and overrides the individual search entries.

    Cheers,
    Brian

  5. #25
    Join Date
    Jun 2007
    Location
    Scotland
    Posts
    2,691
    My apologies Brian - I completely forgot about the Enable AutoRecord setting on the NEWA Config tab.

    Anyway, it's great that it's now working. I couldn't be without it now - it schedules about 99% of my recordings...

    Alex

  6. #26
    Join Date
    Dec 2004
    Location
    West Yorkshire, UK
    Posts
    4,541
    Quote Originally Posted by ACTCMS View Post
    My apologies Brian - I completely forgot about the Enable AutoRecord setting on the NEWA Config tab.
    Ah...so that's where it is.

    As I don't use NEWA very much I'm not familiar with the layout (rookie mistake - I should have guessed).

    Anyway, it's great that it's now working. I couldn't be without it now - it schedules about 99% of my recordings...
    Yes, it looks pretty good. I'll run it manually each day for a while until I figure out what I want to search for (the answer is 42 but are you sure you know what the question is? ).

    Cheers,
    Brian

  7. #27
    Join Date
    Feb 2005
    Location
    Pennsylvania, USA
    Posts
    5,517
    First post updated with latest release bringing NEWA AutoSearch in-line with the search functionality in NEWA.

  8. #28
    Join Date
    Jun 2007
    Location
    Scotland
    Posts
    2,691
    Hi UJB - I notice that the attachment has been dropped. Would you be able to upload it again?

    Alex

  9. #29
    Join Date
    Dec 2004
    Location
    West Yorkshire, UK
    Posts
    4,541
    Alex - I can email you a zip of my version if you like.

    Cheers,
    Brian

  10. #30
    Join Date
    Jun 2007
    Location
    Scotland
    Posts
    2,691
    Quote Originally Posted by bgowland View Post
    Alex - I can email you a zip of my version if you like.

    Cheers,
    Brian
    Thanks Brian, that would be great...

    Alex

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •