Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Server Error in '/' Application

  1. #11
    Join Date
    Jul 2005
    Location
    HK - Pal I
    Posts
    3,440
    OK, I renamed config-web.xml (not called web-config.xml), stopped and started NPVR, logged in and it recreated the file.
    All seems OK for now, need to check remotely, but I did notice when I tried to "Search Now" from config, I got this error.

    Code:
    Server Error in '/' Application.
    --------------------------------------------------------------------------------
    
    Specified cast is not valid. 
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    
    Exception Details: System.InvalidCastException: Specified cast is not valid.
    
    Source Error: 
    
    
    Line 834:                foreach (EPGEvent epgevent in epgeventArray)
    Line 835:                {
    Line 836:                    foreach (DayOfWeek day in selectedDays)
    Line 837:                    {
    Line 838:                         if (epgevent.StartTime.ToLocalTime().DayOfWeek == day)
     
    
    Source File: c:\Users\Public\NPVR\Web\App_Code\Classes\SearchEngine.cs    Line: 836 
    
    Stack Trace: 
    
    
    [InvalidCastException: Specified cast is not valid.]
       N_EWA.classes.SearchEngine.filterSearchResults(Int32 minLength, Int32 maxLength, ArrayList selectedDays) in c:\Users\Public\NPVR\Web\App_Code\Classes\SearchEngine.cs:836
       N_EWA.classes.SearchEngine.SelectEPGEvents(Array channels, Array selectedGenre, Boolean checkTitle, Boolean checkDesc, Boolean checkSubtitle, Boolean matchTitle, Boolean matchDesc, Boolean matchSubtitle, Boolean startTitle, Boolean startDesc, Boolean startSubtitle, Boolean matchUniqueID, String searchFor, Boolean caseSensitive, Schedule scheduleHelper, Int32 EPG_EVENTMinLength, Int32 EPG_EVENTMaxLength, ArrayList selectedDays) in c:\Users\Public\NPVR\Web\App_Code\Classes\SearchEngine.cs:518
       N_EWA.classes.SavedSearchUtils.autoSearch(ArrayList Searches) in c:\Users\Public\NPVR\Web\App_Code\Classes\SavedSearch.cs:1162
       N_EWA.Admin.forceSearch_Click(Object sender, EventArgs e) in c:\Users\Public\NPVR\Web\Admin.aspx.cs:220
       System.Web.UI.WebControls.LinkButton.OnClick(EventArgs e) +78
       System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument) +100
       System.Web.UI.WebControls.LinkButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +10
       System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +13
       System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +170
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2863
    ASUS STRIX X470-F AMD 2700x 4GHz | Win10Prox64 | 32GB | NVIDIA GEforce GT1030 Fanless | WinTV DMB-TH | WinTV HVR-1280 | Hauppauge Colossus | Various HD's | AC86U | USB-UIRT | PCH-A110 | RPi2 | Sony Bravia LCD X9000F Android TV |. Frustrated that NextPVR is not working? Take a moment and consider this and this and this and this and this and this. Credit where credit's due; for one guy (with a wife and two kids), most problems are solved outrageously quickly. Patience.

  2. #12
    Join Date
    Sep 2016
    Location
    Indianapolis
    Posts
    11
    Quote Originally Posted by smajor View Post
    Hello, I'm running NPVR on Win 7. I have never used the web admin with NPVR, although I've been using NPVR for a long time. I enabled it in the previous version of NPVR, gave myself a user/pass, but am receiving the following error. A saw a similar thread, not quite the same error.

    I let it be and installed 2.2.6 and still the error remains. I downloaded it from the wiki and replaced the contents of the web directory with the download. Still the same. Any ideas?

    Code:
    Server Error in '/' Application.
    Runtime Error
    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.
    
    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".
    
    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>
    
    
    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.
    
    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>
    I'm getting the same error as this first post. I have tried deleting the config-web.xml in C:\Users\Public\NPVR\ and then stopping and starting npvr but it isnt fixing the problem. It also isn't recreating the file when I restart npvr. Any suggestions?


    Edit: Fixed. I downloaded the latest version of npvr and reinstalled it and now it works!
    Last edited by Yousty; 2017-07-12 at 03:54 PM.

  3. #13
    Join Date
    Oct 2017
    Location
    US
    Posts
    2
    I've tried reinstalling NextPvR, stop and starting the service but I can't access the web interface. I've made my ip static but both localhost:8866 and IP:8866 neither work. When I do localhost:8866 on my pc hosting nextpvr I get the below error message. Any help would be greatly appreciated. Thanks!

    Server Error in '/' Application.

    Compilation Error

    Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

    Compiler Error Message: CS1061: 'N_EWA.classes.Settings' does not contain a definition for 'GetIP4Address' and no extension method 'GetIP4Address' accepting a first argument of type 'N_EWA.classes.Settings' could be found (are you missing a using directive or an assembly reference?)

    Source Error:


    Line 127: Logger.Info("IP V6 Detected on Server ");
    Line 128: Logger.Info("IP6 Address: " + address);
    Line 129: if (Global.Settings.autologinNets.CheckNumber(Global. Settings.GetIP4Address()))
    Line 130: {
    Line 131: IsInternalnetwork = true;

    Source File: q:\Users\Public\NPVR\web\App_Code\Classes\VerifyIn ernalNetworkJSON.cs Line: 129

  4. #14
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,156
    That is too old a post to be relevant. Your problem is the installer doesn't delete the file verifyinernalnetwork.cs on non standard installations.

    Martin

  5. #15
    Join Date
    Mar 2006
    Location
    Montreal, Canada
    Posts
    765
    We started getting this error on clients using NEWA as well right after the Windows 10 NextPVR server received the fall creators update (1709). X-NEWA also fails to connect now as well. Has anyone else had issues with NEWA after Windows 10 received the fall creators update.
    2 Hauppauge PVR-150's, Celeron 2.93GHz, 1GB RAM, 1TB Maxtor HD, Cooler Master Cavalier 2, Radeon HD 2400 Pro, gbpvr 1.1.5 Blue Skin

  6. #16
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,156
    Also not related but after a major windows update you might need to run the installer again to fix .net files for the web server.

    Martin

  7. #17
    Join Date
    Mar 2006
    Location
    Montreal, Canada
    Posts
    765
    This solution got rid of "Server Error in '/' Application" following the fall creators update (1709).

  8. #18
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,156
    Rerunning the installer should effectively do the same thing.

    Martin

  9. #19
    Join Date
    Oct 2017
    Location
    US
    Posts
    2
    Quote Originally Posted by mvallevand View Post
    That is too old a post to be relevant. Your problem is the installer doesn't delete the file verifyinernalnetwork.cs on non standard installations.

    Martin
    There were posts as recent as July and its the same main error message, it would have been the same topic title I would have used so it seemed redundant.

    Anyway, your suggestion worked like a charm, deleted the file and reinstalled again and now I can access.

    I am curious what is classified as a non standard installation? I simply upgraded my version of NextPVR?

    Thanks for your suggestion and help, much appreciated!

  10. #20
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,156
    Quote Originally Posted by qnexus View Post
    I am curious what is classified as a non standard installation?
    The installer is hard-coded to delete any "bad" files from the default location of C:\Users\Public\NPVR Your folder for NextPVR is on a Q Drive.

    Martin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •