Results 1 to 1 of 1

Thread: NMT Advanced Configs

  1. #1
    Join Date
    Nov 2006
    Location
    Sunninghill, UK
    Posts
    2,584

    NMT Advanced Configs

    steeb is back after months of builder hell and dust and a rapidly growing ickle one

    I have finally got around to start building up my shiny new NextPVR server (for shiny read still on XP, and an old dog of a box, breathed upon and given new life).

    Of course my first thing to get up and running is my extenders. Focussing firstly on the NMT's (haven't tried an MVP yet!)

    All looking pretty good so then decided to start some of the more advanced stuff.

    Specifically first: ability to use MCE remote like I used to with old system.

    Followed the wiki on this.

    Contents of npvr.cgi are as:

    Code:
    #!/bin/sh
    echo "Content-Length: 29";
    echo "Content-type: text/html";
    echo "";
    cd ~
    if [ -f /etc/mvpmc/mvpmcx2 ]
    then
        echo "mvmcx2 is loaded";
    else
        mkdir /etc/mvpmc
        mount -t cifs //10.0.0.60/mvpmc /etc/mvpmc -o username=root,rw
        cp /etc/mvpmc/utelnetd /usr/bin
        cp /etc/mvpmc/lircd1 /bin
        killall lircd
        lircd1 &
        ln -s /lib/librmjpeg.so /lib/libjpeg.so.62
        ln -s /lib/librmzlib.so /lib/libz.so
        ln -s /lib/librmzlib.so /lib/libz.so.1
        ln -s /lib/librmzlib.so /lib/libz.so.123
        utelnetd -l /bin/sh -p 23 &
        echo "Telnetd started on port 23............";
    fi
    killall gaya
    sh -c /etc/mvpmc/startmeup 2>/dev/null >/dev/null &
    exit 0;
    I did this with editpad just to make sure

    Not off USB but mvpmc share on server. And may be that is what is making it fall down? As mvpmc is in D: not C:?

    Message from NMT on startup:

    cp: cannot stat '/etc/mvpmc/l
    Thanks in advance for any help

    any logs needed etc in which case most happy to supply

    cheers

    steeb

    [Edit] Shows what a tired mind and babies do to you! I will leave this post here for posterity's sake to prove what a total numpty I am. I hadn't unpacked the lirc 7z...... hmmmm. It works now with an unpacked zip, well I guess it would, wouldn't it!!! [End Edit]
    Last edited by steeb; 2012-05-11 at 09:03 PM. Reason: I am a numpty!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •