Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Sorry, an error occurred while processing your request.

  1. #1
    Join Date
    Sep 2004
    Location
    Stockholm, Sweden
    Posts
    690

    Sorry, an error occurred while processing your request.

    Reven, I have installed the Webconsole and I get the first login screen (http://192.168.0.100:8877/Setup) working. However, after entering username, email and password I am only getting a "Sorry, an error occurred while processing your request." message.

    Im not sure what logs to attach so please advise.

    Thanks,

    \\AGerdin

  2. #2
    Join Date
    Sep 2004
    Location
    Auckland, NZ
    Posts
    5,823
    couple of things to try.

    check log files, there's a directory called "Logging" of the website dir, usually (C:\Program Files (x86)\Reven\NextPVR Web Console\Logging)

    check event viewer, it *may* write an error there.

    how is that message shown exactly? a popup? a yellow screen of death? a notification popup in the top right corner? just the response from the server visible in the network trace?

  3. #3
    Join Date
    Sep 2004
    Location
    Auckland, NZ
    Posts
    5,823
    also do you mind posting the info you used on the setup screen? you can provide a different password, but if you used any special characters could you list those as well? want to see if i can reproduce this.

  4. #4
    Join Date
    Sep 2004
    Location
    Stockholm, Sweden
    Posts
    690
    Quote Originally Posted by reven View Post
    couple of things to try.
    check log files, there's a directory called "Logging" of the website dir, usually (C:\Program Files (x86)\Reven\NextPVR Web Console\Logging)
    Log looks ok to me
    Code:
    ============================================================
    NextPVR Version: 2.5.9.0
    NextPVR Web Console Version: 0.1.0.33022
    NextPVR Web Console Database Version: 115
    ============================================================
    
    2012-12-07 00:03:26.810 [3]: Deleting old log files
    2012-12-07 01:03:26.811 [19]: Deleting old log files
    2012-12-07 02:03:26.815 [13]: Deleting old log files
    2012-12-07 03:03:26.818 [11]: Deleting old log files
    2012-12-07 04:03:26.823 [7]: Deleting old log files
    2012-12-07 05:03:26.829 [16]: Deleting old log files
    2012-12-07 06:03:26.830 [16]: Deleting old log files
    2012-12-07 07:03:26.836 [18]: Deleting old log files
    2012-12-07 08:03:26.830 [13]: Deleting old log files
    2012-12-07 09:03:26.843 [16]: Deleting old log files
    2012-12-07 10:03:26.844 [3]: Deleting old log files
    2012-12-07 11:03:26.852 [18]: Deleting old log files
    2012-12-07 12:03:26.853 [23]: Deleting old log files
    2012-12-07 13:03:26.857 [21]: Deleting old log files
    2012-12-07 14:03:26.861 [19]: Deleting old log files
    2012-12-07 15:03:26.868 [18]: Deleting old log files
    2012-12-07 16:03:26.872 [13]: Deleting old log files
    2012-12-07 17:03:26.874 [11]: Deleting old log files
    2012-12-07 18:03:26.875 [13]: Deleting old log files
    2012-12-07 19:03:26.882 [7]: Deleting old log files
    2012-12-07 20:03:26.885 [17]: Deleting old log files
    2012-12-07 21:03:26.888 [11]: Deleting old log files
    2012-12-07 21:05:42.292 [16]: Application stopped.

    Quote Originally Posted by reven View Post
    check event viewer, it *may* write an error there.
    Which event viewer, Windows, Webserver?

    Quote Originally Posted by reven View Post
    how is that message shown exactly? a popup? a yellow screen of death? a notification popup in the top right corner? just the response from the server visible in the network trace?
    No popup, just an white empty webpage with the message in the top left corner.

    Quote Originally Posted by reven View Post
    also do you mind posting the info you used on the setup screen? you can provide a different password, but if you used any special characters could you list those as well? want to see if i can reproduce this.
    Tried many different things

    User: agerdin
    Email: anders_gerdin@domain.com
    Pass: 123456
    Pass: 123456

  5. #5
    Join Date
    Sep 2004
    Location
    Auckland, NZ
    Posts
    5,823
    Ok white empty page with single line sounds like a webserver issue with ultidev. Let me do some googling and see what I find

  6. #6
    Join Date
    Sep 2004
    Location
    Auckland, NZ
    Posts
    5,823
    can you open your C:\program files\reven\nextpvr web console\web.config file in notepad or another text editor and then comment out the custom error lines

    eg change
    Code:
    ...
    
        <authentication mode="Forms">
          <forms loginUrl="~/Login" timeout="2880"/>
        </authentication>
        <customErrors mode="On">
          <error statusCode="510" redirect="/Setup" />      
        </customErrors>
        <pages>
          <namespaces>
    ...
    to

    Code:
    ...
    
        <authentication mode="Forms">
          <forms loginUrl="~/Login" timeout="2880"/>
        </authentication>
    <!--
        <customErrors mode="On">
          <error statusCode="510" redirect="/Setup" />      
        </customErrors>
    -->
        <pages>
          <namespaces>
    ...
    notice the new <!-- and --> surrounding the customerrors element. might be this is hiding the real error.

  7. #7
    Join Date
    Sep 2004
    Location
    Auckland, NZ
    Posts
    5,823
    also is this the live code or the alpha using the installer?

  8. #8
    Join Date
    Sep 2004
    Location
    Stockholm, Sweden
    Posts
    690
    Reven,

    Now I can see what the problem is. For archiving purposes I have 2 recording drives setup. One local disk and one on a Server. It seems that WebConsole cannot handle the Server recording drive.

    Code:
    Server Error in '/' Application.
    
    Failed to create recording directory: \\GERDIN-SERVER\Recorded TV\00Recordings
    
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    
    Exception Details: System.Exception: Failed to create recording directory: \\GERDIN-SERVER\Recorded TV\00Recordings
    
    Source Error: 
    
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
    
    Stack Trace: 
    
    
    [Exception: Failed to create recording directory: \\GERDIN-SERVER\Recorded TV\00Recordings]
       NextPvrWebConsole.Models.NextPvrConfigHelper.set_ExtraRecordingDirectories(KeyValuePair`2[] value) +251
       NextPvrWebConsole.Models.Configuration.Save() +1015
       NextPvrWebConsole.Models.RecordingDirectory.Save() +160
       NextPvrWebConsole.Controllers.SetupController.Index(SetupModel Model) +300
       lambda_method(Closure , ControllerBase , Object[] ) +108
       System.Web.Mvc.ActionMethodDispatcher.Execute(ControllerBase controller, Object[] parameters) +17
       System.Web.Mvc.ReflectedActionDescriptor.Execute(ControllerContext controllerContext, IDictionary`2 parameters) +188
       System.Web.Mvc.ControllerActionInvoker.InvokeActionMethod(ControllerContext controllerContext, ActionDescriptor actionDescriptor, IDictionary`2 parameters) +27
       System.Web.Mvc.Async.<>c__DisplayClass42.<BeginInvokeSynchronousActionMethod>b__41() +28
       System.Web.Mvc.Async.<>c__DisplayClass8`1.<BeginSynchronous>b__7(IAsyncResult _) +12
       System.Web.Mvc.Async.WrappedAsyncResult`1.End() +50
       System.Web.Mvc.Async.AsyncControllerActionInvoker.EndInvokeActionMethod(IAsyncResult asyncResult) +29
       System.Web.Mvc.Async.<>c__DisplayClass39.<BeginInvokeActionMethodWithFilters>b__33() +59
       System.Web.Mvc.Async.<>c__DisplayClass4f.<InvokeActionMethodFilterAsynchronously>b__49() +240
       System.Web.Mvc.Async.<>c__DisplayClass37.<BeginInvokeActionMethodWithFilters>b__36(IAsyncResult asyncResult) +12
       System.Web.Mvc.Async.WrappedAsyncResult`1.End() +50
       System.Web.Mvc.Async.AsyncControllerActionInvoker.EndInvokeActionMethodWithFilters(IAsyncResult asyncResult) +31
       System.Web.Mvc.Async.<>c__DisplayClass2a.<BeginInvokeAction>b__20() +23
       System.Web.Mvc.Async.<>c__DisplayClass25.<BeginInvokeAction>b__22(IAsyncResult asyncResult) +128
       System.Web.Mvc.Async.WrappedAsyncResult`1.End() +50
       System.Web.Mvc.Async.AsyncControllerActionInvoker.EndInvokeAction(IAsyncResult asyncResult) +26
       System.Web.Mvc.<>c__DisplayClass1d.<BeginExecuteCore>b__18(IAsyncResult asyncResult) +14
       System.Web.Mvc.Async.<>c__DisplayClass4.<MakeVoidDelegate>b__3(IAsyncResult ar) +25
       System.Web.Mvc.Async.WrappedAsyncResult`1.End() +55
       System.Web.Mvc.Controller.EndExecuteCore(IAsyncResult asyncResult) +41
       System.Web.Mvc.Async.<>c__DisplayClass4.<MakeVoidDelegate>b__3(IAsyncResult ar) +25
       System.Web.Mvc.Async.WrappedAsyncResult`1.End() +55
       System.Web.Mvc.Controller.EndExecute(IAsyncResult asyncResult) +28
       System.Web.Mvc.Controller.System.Web.Mvc.Async.IAsyncController.EndExecute(IAsyncResult asyncResult) +10
       System.Web.Mvc.<>c__DisplayClass8.<BeginProcessRequest>b__3(IAsyncResult asyncResult) +28
       System.Web.Mvc.Async.<>c__DisplayClass4.<MakeVoidDelegate>b__3(IAsyncResult ar) +25
       System.Web.Mvc.Async.WrappedAsyncResult`1.End() +55
       System.Web.Mvc.MvcHandler.EndProcessRequest(IAsyncResult asyncResult) +30
       System.Web.Mvc.MvcHandler.System.Web.IHttpAsyncHandler.EndProcessRequest(IAsyncResult result) +9
       System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +278
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +163
    
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.547
    \\Agerdin

  9. #9
    Join Date
    Sep 2004
    Location
    Auckland, NZ
    Posts
    5,823
    yeah I havent yet adding support for network drives, work around for now is to just map the network drive.

    ill make a ticket in github and try sort it out for the next alpha.

    glad you found the issue.

  10. #10
    Join Date
    Sep 2004
    Location
    Auckland, NZ
    Posts
    5,823

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •