Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: WebRadio 4.0 pre-wiki release

  1. #11
    Join Date
    Oct 2008
    Location
    Severn Estuary (Mendip) UK
    Posts
    1,164
    Quote Originally Posted by mvallevand View Post
    Thanks for doing the research! for some reason ogg was never a valid type when loading from a csv file. I'm surprised that it worked before. I've updated post one with the fix. It's easy while I keep things in sync.

    Martin
    That sorted the Last Played thanks - It quite probably was an issue before but I hadn't loaded so many Ogg stations one after the other to notice.
    I was trying to find why the Opus logo was never used, but I guess that as the streams are always [.opus.ogg] they will always use the Ogg logo - at least they play fine.

    Quote Originally Posted by mvallevand
    Gives me good reason to upload a Web Radio experimental release this weekend.

    Martin
    My sneaky underhand ploy worked then - Thank You Martin
    It's not an overly complicated system - it's more - overly simple operatives

  2. #12
    Join Date
    Sep 2008
    Location
    California
    Posts
    7,230
    I get an unhandled exception, when I select "Internet Television":
    Code:
    System.NullReferenceException: Object reference not set to an instance of an object.
       at WebRadio.WebRadio2.PopulateXMLWidget(String loadStationFile, List`1 itemList)
       at WebRadio.WebRadio2.PopulateList()
       at WebRadio.WebRadio2.ActivateItem(ListObject selectedObject)
       at NUtility.Controls.ListRenderers.UiListList.OnKeyDown(KeyEventArgs e)
       at NUtility.Base.NewStyleButtonListPlugin.OnKeyDown(KeyEventArgs e)
       at WebRadio.WebRadio2.OnKeyDown(KeyEventArgs e)
       at NextPVR.ControllerForm.OnKeyDown(Object sender, KeyEventArgs e)
       at System.Windows.Forms.Control.OnKeyDown(KeyEventArgs e)
       at System.Windows.Forms.Control.ProcessKeyEventArgs(Message& m)
       at System.Windows.Forms.Control.ProcessKeyMessage(Message& m)
       at System.Windows.Forms.Control.WmKeyChar(Message& m)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
       at System.Windows.Forms.Form.WndProc(Message& m)
       at NextPVR.ControllerForm.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    The content of my TVStations.xml is the example you posted above. I thought maybe it was because the two icon images didn't exist (tv.png and vevotv.png), but I copied another .png to those names and it didn't help.

    nothing seems very interesting in NPVR.log, just this for two attempts to go into "Internet Television":
    Code:
    2014-02-09 08:51:01.012	[DEBUG][1]	OnKeyDown() called: Return
    2014-02-09 08:51:01.043	[DEBUG][1]	NUtility.Controls.UiList+ListContainer
    2014-02-09 08:51:01.043	[DEBUG][1]	False
    2014-02-09 08:51:01.043	[DEBUG][1]	Populating C:\Users\Public\NPVR\Plugins\WebRadio\TVStations.xml
    2014-02-09 08:51:01.044	[DEBUG][1]	C:\Users\Public\NPVR\Plugins\WebRadio\TVStations.xml
    2014-02-09 08:51:04.432	[DEBUG][1]	OnKeyDown() called: Return
    2014-02-09 08:51:04.432	[DEBUG][1]	NUtility.Controls.UiList+ListContainer
    2014-02-09 08:51:04.432	[DEBUG][1]	False
    2014-02-09 08:51:04.433	[DEBUG][1]	Populating C:\Users\Public\NPVR\Plugins\WebRadio\TVStations.xml
    2014-02-09 08:51:04.433	[DEBUG][1]	C:\Users\Public\NPVR\Plugins\WebRadio\TVStations.xml
    2014-02-09 08:51:06.658	[DEBUG][1]	OnKeyDown() called: Escape
    2014-02-09 08:51:06.658	[DEBUG][1]	Populating C:\Users\Public\NPVR\Plugins\WebRadio\TVStations.xml
    2014-02-09 08:51:06.659	[DEBUG][1]	C:\Users\Public\NPVR\Plugins\WebRadio\TVStations.xml
    2014-02-09 08:51:08.976	[DEBUG][1]	Unable to find radio icon: C:\Users\Public\NPVR\Media\RadioLogos\tvfolder.png
    2014-02-09 08:51:08.977	[DEBUG][1]	Loading radio icon: C:\Users\Public\NPVR\Media\RadioLogos\moremusic.png
    Last edited by johnsonx42; 2014-02-09 at 04:53 PM.
    NPVR Tech Support Sticky - - http://forums.nextpvr.com/showthread...931#post480931
    ---------------------------
    my server: NPVR 4.2.2/Win10Pro 32-bit/AMD A6-7400K/hvr-2250 & hvr-1250 with Winegard Flatwave antenna/Schedules Direct
    playback client: Google Nexus Player running Android 8/Kodi 16.1 (last version with good 1080i MPEG-2 playback) & X-NEWA 2.5.1

  3. #13
    Join Date
    May 2006
    Location
    Canada
    Posts
    27,759
    I must have cut the wrong example for Vevo. Just remove that stationlist for now.

    Martin

  4. #14
    Join Date
    Sep 2008
    Location
    California
    Posts
    7,230
    yes, that fixes the unhandled exception, thanks.
    NPVR Tech Support Sticky - - http://forums.nextpvr.com/showthread...931#post480931
    ---------------------------
    my server: NPVR 4.2.2/Win10Pro 32-bit/AMD A6-7400K/hvr-2250 & hvr-1250 with Winegard Flatwave antenna/Schedules Direct
    playback client: Google Nexus Player running Android 8/Kodi 16.1 (last version with good 1080i MPEG-2 playback) & X-NEWA 2.5.1

  5. #15
    Join Date
    May 2006
    Location
    Canada
    Posts
    27,759
    Quote Originally Posted by johnsonx42 View Post
    yes, that fixes the unhandled exception, thanks.
    Ok I fixed my example, it is a Station not StationList VevoTV is a great example of OTT HD broadcasting if you have the bandwdith

    Martin

  6. #16
    Join Date
    Oct 2008
    Location
    Severn Estuary (Mendip) UK
    Posts
    1,164
    I have been testing your example for Internet TV -

    1) Some of the links in the Stationlist work fine but there are a lot of "File Unavailable" etc. I presume that is the nature of the beast?
    2) The Vevo TV link chucks me off could that be because I am not in North America? - Although I found a link in the Whuffclee list for it that worked OK.
    3) Last Played shows the TV links - but they will not load from there, I always have to go back to the original link in Internet Television.
    4) Can we use an XBMC xml file as a StationList similar to:

    Code:
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    
    <items>
    
    <item>
    <title>01 联合新闻网 </title>
    <link>mms://udnlive.media.hinet.net/bc000093</link>
    <thumbnail>http://david-link.googlecode.com/svn/trunk/icons/news/udn.jpg</thumbnail>
    </item>
    
    <item>
    <title>02 凤凰卫视资讯台</title>
    <link>mms://112.230.192.196/zb12</link>
    <thumbnail>http://david-link.googlecode.com/svn/trunk/icons/news/fenghuangzixun.jpg</thumbnail>
    <fanart>http://david-link.googlecode.com/svn//trunk/icons/background/fenghuang.jpg</fanart>
    </item>
    
    <item>
    <title>39 香港卫视 </title>
    <link>http://zb.v.qq.com:1863/?progid=2584831218</link>
    <thumbnail>http://imgsrc.baidu.com/baike/abpic/item/b7bc4c66ba285765ab184ca4.jpg</thumbnail>
    </item>
    Don't know if any of the stations will stream but it might be worth a go.

    Finally
    Anyone using Internet TV with the icon packs from the wiki will want this one. (Once you update the wiki version to WebRadio 4.0 I will update the install instructions and put it in the RadioLogo pack)
    Attached Images Attached Images  
    Attached Files Attached Files
    Last edited by Lao Pan; 2014-02-14 at 02:01 PM. Reason: Added TVFolder.png in zip
    It's not an overly complicated system - it's more - overly simple operatives

  7. #17
    Join Date
    May 2006
    Location
    Canada
    Posts
    27,759
    Quote Originally Posted by Lao Pan View Post
    1) Some of the links in the Stationlist work fine but there are a lot of "File Unavailable" etc. I presume that is the nature of the beast?
    You will get many that fail for sure. Bad link and 1 million XBMC users don't help. If you run in Windows in a window on PC the hidden menu has a debug optionand you might see something more detailed. ie mmsh isn't support but you might be able to change those links to rtsp.

    Also anything that requires scraping will fail, those are of dubious origin anyway.

    2) The Vevo TV link chucks me off could that be because I am not in North America? - Although I found a link in the Whuffclee list for it that worked OK.
    Geo-blocking is certainly going to be an issue for several links

    3) Last Played shows the TV links - but they will not load from there, I always have to go back to the original link in Internet Television.
    That is there to help you find a a link in a plx file, I figured it was easier than logging it.

    4) Can we use an XBMC xml file as a StationList similar to:
    A plx file should be able to be saved and played from your disk. It is recommended for those that are worried about adult content that might be available when just going via the online lists (also why TVStations.xml is not included in the installer)

    Martin

  8. #18
    Join Date
    Oct 2008
    Location
    Severn Estuary (Mendip) UK
    Posts
    1,164
    Just added the TVFolder png in a zip to the post above - didn't realize the forum turned all images into jpg mush.
    It's not an overly complicated system - it's more - overly simple operatives

  9. #19
    Join Date
    May 2006
    Location
    Canada
    Posts
    27,759
    In the unlikely event that anyone tried Shoutcast with WebRadio and had problems and didn't post, the problem has been resolved. My dev ID wasn't properly moved over on the 17th when the changes from the purchase of Shoutcast from AOL to Radionomy started kicking in.

    Martin

  10. #20
    Join Date
    Oct 2008
    Location
    Severn Estuary (Mendip) UK
    Posts
    1,164
    Worked last week-end - worked this week-end
    Thanks
    It's not an overly complicated system - it's more - overly simple operatives

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •