Page 12 of 13 FirstFirst ... 210111213 LastLast
Results 111 to 120 of 121

Thread: NextPVR - EPG Setup - XML/XMLTV EPG - Zap2it & Zap2xml

  1. #111
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    91,118
    Quote Originally Posted by donm168@gmail.com View Post
    This has been an issue for me for months. I have been able to work my way through my problems until now. The last time I had things working - somewhat - I had to run the routine manually. If I forgot, the menu would eventually be empty. Now, I can't even get that done. It appears to me that everything is OK except that the data does not appear in the Menu. I tried the suggested (-a) but that made no difference.
    Looks like you've had no listings in your C:\Users\Public\NPVR\Scripts\epg.xml file the last couple of nights when NextPVR read the file. ie, some bug in whatever you're running in UpdateEPG.bat

  2. #112
    Join Date
    Apr 2017
    Location
    US
    Posts
    9
    I just discovered that the mapping I have done previously has somehow changed. Further, the listing of choices for mapping I am presented with does not match the choices I have made at zap2it. Does anyone know how I can change that? Most likely, a question for zap2it.

  3. #113
    Join Date
    Apr 2017
    Location
    US
    Posts
    9
    Well, what do you know about that? The answer to MY problem was me (again). Apparently, some time ago, I logged in and checked program listings for another provider. I logged in again a while ago and checked the listings I am looking for in NPVR. And, there it is, working like it should have once I mapped them all again. The unexplained thing is that I have been checking the same listings in a browser and seeing exactly what I wanted but without logging in. Whatever you were checking when you last logged in, that is what the station listing will show.

  4. #114
    Join Date
    Dec 2015
    Location
    USA
    Posts
    11
    I think i'm having a problem similar to what some other people were describing... I was working great with the old zap2xml and it stopped working. (not logging in) I upgraded to the new version, it is logging in fine, using the same update.bat file.. it creates my channels.xml files, but when I go into NextPVR i'm not seeing anything in the guide. I cleared the cache folder, and cleared the EPG in next PVR. tried the -a switch someone suggested, but still nothing...any ideas? thanks

  5. #115
    Join Date
    Mar 2006
    Location
    Montreal, Canada
    Posts
    765
    Follow the steps in post #103 especially the last step since channel id's have changed on zap2it.com so your old nextpvr channels won't match with anything in your new channels.xml file.

  6. #116
    Join Date
    May 2019
    Location
    USA
    Posts
    1
    I got this working thanks for the first post. I apologize in advance if this is answered somewhere already, but how do I run the UpdateEPG.bat on a timer so I don't have to do it manually every 10 days or whatever?

  7. #117
    Join Date
    May 2006
    Location
    Canada
    Posts
    29,134
    UpdateEPG.bat is run every time you do any EPG update. Users typically do this with a daily run with a run time setup in Settings. It is best to choose a time when no recordings are typically taking place.

    Note that this part of zap2xml configuration has been the hardest for many users.

    Martin

  8. #118
    Join Date
    Jun 2019
    Location
    United States
    Posts
    1
    THANKS so much for this How To...priceless for my situation living in very low signal level location, 95-miles from transmitters having horrible EPG population reliability. This is fantastic! Thanks again for your time and effort!

  9. #119
    Join Date
    Jun 2019
    Location
    Long Beach,CA USA
    Posts
    1
    pulling data from a zap2it account
    It fails for me, it tries to access a non existant file
    [133] Post SH00733129: https://tvlistings.zap2it.com/api/pr...verviewDetails

    [D] Parsing: EP007331290387
    [134] Post SH02396142: https://tvlistings.zap2it.com/api/pr...verviewDetails

    Failed to open 'cache/OEP023961420067.js.gz': Invalid argument at script/zap2xml.pl line 987.

  10. #120
    Need help. Followed the instruction and it works up to "Update EPG" button in Settings>Channel. My issue is "Auto Update EPG". After the preset EPG Update Hour, there's no update. If this is user vs localsystem issue, how to fix?

    Found a workaround in Windows 10. I created another batch file called updateepgonly.bat with these 2 lines.

    @ECHO OFF
    "C:\Program Files (x86)\NPVR\nextpvr.exe" -updateepgonly

    Then in windows "Task Scheduler", created a basic task to run this batch file daily.
    Last edited by acegolfer; 2019-08-11 at 11:59 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •