Results 1 to 5 of 5

Thread: Oh no! Request cannot be processed!

  1. #1
    Join Date
    Oct 2007
    Location
    Redmond, WA USA
    Posts
    132

    Oh no! Request cannot be processed!

    All
    After years of trouble free service my PC died from a power-outage induced surge. I have built a new one and have NPVR running but ... can't get my NMTs up! I get to the NPVR.html menu, but when I click NPVR I get the dreaded message. This is a Windows 10 PC, I have edited npvr.cgi to use my username and password for mounting /etc/mvpmc (using vim as the editor) and substituted my sharename in the NPVR.html. I have C:\mvpmc shared with Guest and with my personal id. Windows Firewall has npvr in the allowed program list. One strange thing is that if I use the network browser on the PCH and navigate to the media server it says no content found. Below is the Syntax Checker output. Any suggestions greatly appreciated!

    Checking for mvpmc share on MEDIA-SERVER
    mvpmc C:\mvpmc

    Checking GB-PVR.html links
    C:\mvpmc \GB-PVR.html not found

    NMT IP Address: 192.168.1.4 MAC 0006DC80C496

    GB-PVR Not Installed

    N-PVR Installed C:\Users\Public\NPVR
    <a href="http://localhost.drives:8883/NETWORK_SHARE/NPVR/npvr.cgi">N-PVR</a>
    <a href="http://localhost.drives:8883/NETWORK_SHARE/NETWORK_BROWSER/browser.cgi">N-PVR via Network Browser</a>
    <a href="http://localhost.drives:8883/USB_DRIVE_A-1/mvpmc/usb_a.cgi">N-PVR via USB</a>

    config.xml entry found Client Type PCH2
    MVPName Family Room
    MVPClientType PCH2
    MVPWidth 1280
    MVPHeight 720
    MVPOffsetX 0
    MVPOffsetY 0
    MVPSendIncrementalUpdates true
    MVPAspectRatio default
    MVPSkin Default
    MVPPreferredMenuStyle slideout

    Enabled true
    Port 8866

    The remote server returned an error: (404) Not Found.

    Checking NMT Version
    01-17-080818-15-POP-403-091

    Checking NMT Display
    &nbsp;&nbsp;AUTO

    Calling NMT Source
    NPVR
    smb://MEDIA-SERVER/mvpmc Username: drbenjamin Password Length: 8
    2 HD-PVRs, G4400 w/ 4GB RAM, 12 TB HD, Windows 10 Pro, 2 PCH A110, 1 eGreat m34A

  2. #2
    Join Date
    Oct 2007
    Location
    Redmond, WA USA
    Posts
    132
    Bumping my thread here. I've tried to fix this on and off but still no joy. I've tried editing all the files in the mvpmc dir, currently npvr.cgi loks like this (password x'd out). The IP address is correct, can't find any errors in my windows or npvr logs. I've added the guest user registry hack described on this site, C:\mvpmc is shared with everyone, guest,guests and drbenjamin. thanks for any suggestions

    cd ~
    if [ -f /etc/mvpmc/mvpmcx2 ]
    then
    echo "mvpmcx2 is loaded";
    else
    echo "Mounting ..."
    mkdir /etc/mvpmc
    mount -t cifs //192.168.1.15/mvpmc /etc/mvpmc -o username=drbenjamin,password=xxxxxxxx,rw
    cp /etc/mvpmc/utelnetd /usr/bin
    ln -s /lib/librmjpeg.so /lib/libjpeg.so.62
    ln -s /lib/librmzlib.so /lib/libz.so
    ln -s /lib/librmzlib.so /lib/libz.so.1
    ln -s /lib/librmzlib.so /lib/libz.so.123
    utelnetd -l /bin/sh -p 23 &
    echo "Telnetd started on port 23............";
    fi
    killall gaya
    sh -c /etc/mvpmc/startmeup 2>/dev/null >/dev/null &
    exit 0;
    2 HD-PVRs, G4400 w/ 4GB RAM, 12 TB HD, Windows 10 Pro, 2 PCH A110, 1 eGreat m34A

  3. #3
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,048
    I see at least two things in your original post

    - from the Dummies Guide you have to change from the Auto format
    - It doesn't look like you let NMT Install create things so the call to npvr.cgi may not work it should be something like this if you used the defaults

    Code:
     <a href="http://localhost.drives:8883/NETWORK_SHARE/MEDIA-SERVER:mvpmc/npvr.cgi">N-PVR</a>

    For Windows 10 you may need to enable 40-56 bit encryption.

    Martin

  4. #4
    Join Date
    Oct 2007
    Location
    Redmond, WA USA
    Posts
    132
    Thanks Martin. I reinstalled NMT using the NMTInstall2 from the Wiki. I named my share on the PCH back to MEDIA-SERVER:mvpmc. Now my NMTChecker gives

    GB-PVR Not Installed

    N-PVR Installed C:\Users\Public\NPVR
    <a href="http://localhost.drives:8883/NETWORK_SHARE/MEDIA-SERVER:mvpmc/npvr.cgi">N-PVR</a>
    <a href="http://localhost.drives:8883/NETWORK_SHARE/NETWORK_BROWSER/browser.cgi">N-PVR via Network Browser</a>
    <a href="http://localhost.drives:8883/USB_DRIVE_A-1/mvpmc/usb_a.cgi">N-PVR via USB</a>

    config.xml entry found Client Type PCH2
    MVPSendIncrementalUpdates true
    MVPClientType PCH2
    MVPWidth 1280
    MVPHeight 720
    MVPOffsetX 0
    MVPOffsetY 0

    Enabled true
    Port 8866

    The remote server returned an error: (404) Not Found.

    Checking NMT Version
    01-17-110314-15-POP-403-000

    Checking NMT Display
    720p 60Hz

    Calling NMT Source
    MEDIA-SERVER:mvpmc
    smb://media-server/mvpmc Username: drbenjamin Password Length: 8

    This time I am getting to a white screen with black text saying

    mount \\192.168.1.15\mvpmc i

    I have left the following line in npvr.cgi

    mount -t cifs //192.168.1.15/mvpmc /etc/mvpmc -o username=root,rw

    Do I need to change the username? For some reason I though I needed my Windows credentials in that spot but now I"m not sure.

    #Edit - changed the mount line to use my windows login instead of "root" and it all works. Looking back between my original install and this new one I don't see any differences that account for the failure, but it's working and my WAF is back up

    thanks again
    Last edited by drbenjamin; 2016-12-26 at 10:44 PM.
    2 HD-PVRs, G4400 w/ 4GB RAM, 12 TB HD, Windows 10 Pro, 2 PCH A110, 1 eGreat m34A

  5. #5
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,048
    Great. Root would only work if you have your PC share open, you have it restricted which I don't recommend because it makes support harder.

    Martin
    Last edited by mvallevand; 2016-12-27 at 05:47 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •