Results 1 to 3 of 3

Thread: Recording service not running

  1. #1
    Join Date
    Aug 2016
    Location
    UK
    Posts
    3

    Recording service not running

    Would it be possible for NextPVR to check if the recording service is running prior to the recording time, and if not for the recording service to start.

    I'm not sure if this is possible to do, but could the tray icon process do this perhaps as right clicking on the tray icon does give the option to restart the recording process.

    I thought that if a tv show/film/whatever was due to start at 12pm, and it had a 1 minute padding to the start, then a process could check if the recording process was running at 11:58am and if it was running for it to make an attempt to restart it. This shouldn't affect programs that are currently recording as the recording process must be running for those programs to be recording.

    This should stop the errors of "Recording service not running at recording time".

  2. #2
    Join Date
    Aug 2006
    Location
    nr Brighton, UK
    Posts
    713
    A simple batch file that runs before recordings or (say) every five minutes would solve this problem. But it would be neater if it were included...
    - Silent client PVR: HDPlex HS.1 aluminium fanless case / Thin-ITX ASRock H81TM-ITX motherboard / Intel Celeron 1850T CPU / 4GB RAM / 120GB SSD / TBS6982 DBS-S2 dual-tuner card / Win10+nPVR+Plex Media Player feeding LG OLED55B6V + Anthem MRX510 AV Receiver / PMC GB1 / B&W / REL speakers.
    - Noisy NAS: Xeon / Intel mobo / 16GB RAM / FreeNAS + Ubuntu VMs on VMware ESXi + 12TB RAID
    running Plex Media Server


  3. #3
    Join Date
    Sep 2008
    Location
    California
    Posts
    7,111
    having some sort of "recording service watchdog" on the system tray app isn't a bad idea, but why isn't your recording service running at recording time in the first place? better to solve the root of the problem.
    NPVR Tech Support Sticky - - http://forums.nextpvr.com/showthread...931#post480931
    ---------------------------
    my server: NPVR 4.0.4/Win10Pro 32-bit/AMD A6-7400K/hvr-2250 & hvr-1250 with Winegard Flatwave antenna/Schedules Direct
    playback client: Google Nexus Player running Android 7.1.2/Kodi 17.3 (bad 1080i MPEG-2 playback) & X-NEWA 2.5.1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •