Results 1 to 9 of 9

Thread: Buffer Continuing after Kodi Close/Live TV Stop

  1. #1
    Join Date
    Sep 2016
    Location
    usa
    Posts
    3

    Buffer Continuing after Kodi Close/Live TV Stop

    Hi,

    I am having an issue where NextPVR misses (or Kodi never sends) the stop/close connection to the NextPVR backend and therefore the stream continues to buffer until eventually the HDD runs out of space.

    The only error I see is when I close Kodi I see the following:


    16:37:18 T:7440 FATAL: C:\Program Files (x86)\Kodi\addons\pvr.nextpvr\pvr.nextpvr.dll is a system dll and should never be released
    16:37:18 T:7440 NOTICE: application stopped...
    16:37:18 T:7440 FATAL: /libcurl.dll is a system dll and should never be released
    16:37:18 T:7440 FATAL: /cpluff.dll is a system dll and should never be released
    16:37:18 T:7440 FATAL: /cec.dll is a system dll and should never be released

    BTW this occurred in both Jarvis and the new Krypton Beta2.

    Thanks
    Attached Files Attached Files
    Last edited by liquidbad; 2016-10-09 at 01:03 PM.

  2. #2
    Join Date
    Jan 2016
    Location
    Cayman Islands
    Posts
    71
    Hello liquidbad I was just checking the forums to see if anyone had reported on the status of this issue after the last update. I found it to be exactly the same as before and the v3.8.3 change log does not mention doing anything in regards to live TV while using Kodi so it looks like this has not been resolved. I've since just switched exclusively to NextPVR for live TV until it is resolved.

  3. #3
    Join Date
    Oct 2016
    Location
    United States
    Posts
    1
    I'm having the same issue as noted here. I'm using Kodi as the PVR front end. This is very disappointing as I think NPVR is the only backend that supports cablecard and Kodi. And I can't bring myselff to go back to WMC.

  4. #4
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    84,520
    If you guys want to supply the logs showing this happen, I'm happy to take a look.

  5. #5
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,770
    I don't think there is a heartbeat in timeshifting mode so if Kodi is killed or crashes and no shutdown signal is received this is possible. If you turn off timeshifting that would help.

    Martin

  6. #6
    Join Date
    Sep 2016
    Location
    usa
    Posts
    3
    Hi Sub,

    I've attached the debug logs to original post.

    @Martin--this happens even when I go through the normal shutdown procedure of Kodi, it's not limited to crashes. Not sure if kodi is bad about have a defined shutdown routine or not though. I've also gone ahead and testing turning on and off timeshifting. While turning timeshifting off does eliminate the issue of having the tuner staying tuned/buffering. It yields unwatchable TV that stutters and continuously tries to rebuffer mid stream.

    Thanks
    liq
    Last edited by liquidbad; 2016-10-21 at 11:36 AM.

  7. #7
    Join Date
    Jan 2016
    Location
    Cayman Islands
    Posts
    71
    Hello Sub,

    I was just looking through the old posts I've made on this subject (link below). This is from my post a few months ago, I'm not sure if this ever got resolved so I had tried posting this issue on the Kodi forum just a day or two ago, but I have not gotten any response from them yet. After having posted this topic here before I assumed this was not an issue with NextPVR. I can also get some new logs as it's easily reproduce-able and happens every time liveTV is watched with Kodi and NextPVR as the DVR backend.

    http://forums.nextpvr.com/showthread...ht=#post503510

  8. #8
    Join Date
    Nov 2016
    Location
    Canada
    Posts
    1
    Hello,

    If I may offer some information to assist in this issue. I have Kodi 16.1 with NPVR on a Win 7 machine, Hauppauge WinTV dual HD tuner. I'm not sure when it started but for at least a couple of months, approximately 90% of the time when I stop a TV channel in Kodi, the NPVR Live TV buffering continues (red (n) in notification icon, .ts files build in the live TV buffer). I've attached a log where, from a clean system start, I start and stop a channel and after a few times failing (buffer continues) one time success followed by a dozen or so failures then one more success where I ended. It seems like some race condition related to the Kodi add-on.
    Of interest, the process succeeds 100% of the time from any of my other Kodi client machines, it is only with Kodi on the same machine as NPVR server where this issue occurs.

    Cheers,
    Shawn
    Attached Files Attached Files

  9. #9
    Join Date
    Jan 2016
    Location
    Cayman Islands
    Posts
    71
    Hello All,

    I just upgraded my kodi media centre to v17rc3 and this issue has ceased to happen. I did also just upgrade my pc to win10 so I am not sure if that has anything to do with why this issue has ended so I'm assuming it was kodi v17rc3 that has rectified this issue. What ever was happening must have been because of kodi because it's fine now. I've been testing this for a week just to make sure it was settled and I've switched to watching livetv with kodi exclusively and have had no problems with it buffering afterward, and the temp file created is immediately deleted or just changes to the new channel tuned just like if I was using nextpvr.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •