Results 1 to 6 of 6

Thread: Refresh Rate Problem

  1. #1
    Join Date
    Jan 2011
    Location
    North Gloucestershire, England
    Posts
    723

    Refresh Rate Problem

    On my main TV although my RPi2 runs 1080p at 50Hz OK both my AMD E450 and Intel Celeron powered nettop PCs will only run at 24Hz or 30Hz. It seems to be some incompatibility between this particular TV and LibreElec/KODI as both PCs when connected to other TVs run at up to 50Hz & 60Hz at 1080p.

    As a work around I am using the KODI Player setting “Adjust Display Refresh Rate” which seems OK. Will it be best to run at 24Hz or 30Hz for best results or wont it matter? The other option is to playback at 720p which offers 50 Hz playback.

    Chris
    NextPVR Server - HP N54L Microserver, Windows 7 - Storage 2 X 3TB in Windows mirror- Tuners DVBSky S952 Twin DVB-S/S2 PCIe, August T210 DVB-T/T2 USB, KWorkd UB499-2T Twin DVB-T USB.
    Clients RPi2 & Acer RL80 Celeron Nettop both running X-NEWA on LibreElec.

  2. #2
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,560
    Did you try different HDMI ports on your TV? Often they use different chipsets with different functionality. Note the GUI resolution and video resolution may be different too.

    For playing your 25/50 PAL videos you probably will be the best critic.

    Martin

  3. #3
    Join Date
    Jan 2011
    Location
    North Gloucestershire, England
    Posts
    723
    The problem seems to be with the Linux driver not correctly detecting what refresh rate that particular Sharp TV can do as I ran Ubuntu on a live USB drive on the same setup and that also only offered 24Hz and 30Hz refresh.

    Running with “Adjust Display Refresh Rate” set seems a good work around as I cannot detect any objectionable flicker on SD or HD recordings. I dont know if its running at 25Hz or 50Hz at unlike my Samsung TV the Sharp does not report changes in the video signal.

    The RPi2 has played all SD and HD without a problem for about a year but at some point possibly when I installed LibreElec 8 Alpha/Beta to run Kodi 17 "Skip" became irritating as it would miss about 1 in 4 skips.

    Chris
    NextPVR Server - HP N54L Microserver, Windows 7 - Storage 2 X 3TB in Windows mirror- Tuners DVBSky S952 Twin DVB-S/S2 PCIe, August T210 DVB-T/T2 USB, KWorkd UB499-2T Twin DVB-T USB.
    Clients RPi2 & Acer RL80 Celeron Nettop both running X-NEWA on LibreElec.

  4. #4
    Join Date
    Jan 2011
    Location
    North Gloucestershire, England
    Posts
    723
    Running at 30Hz which is the highest refresh offered I was not able to detect any problem during any programme except the credits at the end which don't move as smoothly up as they should! However yesterday son came to visit and while we watched a Simpsons HD recording he complained about the picture flicker! On closer examination I could see it also and was most noticeable on thin horizontal lines which jitter up and down a bit like slow interlacing! Perhaps the temporary solution is until I find a fix is to use the RPi2 if I want to watch the Simpsons!! This jitter is not noticeable on other recordings so far even with close examination so will use the Nettop PC while looking for a solution!!

    Chris
    NextPVR Server - HP N54L Microserver, Windows 7 - Storage 2 X 3TB in Windows mirror- Tuners DVBSky S952 Twin DVB-S/S2 PCIe, August T210 DVB-T/T2 USB, KWorkd UB499-2T Twin DVB-T USB.
    Clients RPi2 & Acer RL80 Celeron Nettop both running X-NEWA on LibreElec.

  5. #5
    Join Date
    Jan 2011
    Location
    North Gloucestershire, England
    Posts
    723

    [SOLVED] Refresh Rate Problem

    This web page solved my problem:-


    http://wiki.openelec.tv/index.php?ti...conf#tab=Intel

    Created xorg.conf in .config directory and in my case copied Intel data to the file and after reboot 1080p x 50Hz is an option in Kodi.

    (Link should now work!)

    Chris
    Last edited by jcjefferies; 2017-02-28 at 12:57 AM. Reason: Corrected faulty link
    NextPVR Server - HP N54L Microserver, Windows 7 - Storage 2 X 3TB in Windows mirror- Tuners DVBSky S952 Twin DVB-S/S2 PCIe, August T210 DVB-T/T2 USB, KWorkd UB499-2T Twin DVB-T USB.
    Clients RPi2 & Acer RL80 Celeron Nettop both running X-NEWA on LibreElec.

  6. #6
    Join Date
    Jul 2005
    Location
    HK - Pal I
    Posts
    3,217
    Quote Originally Posted by jcjefferies View Post
    This web page solved my problem:-

    http://wiki.openelec.tv/index.php?title=...#tab=Intel

    Chris
    Hi Chris - bad link?
    ASUS P5K-PRO Q9300 2.5GHz | Win10x64 | 6GB RAM | NVIDIA GEforce 210 | 1 x WinTV DMB-TH | Various HD's | AC68U | USB-UIRT | PCH-A110 | Hauppauge Colossus |
    If you've ever become frustrated because something in NextPVR is not working, take a moment and consider this and this and this and this and this and this. Credit where credit's due; for one guy (with a wife and two kids), most problems are solved outrageously quickly. Patience.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •