Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: TV Listing crashing

  1. #11
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,564
    Quote Originally Posted by sub View Post
    Martin, are you see this with your plugins too? If so, if you run it up in the debugger what looks like it's failing when your plugin is loading?

    In that stack trace above, it looks like the TVListings plugin has loaded, and starts running, but encounters some issue loading some xml from somewhere. Hard to guess what this is doing without the source code to it.
    I saw it with a tuner plugin and will try to go into my other plugin settings tomorrow.

    Martin

  2. #12
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,564
    Quote Originally Posted by mvallevand View Post
    I saw it with a tuner plugin and will try to go into my other plugin settings tomorrow.
    I can confirm plugins aren't loaded from the NTray Show Settings option, the option to configure them is even missing. Most of the NextPVR init logic is skipped from this option.

    Martin

  3. #13
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    83,860
    Is the constructor code run?

  4. #14
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,564
    Quote Originally Posted by sub View Post
    Is the constructor code run?
    No not for my plugins, but plugin discovery isn't even done so I can't imagine TV Listings even runs. This is more about the comments about not being able to configure plugins.

    Martin

  5. #15
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    83,860
    Do you have these types of messages in your log:
    2017-03-12 16:58:21.412 [DEBUG][1] About to look for plugin directories in: C:\Users\Public\NPVR\Plugins\
    2017-03-12 16:58:21.412 [DEBUG][1] About to look for plugin directories in: C:\Program Files (x86)\NPVR\Plugins\
    and then for dlls found:
    2017-03-12 16:58:21.412 [DEBUG][1] About to check for plugin interfaces in: C:\Program Files (x86)\NPVR\Plugins\TV Listings\TV Listings.dll

  6. #16
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,564
    No and neither does the op in his logs from -settings if I recall correctly.

    Martin

  7. #17
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    83,860
    Those messages quoted above were from his log when TVListings was crashing with that message.

  8. #18
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    83,860
    Checking the code, it looks like it should always go looking for plugins. ie, there is no conditional logic stuff whether it goes looking. It should happen immediately after a "Load@1" message (which was the last message unrelated to plugins).

  9. #19
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,564
    Quote Originally Posted by sub View Post
    Checking the code, it looks like it should always go looking for plugins. ie, there is no conditional logic stuff whether it goes looking. It should happen immediately after a "Load@1" message (which was the last message unrelated to plugins).
    There is no Load@1 message when you use the -settings command line option or ShowSettings from NTray as a ControllerForm with all the good stuff is never instantiated. The OP's post http://forums.nextpvr.com/showthread...338#post513338 has an example and crash.

    Martin

  10. #20
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    83,860
    You could see if this patch helps.
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •