Results 1 to 10 of 10

Thread: Recordings starting 10 mins late

  1. #1
    Join Date
    Aug 2006
    Location
    Wellington, NZ.
    Posts
    277

    Recordings starting 10 mins late

    I've been seeing an occasional issue occur since the Win 10 creators update - recordings seem to miss the first 10 mins.

    Here's an example from the log

    2017-05-17 17:59:00.121 [INFO][58] DigitalRecorder.StartStream(F:\Recorded TV\Newshub Live At 6pm\Newshub Live At 6pm_20170517_18001900.ts)
    2017-05-17 17:59:00.121 [INFO][58] Creating BDA graph
    2017-05-17 17:59:00.121 [DEBUG][58] Using tuner: Silicondust HDHomeRun Tuner 1110C493-0 (1)
    2017-05-17 17:59:00.121 [INFO][58] [14fbe79c-b17c-06de-4c000000bca7b201]-14fbe7d8-00000000
    2017-05-17 17:59:00.121 [DEBUG][58] About to connect...
    2017-05-17 17:59:00.121 [DEBUG][58] has network provider
    2017-05-17 17:59:00.121 [DEBUG][58] has tuner
    2017-05-17 17:59:00.137 [DEBUG][58] About to auto detect capture filter...
    2017-05-17 17:59:00.137 [DEBUG][58] Skipping capture filter detection
    2017-05-17 17:59:00.137 [DEBUG][58] No BDA capture filter for this device
    2017-05-17 17:59:00.137 [DEBUG][58] Activating time machine
    2017-05-17 17:59:00.137 [DEBUG][58] Time machine activated...
    2017-05-17 17:59:00.152 [DEBUG][58] EIT collection started
    2017-05-17 17:59:00.152 [DEBUG][58] Graph filter list:
    2017-05-17 17:59:00.152 [DEBUG][58] - MPEG-2 Sections and Tables
    2017-05-17 17:59:00.152 [DEBUG][58] - BDA MPEG2 Transport Information Filter
    2017-05-17 17:59:00.152 [DEBUG][58] - MPEG-2 Demultiplexer
    2017-05-17 17:59:00.152 [DEBUG][58] - NPVR TS Mon
    2017-05-17 17:59:00.152 [DEBUG][58] - Tuner
    2017-05-17 17:59:00.152 [DEBUG][58] - Network Provider
    2017-05-17 17:59:00.152 [INFO][58] About to start BDA graph
    2017-05-17 17:59:00.152 [DEBUG][58] Starting graph...
    2017-05-17 17:59:00.155 [DEBUG][58] Calling LockChannel()
    2017-05-17 17:59:00.155 [DEBUG][58] locked=0, present=0, strength=0, quality=0 (took 0ms to check)
    2017-05-17 17:59:00.155 [DEBUG][58] About to tune BDA graph:
    <tuning>
    <type>DVB-T</type>
    <locator>
    <frequency>562000</frequency>
    <bandwidth>8</bandwidth>
    </locator>
    <service_id>1300</service_id>
    <tsid>31</tsid>
    <onid>8746</onid>
    <service_type>25</service_type>
    <provider>Mediaworks</provider>
    </tuning>

    2017-05-17 17:59:00.155 [DEBUG][58] DigitalRecorderDVBT::Tune@1
    2017-05-17 17:59:00.155 [DEBUG][58] DigitalRecorderDVBT::Tune@2
    2017-05-17 17:59:00.155 [DEBUG][58] DigitalRecorderDVBT::Tune@3
    2017-05-17 17:59:00.155 [DEBUG][58] DigitalRecorderDVBT::Tune@4
    2017-05-17 17:59:00.165 [DEBUG][58] DigitalRecorderDVBT::Tune@5
    2017-05-17 18:09:00.325 [DEBUG][58] DigitalRecorderDVBT::Tune@post
    2017-05-17 18:09:00.325 [DEBUG][58] whoosh whoosh
    2017-05-17 18:09:07.279 [DEBUG][58] Calling LockChannel()
    2017-05-17 18:09:07.279 [DEBUG][58] locked=0, present=0, strength=0, quality=0 (took 0ms to check)
    2017-05-17 18:09:07.279 [DEBUG][58] File size is 0
    2017-05-17 18:09:07.279 [INFO][58] DigitalRecorder.StartStream() allocated handle: 0x12
    2017-05-17 18:09:07.279 [DEBUG][58] Temp at 17/05/2017 18:09:17
    2017-05-17 19:02:00.190 [INFO][180] DigitalRecorder.StopStream() handle: 12
    2017-05-17 19:02:00.320 [INFO][180] No more streams active. Stopping device.
    2017-05-17 19:02:00.320 [DEBUG][180] About to request async graph stop
    2017-05-17 19:02:00.320 [DEBUG][179] Graph stopping... (async)
    2017-05-17 19:02:00.345 [DEBUG][179] Graph reports state 'Stopped'
    2017-05-17 19:02:00.345 [DEBUG][179] Graph stopped (async)
    2017-05-17 19:02:00.345 [DEBUG][180] Async stop completed successfully
    2017-05-17 19:02:00.351 [DEBUG][180] Removing filter MPEG-2 Sections and Tables
    2017-05-17 19:02:00.351 [DEBUG][180] Removing filter BDA MPEG2 Transport Information Filter
    2017-05-17 19:02:00.351 [DEBUG][180] Removing filter MPEG-2 Demultiplexer
    2017-05-17 19:02:00.351 [DEBUG][180] Removing filter NPVR TS Mon
    2017-05-17 19:02:00.351 [DEBUG][180] Removing filter Tuner
    2017-05-17 19:02:00.351 [DEBUG][180] Removing filter Network Provider

    On the main recordings screen it shows the 6pm - 7pm time but the recording actually starts at 6:09pm so I miss the first 10 mins.

    This issue will not occur for a couple of days after a system reboot but then seems to happen continually until a reboot and it then comes right again.

    Any ideas sub?

  2. #2
    Join Date
    Dec 2005
    Location
    UK
    Posts
    2,409
    Is there a ndigitalhost log, or its equivalent, for the same time period?
    AMD A75, 4 Gig, 1000 Gig, Nvidia N210
    1 x Hauppauge WinTV QuadHD DVB-T2
    1 x TBS 6281 dual DVB-T2
    2 x Hauppauge Nova-t PCI

  3. #3
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    84,021
    2017-05-17 17:59:00.165 [DEBUG][58] DigitalRecorderDVBT::Tune@5
    2017-05-17 18:09:00.325 [DEBUG][58] DigitalRecorderDVBT::Tune@post
    Yeah, that is strange to see a big delay like that. I'd be looking for updated drivers for your capture device. Between those "Tune@5" and "Tune@post" it asks the device to switch to the new channel. This call should complete in milliseconds, not minutes.

  4. #4
    Join Date
    Aug 2006
    Location
    Wellington, NZ.
    Posts
    277
    It's been a long time since I updated my HDHomerun software and firmware so I've done that.. The issue only started occurring with the creators update.

  5. #5
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    84,021
    I'm not sure why you'd be seeing that. I'm not seeing it with my HDHomeRun, and I'm on the Creators update.

  6. #6
    Join Date
    Aug 2006
    Location
    Wellington, NZ.
    Posts
    277
    I've now spent a few hours trying everything to fix this but am no closer to resolving it. Installed latest HDHomeRun software, reinstalled NextPVR and messed with various other things.

    Pretty much after I reboot the PC NextPVR works perfectly for 24-48 hours but after that I can't access the tuner for live tv and recordings start precisely 10 mins late. Reboot and the issue fixes itself again. I've yet to test whether the HDHomeRun software itself can access the tuner when this issue occurs.

  7. #7
    Join Date
    Jun 2013
    Location
    Rock Hill, SC
    Posts
    201
    Just out of curiosity what does the HDHomeRun System log show when this happens.
    http://192.168.1.122/log.html

  8. #8
    Join Date
    Dec 2005
    Location
    UK
    Posts
    2,409
    Quote Originally Posted by scJohn View Post
    Just out of curiosity what does the HDHomeRun System log show when this happens.
    http://192.168.1.122/log.html
    Sadly 192.168.1.122 is part of a private network and there are hundreds of millions of computers with this address ... and none of them are reachable from my machine.
    AMD A75, 4 Gig, 1000 Gig, Nvidia N210
    1 x Hauppauge WinTV QuadHD DVB-T2
    1 x TBS 6281 dual DVB-T2
    2 x Hauppauge Nova-t PCI

  9. #9
    Join Date
    Mar 2006
    Location
    Houston, Texas, USA
    Posts
    748
    Quote Originally Posted by Graham View Post
    Sadly 192.168.1.122 is part of a private network and there are hundreds of millions of computers with this address ... and none of them are reachable from my machine.
    Replace the IP address in the URL with the IP address of YOUR HD HomeRun device.
    E4600 Core2Duo, 4GB RAM, Win7 Pro, HD5570, HDHomeRun Prime, NPVR 3.6.6, 2 Popcorn Hour A-100's and a partridge in a pear tree...
    On a clear disk, you can seek forever...

  10. #10
    Join Date
    Jun 2013
    Location
    Rock Hill, SC
    Posts
    201
    Open File Explorer > In the left hand pane, click on Network. In the main pane under Other Devices you should see your HDHomeRun RUI. Right click on that icon and then click on View Device Webpage. On the webpage, click on System Status and the click on System Log.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •