Results 1 to 10 of 10

Thread: Kodi NPVR does not play/stream TV... ?

  1. #1
    Join Date
    May 2017
    Location
    Plant City, Florida
    Posts
    7

    Kodi NPVR does not play/stream TV... ?

    I have my NPVR backend setup on a Windows 10 box and if I use the NPVR client on the box it all works as advertised.

    On another windows 10 PC I have Kodi loaded with the NPVR front end and all appears fine... it shows the channels, it shows the guide, but it will not play/stream the TV channels to it. I just get a spinning thingy (I am assuming it is buffering) that goes on and on for a long while before I guess it just times out.

    Does anybody have any ideas for this?

    Thank you

    Here is the log I get...

    8:29:24.107 T:5900 NOTICE: VideoPlayer: Opening: pvr://channels/tv/All channels/pvr.nextpvr_7151.pvr
    08:29:24.107 T:5900 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
    08:29:24.107 T:5900 ERROR: DXVA::CProcessorHD::IsFormatSupported: Unsupported format 104 for 1.
    08:29:24.107 T:5900 ERROR: DXVA::CProcessorHD::IsFormatSupported: Unsupported format 105 for 1.
    08:29:24.107 T:4216 NOTICE: Creating InputStream
    08:32:09.032 T:4216 ERROR: AddOnLog: NextPVR PVR Client: Socket::receive: (Winsock error=10054) Connection reset by peer
    08:32:09.032 T:4216 ERROR: CVideoPlayer::OpenInputStream - error opening [pvr://channels/tv/All channels/pvr.nextpvr_7151.pvr]
    08:32:09.032 T:4216 NOTICE: CVideoPlayer::OnExit()
    08:32:09.051 T:5900 NOTICE: CVideoPlayer::CloseFile()
    08:32:09.051 T:5900 NOTICE: VideoPlayer: waiting for threads to exit
    08:32:09.051 T:5900 NOTICE: VideoPlayer: finished waiting
    08:32:09.051 T:5900 NOTICE: CVideoPlayer::CloseFile()
    08:32:09.051 T:5900 NOTICE: VideoPlayer: waiting for threads to exit
    08:32:09.051 T:5900 NOTICE: VideoPlayer: finished waiting
    08:32:09.845 T:9412 ERROR: PVR::CPVRTimerInfoTag::CPVRTimerInfoTag: no epg tag given for epg based timer type (2)!
    08:33:05.431 T:9412 WARNING: CPVRRecording::CPVRRecording - unable to determine channel type. Defaulting to TV.

    More information:

    I can pull up the TV guide on Kodi and have a recording made... I went to the Backend and checked to confirm the recording is being made and it is, and I can play it back on the Backend box... but still no streaming back to Kodi.
    Last edited by Zbugsii; 2017-05-17 at 12:46 PM.

  2. #2
    Join Date
    Dec 2005
    Location
    UK
    Posts
    2,562
    Please attach the logs from the NextPVR backend machine. There is a button at NextPVR Settings --> About that will create a zip file of the logs that can be attached to a post.
    i3-3250, 4 Gig, 1000 Gig, Nvidia N210
    1 x Hauppauge WinTV QuadHD DVB-T2
    1 x TBS 6281 dual DVB-T2
    2 x Hauppauge Nova-t PCI

  3. #3
    Join Date
    May 2017
    Location
    Plant City, Florida
    Posts
    7
    Quote Originally Posted by Graham View Post
    Please attach the logs from the NextPVR backend machine. There is a button at NextPVR Settings --> About that will create a zip file of the logs that can be attached to a post.
    I have attached the log in a zip file...
    Attached Files Attached Files

  4. #4
    Join Date
    May 2006
    Location
    Canada
    Posts
    25,815
    You have configured Kodi to connect over Internet IP, normally you should use the local LAN IP

    2017-05-17 08:29:26.488 [DEBUG][73] Not allowing internet based streaming request

    If you really want to try over internet and have the bandwidth up and down there is a settings in config.xml for AllowRremoteStreaming

    Martin

  5. #5
    Join Date
    May 2017
    Location
    Plant City, Florida
    Posts
    7
    Uhmmm, how do you see that it is configured over internet IP, verses local Lan IP? I sure do not want it this way. Sorry to be so dumb, but where do I change this?

  6. #6
    Join Date
    Dec 2005
    Location
    UK
    Posts
    2,562
    Quote Originally Posted by Zbugsii View Post
    Uhmmm, how do you see that it is configured over internet IP, verses local Lan IP? I sure do not want it this way. Sorry to be so dumb, but where do I change this?
    The web.log.1 file has

    2017-05-17 08:29:26.488 [DEBUG][73] Not allowing internet based streaming request from: 192.174.0.85
    That IP address is a public address (i.e. somewhere on the Internet). Many folk use addresses in the range 192.168.1 .1 to 192.168.1.200 (ish) because those addresses are regarded as private (i.e. somewhere in this, or any, building).

    How do your 'puters get their IP address ? ... Often, the addresses are allocated by the router that provides the connection to the Internet.
    i3-3250, 4 Gig, 1000 Gig, Nvidia N210
    1 x Hauppauge WinTV QuadHD DVB-T2
    1 x TBS 6281 dual DVB-T2
    2 x Hauppauge Nova-t PCI

  7. #7
    Join Date
    May 2017
    Location
    Plant City, Florida
    Posts
    7
    Ah, will my home network is setup with this IP addressing... 192.174.0.1-254, so this really should not be the issue. I have both static IPs and dynamic... servers and NAS are static, most other items are dynamic within the range set.

    So... now what...?

    Oh, and further to this... I just setup my Kodi running on the same box as my backend NPVR with the frontend NPVR and tested it... this works fine. So, somewhere in the networking things are going amuck. And yes, I have checked firewall settings. Remember, I can see all that is going on with the backend, I can issue commands to record, I can see that it is recording... but I can not stream live or recorded TV to my other PC frontend NPVR.

    So, any help would be great.
    Last edited by Zbugsii; 2017-05-17 at 03:50 PM.

  8. #8
    Join Date
    Dec 2005
    Location
    UK
    Posts
    2,562
    Quote Originally Posted by Zbugsii View Post
    Ah, will my home network is setup with this IP addressing... 192.174.0.1-254, so this really should not be the issue.
    Wikipedia and others may disagree ... https://en.wikipedia.org/wiki/Private_network

    NextPVR regards the range 192.174.0.1-254, as part of the public Internet and the default is to not allow streaming to the public Internet. Your options are to change the setting per Martin's post or change the address range used in your home network.
    i3-3250, 4 Gig, 1000 Gig, Nvidia N210
    1 x Hauppauge WinTV QuadHD DVB-T2
    1 x TBS 6281 dual DVB-T2
    2 x Hauppauge Nova-t PCI

  9. #9
    Join Date
    May 2017
    Location
    Plant City, Florida
    Posts
    7
    Well, looks like I will be changing my local network... as I might have issues further on... thanks. I will be away for 1 week, so I will address upon my return.

    And will test it and let all know.

  10. #10
    Join Date
    May 2017
    Location
    Plant City, Florida
    Posts
    7
    Ok, as I stated above... I went about changing my IP scheme for my local network to be in the "public" arena of the internet...

    And yes, it now works properly. So, thank you for pointing this out to me and to others.

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •