Results 1 to 4 of 4

Thread: NextPVR not starting with Kodi on Raspberry Pi 3

  1. #1
    Join Date
    Sep 2017
    Location
    New Zealand
    Posts
    3

    NextPVR not starting with Kodi on Raspberry Pi 3

    I am getting an error message every time I start my Raspberry PI that NextPVR cannot start because of an 'unknown error" I checked the other help on this forum on this subject and can confirm it is using the right IP address for my server. The firewall on the server is open on port 8866 for incoming and outgoing on TCP and UDP. Attached is my log file.

    Thanks

    Simon

    https://paste.ubuntu.com/25526425/

  2. #2
    Join Date
    Sep 2017
    Location
    New Zealand
    Posts
    3
    This seems to show it connected?

    11:09:04.053 35.552593 T:1892676352 DEBUG: SECTION:LoadDLL(/usr/local/lib/kodi/addons/pvr.nextpvr/pvr.nextpvr.so.2.4.13)
    11:09:04.053 35.553204 T:1892676352 DEBUG: Loading: /usr/local/lib/kodi/addons/pvr.nextpvr/pvr.nextpvr.so.2.4.13
    11:09:04.095 35.594944 T:1892676352 INFO: AddOnLog: NextPVR PVR Client: Creating NextPVR PVR-Client
    11:09:04.096 35.595898 T:1892676352 DEBUG: CAddonCallbacksAddon - GetAddonSetting - add-on 'NextPVR PVR Client' requests setting 'host'
    11:09:04.103 35.603184 T:1892676352 DEBUG: CAddonCallbacksAddon - GetAddonSetting - add-on 'NextPVR PVR Client' requests setting 'port'
    11:09:04.106 35.605598 T:1892676352 DEBUG: CAddonCallbacksAddon - GetAddonSetting - add-on 'NextPVR PVR Client' requests setting 'pin'
    11:09:04.108 35.607708 T:1892676352 DEBUG: CAddonCallbacksAddon - GetAddonSetting - add-on 'NextPVR PVR Client' requests setting 'usetimeshift'
    11:09:04.110 35.609741 T:1892676352 DEBUG: CAddonCallbacksAddon - GetAddonSetting - add-on 'NextPVR PVR Client' requests setting 'guideartwork'
    11:09:04.112 35.612267 T:1892676352 DEBUG: AddOnLog: NextPVR PVR Client: settings: host='192.168.1.8', port=8866
    11:09:04.116 35.615669 T:1892676352 DEBUG: CFileCache::Open - opening <service> using cache
    11:09:04.117 35.617203 T:1892676352 DEBUG: CurlFile::Open(0x5c2ff878) http://192.168.1.8:8866/service?meth....0&device=xbmc
    11:09:04.118 35.618435 T:1892676352 INFO: easy_aquire - Created session to http://192.168.1.8


    but later in the log I see:

    11:10:05.340 65.622688 T:1892676352 ERROR: CCurlFile::FillBuffer - Failed: Timeout was reached(28)
    11:10:05.340 65.623032 T:1892676352 ERROR: CCurlFile::Open failed with code 0 for http://192.168.1.8:8866/service?meth....0&device=xbmc
    11:10:05.341 65.623596 T:1892676352 ERROR: Open - failed to open source <http://192.168.1.8:8866/service?method=session.initiate&ver=1.0&device=xbm c>
    11:10:05.348 65.630707 T:1892676352 DEBUG: AddOnLog: NextPVR PVR Client: ->~cPVRClientNextPVR()
    11:10:05.350 65.632973 T:1892676352 ERROR: ADDON: Dll NextPVR PVR Client - Client returned bad status (1) from Create and is not usable

  3. #3
    Join Date
    Oct 2006
    Location
    Hamilton New Zealand
    Posts
    4,943
    just use xnewa way less issues
    Specs
    Server:Cpu-Intel i3,ATI Radeon HD 5670 ,OS-Windows 7,2gig ram. 2xHvr4400,Nova-s plus(dvb-s SD),hvr2210(dvb-t HD)
    Client:Cpu-AMD am2,Gpu-Ati HD2100 integrated ,OS-Windows 7,2gig ram
    Client:Cpu Intel 2 gig ram ,Nvidia 9400
    Client:Popcorn Hour A110
    Client:Samsung [NZ][DVB-s][2012]BD-E5900x2
    Client:Samsung [NZ][DVB-s][2013]BD-F6500

  4. #4
    Join Date
    Sep 2017
    Location
    New Zealand
    Posts
    3
    FIXED!

    I went back to basics and just tried localhost:8866 on my windows machine and that was refused. So a complete uninstall of Next PVR followed by a complete install and everything started working again. Weird but lets leave it at that.

    Simon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •