Results 1 to 3 of 3

Thread: Recordings fail silently when drive not available.

  1. #1
    Join Date
    May 2006
    Location
    Canada
    Posts
    26,315

    Recordings fail silently when drive not available.

    I returned from a long vacation and noticed my NAS and it failed to restart after a power outage. Normally it is on a UPS but that is user error.

    Anyway NextPVR recordings to that drive failed but there was no indication of the failure for rerecordings. The error code is zero and the there is no reason code showing. The only indication of an error in the logs is on that batch files

    Code:
    2018-05-16 21:00:00.265	[DEBUG][6]	Recording explicitly recording to directory: '[Network]'
    2018-05-16 21:00:00.291	[DEBUG][6]	allocating recording target filename: K:\The Expanse\Season 03\The Expanse.S03E06.Immolation.ts
    2018-05-16 21:00:00.294	[DEBUG][6]	About to start recording (19444 on 1524): K:\The Expanse\Season 03\The Expanse.S03E06.Immolation.ts...
    2018-05-16 21:00:00.303	[INFO][6]	HDPVRRecorder.StartStream(K:\The Expanse\Season 03\The Expanse.S03E06.Immolation.ts)
    ...
    2018-05-16 21:00:00.984	[DEBUG][6]	Started recording (19444:19:K:\The Expanse\Season 03\The Expanse.S03E06.Immolation.ts)
    2018-05-16 21:00:01.001	[DEBUG][6]	Invalid file passed to StartParallelProcessing(): 'K:\The Expanse\Season 03\The Expanse.S03E06.Immolation.ts'
    ...
    2018-05-16 22:01:00.075	[DEBUG][6]	Stopping recording (19444 on 1524). Past end time of recording. 19
    2018-05-16 22:01:00.084	[INFO][6]	HDPVRRecorder.StopStream(19)
    ...
    2018-05-16 22:01:02.807	[DEBUG][6]	Invalid file passed to StartPostProcessing(): 'K:\The Expanse\Season 03\The Expanse.S03E06.Immolation.ts'
    Since it seems like Windows is able to detect the invalid file so it would be nice if NextPVR "caught" this inititally.

    Martin

  2. #2
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    87,018
    Weird - I would have thought it would have reported this.

    Do you think K: would have been missing when it tried to record? I'll have to try reproducing it here.

  3. #3
    Join Date
    May 2006
    Location
    Canada
    Posts
    26,315
    Quote Originally Posted by sub View Post
    Weird - I would have thought it would have reported this.

    Do you think K: would have been missing when it tried to record? I'll have to try reproducing it here.
    K: was certainly offline but it would have been online up to the power outage, not sure how Windows handles this. I powered up the NAS for other reasons so I cannot see what the backend was seeing.

    Martin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •