Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 45

Thread: Can't stream existing recordings

  1. #21
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    91,181
    Can you post logs showing an attempt to stream that specific recording, so I can compare with my logs here?

  2. #22
    Join Date
    Sep 2004
    Location
    Winsford, UK
    Posts
    635
    just downloaded the file from OneDrive and checked it myself. Has the same length as the original....but... the downloaded file plays/transcodes fine. The original does not :-(
    Frustrating
    So something changed by copying the file.
    NPVR Version= 4.2.4_190307
    Intel i7 Quad Core 3200 + 16GB DDR2 Gigabyte Motherboard
    Windows 10 Pro 64bit
    BlackGold dual DVB T & S tuner
    60Gb SSD System Disk (Raid 1)
    60Gb SSD Recording Cache
    4Tb Media Store (WD Red 4Tb x 2 in Raid 1)

    Raspberry Pi2 running OSMC (Kodi v18.3) x 2
    Raspberry Pi3 B+ running OSMC (Kodi v18.3)

  3. #23
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    91,181
    Quote Originally Posted by Bobins View Post
    just downloaded the file from OneDrive and checked it myself. Has the same length as the original....but... the downloaded file plays/transcodes fine. The original does not :-(
    Frustrating
    So something changed by copying the file.
    That's weird.

  4. #24
    Join Date
    Jan 2005
    Location
    London
    Posts
    3,263
    Quote Originally Posted by Bobins View Post
    just downloaded the file from OneDrive and checked it myself. Has the same length as the original....but... the downloaded file plays/transcodes fine. The original does not :-(
    Frustrating
    So something changed by copying the file.
    perhaps you could generate an MD5 hash for each files to check if they are both bit-perfect identical to ensure you are comparing apples and apples. If they are the same, this would seem to suggest some sort of file i/o problem, possibly excessive file fragmentation?
    “If this is the way Queen Victoria treats her prisoners, she doesn't deserve to have any.”

  5. #25
    Join Date
    Sep 2004
    Location
    Winsford, UK
    Posts
    635
    Ok. I've found another file that displays the "won't stream" problem in the web interface but plays ok directly in NPVR.
    I've checked the MD5 hash and file size on the original, a copy of the file and an uploaded copy on OneDrive.
    They are all identical and importantly, copying the file back and overwriting the original still has the problem

    Sub: I'll PM you a link to the new file so you can take a look when you're free. Be interesting to see if you get the same error.

    File MD5 Hash File size
    Original BF93E5281F1AD49AF0CE394A4C4BCF4A 3,791,019,624 Bytes
    Copied BF93E5281F1AD49AF0CE394A4C4BCF4A 3,791,019,624 Bytes
    Added to One Drive BF93E5281F1AD49AF0CE394A4C4BCF4A 3,791,019,624 Bytes
    NPVR Version= 4.2.4_190307
    Intel i7 Quad Core 3200 + 16GB DDR2 Gigabyte Motherboard
    Windows 10 Pro 64bit
    BlackGold dual DVB T & S tuner
    60Gb SSD System Disk (Raid 1)
    60Gb SSD Recording Cache
    4Tb Media Store (WD Red 4Tb x 2 in Raid 1)

    Raspberry Pi2 running OSMC (Kodi v18.3) x 2
    Raspberry Pi3 B+ running OSMC (Kodi v18.3)

  6. #26
    Join Date
    Sep 2004
    Location
    Winsford, UK
    Posts
    635
    Small bump....Sub, did you see my PM?
    NPVR Version= 4.2.4_190307
    Intel i7 Quad Core 3200 + 16GB DDR2 Gigabyte Motherboard
    Windows 10 Pro 64bit
    BlackGold dual DVB T & S tuner
    60Gb SSD System Disk (Raid 1)
    60Gb SSD Recording Cache
    4Tb Media Store (WD Red 4Tb x 2 in Raid 1)

    Raspberry Pi2 running OSMC (Kodi v18.3) x 2
    Raspberry Pi3 B+ running OSMC (Kodi v18.3)

  7. #27
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    91,181
    Quote Originally Posted by Bobins View Post
    Small bump....Sub, did you see my PM?
    I've just checked this file now.

    I haven't sat through the whole file video, but I've watched the first few minutes in both Chrome and Edge, and both seemed to be playing ok.

    Does it not start at all when your try watching it there? What browser where you using?

    When you try streaming a .log file will be created in the C:\Users\Public\NPVR\web\temp directory. Can you post that?

  8. #28
    Join Date
    Sep 2004
    Location
    Winsford, UK
    Posts
    635
    Did the MD5 hash match mine (just want to be sure nothing changed in the download)?
    What I see is the requesting transcode message....buffering....75%....100%..... then "The media could not be loaded either because the server or network failed Or because the format is not supported"
    I'm using the edge browser
    Just discovered that temp folder seems to have 1000+ 1mb files in it. appear to be 1mb snippets of a file that successfully played.
    I'll purge and try the problem file again.
    NPVR Version= 4.2.4_190307
    Intel i7 Quad Core 3200 + 16GB DDR2 Gigabyte Motherboard
    Windows 10 Pro 64bit
    BlackGold dual DVB T & S tuner
    60Gb SSD System Disk (Raid 1)
    60Gb SSD Recording Cache
    4Tb Media Store (WD Red 4Tb x 2 in Raid 1)

    Raspberry Pi2 running OSMC (Kodi v18.3) x 2
    Raspberry Pi3 B+ running OSMC (Kodi v18.3)

  9. #29
    Join Date
    Sep 2004
    Location
    Winsford, UK
    Posts
    635
    OK,
    Watching the temp directory when I trigger the stream, files start to appear containing video snippets but the stream fails to display in the browser giving the error as above.
    The directory does seem to get purged when I exit the browser (with the exception of log files)

    Here's the log of the stream attempt..
    NPVR Version= 4.2.4_190307
    Intel i7 Quad Core 3200 + 16GB DDR2 Gigabyte Motherboard
    Windows 10 Pro 64bit
    BlackGold dual DVB T & S tuner
    60Gb SSD System Disk (Raid 1)
    60Gb SSD Recording Cache
    4Tb Media Store (WD Red 4Tb x 2 in Raid 1)

    Raspberry Pi2 running OSMC (Kodi v18.3) x 2
    Raspberry Pi3 B+ running OSMC (Kodi v18.3)

  10. #30
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    91,181
    Quote Originally Posted by Bobins View Post
    Did the MD5 hash match mine (just want to be sure nothing changed in the download)?
    Yes - just checked. bf93e5281f1ad49af0ce394a4c4bcf4a

    What I see is the requesting transcode message....buffering....75%....100%..... then "The media could not be loaded either because the server or network failed Or because the format is not supported"
    I'm using the edge browser
    Just discovered that temp folder seems to have 1000+ 1mb files in it. appear to be 1mb snippets of a file that successfully played.
    I'll purge and try the problem file again.
    Ultimately, it's all these small .ts segment files that gets played in the browser. It does play for me fine in Edge.

    Can you also post NextPVR logs, and I'll check through them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •