Results 1 to 5 of 5

Thread: duplicate ch# for imports from iptv

  1. #1
    Join Date
    Aug 2005
    Location
    Houston
    Posts
    4,762

    duplicate ch# for imports from iptv

    is there anything that can be done about when importing channels from iptv m3u, it duplicates channel #s already in use, so in guide i have multiple ch2, one for locals, one for iptv,and not same content...not sure how can change livetv to a certain channels with # buttons in guide when that happens..
    also it severely stuffs up order, forcing manual changing every single channel # for all imports..
    example, i have locals as 2,8,11,13,20,26,39...and on import of iptv i have: 2,2,3,4,5,6,7,8,8,9,10,11,11,12,13,13,14,15,16,etc ..

    could we get a 'starting at ch#' for the import? or at least not use existing channel #'s?
    starting ch# would keep the iptv separated from existing ch's on other devices..

    also, even tho i specified a guide .xml when i imported, none of them are mapped to it? i have to go into bulkmap to fix..all channels match epg names..
    Hardware: HDHR Prime, HDPVR 1212, Raspberry pi2, VFD display w/LCDSmartie

  2. #2
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    87,481
    Quote Originally Posted by pBS View Post
    could we get a 'starting at ch#' for the import? or at least not use existing channel #'s?
    I'll add some import settings like this in the next release.

    also, even tho i specified a guide .xml when i imported, none of them are mapped to it? i have to go into bulkmap to fix..all channels match epg names..
    If you want to pm my the urls, I can do a brief check why they didn't work automatically.

  3. #3
    Join Date
    Aug 2005
    Location
    Houston
    Posts
    4,762
    just to be clear, they do all match up automatically when i go into bulk map and manually do one, it asks to do the rest and they all get mapped correctly..
    it's just that directly after iptv import, all the ch have 'none' where they should have 'xmltv' for epg source.
    maybe have something to do with me having sd's .xml file already mapped to locals?
    Last edited by pBS; 2018-09-14 at 09:46 PM.
    Hardware: HDHR Prime, HDPVR 1212, Raspberry pi2, VFD display w/LCDSmartie

  4. #4
    Join Date
    Aug 2005
    Location
    Houston
    Posts
    4,762

    New problem w channel not being saved

    i'm having a problem with certain channels not being saved after import..
    they import fine, then if i go back into dialog, it shows no url at all..
    and obviously they won't work in guide to play w no url to go to..
    they imported fine before, not sure what changed, i even removed some info i thought might be interfering, but no luck..

    if i 'add' a channel and manually insert info, it keeps it and channel works..
    here's a sample entry that won't import..
    Code:
    #EXTINF:-1 tvg-name="MLB #1" tvg-id="39811.vaders.tv" tvg-logo="" group-title="MatchCenter",MLB #1
    http://vapi.vaders.tv/play/39811.m3u8?token=eyJ1c2VybmFtZSI6InBwcHAiLCJwYXNzd29yZCI6InNhc3N5OOO=
    like i mentioned, if i insert second line as url it works fine..
    any ideas?
    Hardware: HDHR Prime, HDPVR 1212, Raspberry pi2, VFD display w/LCDSmartie

  5. #5
    Join Date
    Aug 2005
    Location
    Houston
    Posts
    4,762

    n/m

    nevermind, i got channel import fixed, had to cleanup 1000's of extra old unused channels from db..
    still had to manually adjust ch #s tho...only took about 30 mins..lol
    [wish i could use keyboard alone to navigate in bulk mapper screen, had to use mouse + keys, much slower]
    Hardware: HDHR Prime, HDPVR 1212, Raspberry pi2, VFD display w/LCDSmartie

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •