Page 1 of 5 123 ... LastLast
Results 1 to 10 of 45

Thread: No audio on HD channels with LAV

  1. #1
    Join Date
    Oct 2018
    Location
    France
    Posts
    3

    No audio on HD channels with LAV

    Hi there,

    I just installed NextPVR on a windows 10 (activated, up-to-date) computer which already had LAV installed (i use them with media player classic).
    LAV is configured to pass digital audio through to my home theater receiver via HDMI.

    In NextPVR decoder settings, i set LAV in all video and audio sections.

    Then, when watching live TV, i have no audio on HD channels (but it works on SD channels). Video works fine.

    If i watch a recorded .ts, i have no audio either. However, if i open the .ts file with MPC (which also uses LAV) then i do get sound.

    I have found this archived thread : https://forums.nextpvr.com/archive/i...p/t-58470.html and tried whats described on it with no success.

    My TV tuner is an USB "AVerMedia AVerTV Volar HD 2".

    Thanks for your help
    Attached Files Attached Files
    Last edited by Zerist; 2018-10-20 at 08:11 AM.

  2. #2
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,519
    Does it work with pass through turned off?

    Martin

  3. #3
    Join Date
    Oct 2018
    Location
    France
    Posts
    3
    I did try disabling the pass-through, but it didn't change anything...

  4. #4
    Join Date
    Oct 2018
    Location
    France
    Posts
    3
    Okay, i checked "use legacy NPVR TS reader and Microsoft demultiplexer" under "settings/Decoders" and now it works.

  5. #5
    Join Date
    Oct 2018
    Location
    USA
    Posts
    20
    I have this same problem. How do you disable pass-through on windows 10 machine running latest nextpvr?

  6. #6
    Join Date
    Oct 2018
    Location
    USA
    Posts
    20
    I have the same problem as stated above. Your solution didn't work for me. However, I haven't tried disabling pass-through. Not sure how. Initially I did have sound on my SD channels. I tried to adjust decoders per the error message below, now I have no sound on SD or HD (h.264 ) channels. I recently subscribed to the HDHR Prime TV and have loaded their h264 channels along with my existing OTA channels into NEXTPVR. My decoders for video are ffshow for mpeg2 and Microsoft DVD for h264. All audio decoders have LAV selected including AAC despite what the error message below says. This started 3 days ago when I added the new HDHR Prime TV Service.

    I get the following error message which flashes on my PC screen while video is playing: "Missing audio? You don't have AAC decoder selected. You can fix this on the settings decoder screen".

    Audio and video do play on clients, however audio studders every 3-5 mins on the RPI3B only... maybe a separate issue.

    Below are my current logs:
    Attached Files Attached Files
    Last edited by ssmith1936; 2018-10-20 at 08:55 PM. Reason: add decoders, other detail, timing
    Server: NPVR 4.2.2/Win10 Home v1803 64-bit/HP Envy Phoenix i7-4960X CPU @ 3.6 GHZ, 4 TB, 24GB/2 x HDHR4-2US Connect (OTA & HDHR Prime TV) with 1 Clearstream 2V antenna/Schedules Direct
    Playback clients: NVidia Shield running Android 8.1, Kodi 17.6/ 2 x RPI3B OpenELEC 8.0.4 running Kodi 17.3/2 x Firestickv1

  7. #7
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    90,424
    Zerist - I'm not going to be able to look at it for a few days (currently travelling), but could you supply a sample recording. France is a little different than everywhere else in that it uses E-AC3. It's possible I got something wrong in the support for this.

  8. #8
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    90,424
    ssmith1936 - your issue will be something different than Zerist was having.

    Is it just live tv, or also playback of recordings?

  9. #9
    Join Date
    Oct 2018
    Location
    USA
    Posts
    20
    For playback on my Windows 10 server, OTA (SD/Mpeg2) recordings also don't have sound. HD (h.264) recordings do have sound.
    Server: NPVR 4.2.2/Win10 Home v1803 64-bit/HP Envy Phoenix i7-4960X CPU @ 3.6 GHZ, 4 TB, 24GB/2 x HDHR4-2US Connect (OTA & HDHR Prime TV) with 1 Clearstream 2V antenna/Schedules Direct
    Playback clients: NVidia Shield running Android 8.1, Kodi 17.6/ 2 x RPI3B OpenELEC 8.0.4 running Kodi 17.3/2 x Firestickv1

  10. #10
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    90,424
    Usually setting the AC3 decoder to LAV would do the job, but maybe try installing AC3Filter from http://www.ac3filter.net, and select that for your AC3 decoder.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •