Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 51

Thread: [Moved] Comskip with XNEWA on Kodi 18 Leia

  1. #21
    Join Date
    May 2006
    Location
    Canada
    Posts
    27,572
    SMB2 cannot be navigated as the Kodi thread you linked to stated. You need to type in the access information. If guest access is working the advancedsettings.xml would work. In your last logs it still is not.

    For the RPi you need to make sure that you have the right version of Librelec to access SMB2 https://wiki.libreelec.tv/accessing_libreelec

    Martin

  2. #22
    Join Date
    Jul 2005
    Location
    HK - Pal I
    Posts
    3,435
    Hi Martin just an update as I’m away for a couple of weeks but haven’t given up!

    I’m making headway with SMB shares (turned on guest as discussed although not sure it helped) by adding server IP address and login / PWD manually in KODI.

    Using this I can browse to the server via SMB share to add folders to Kodi’s Video and photos sources. I still have the shares in advancedsettings.xml.

    I’m sort of left wondering how XNEWA/ NextPVR actually knows about the share paths ? Does it address the Kodi shares?
    I tried the show again in XNEWA but still never saw it skip; PC and PCH are perfect. Will get you logs in a couple weeks.
    ASUS STRIX X470-F AMD 2700x 4GHz | Win10Prox64 | 32GB | NVIDIA GEforce GT1030 Fanless | WinTV DMB-TH | WinTV HVR-1280 | Hauppauge Colossus | Various HD's | AC86U | USB-UIRT | PCH-A110 | RPi2 | Sony Bravia LCD X9000F Android TV |. Frustrated that NextPVR is not working? Take a moment and consider this and this and this and this and this and this. Credit where credit's due; for one guy (with a wife and two kids), most problems are solved outrageously quickly. Patience.

  3. #23
    Join Date
    May 2006
    Location
    Canada
    Posts
    27,572
    Ok. Basically think of the to and from as search and replace. Kodi does the replace and tries and find the files an if not found it gives up and uses http. If you give me a debug log playing the file from the Video library I might be able to help you out further.

    Martin

  4. #24
    Join Date
    Jul 2005
    Location
    HK - Pal I
    Posts
    3,435
    Quote Originally Posted by mvallevand View Post
    Ok. Basically think of the to and from as search and replace. Kodi does the replace and tries and find the files an if not found it gives up and uses http. If you give me a debug log playing the file from the Video library I might be able to help you out further.

    Martin
    Hi Martin,

    Right, I'm back. I ran it twice:

    1. XNEWA with NextPVR logs and Kodi Debug link attached https://paste.kodi.tv/acisuxuher
    2. From Kodi VIDEOS (assuming path was SMB); https://paste.kodi.tv/tobahiniwu

    Observations:
    • I get a fair bit of buffering when using XNEWA and I skip or fast forward.
    • The timeline only shows in XNEWA (not Kodi Videoas) although there is no longer the nice PCH Blue button to bring it up), if I hit pause I can see it.
    • Skip still doesn't work for me (the reason for this thread).
    • When I hit forward or skip in XNEWA, when in Kodi on the TV, the timeline jumps forward then jumps back? Not sure why?
    Last edited by jksmurf; 2019-02-11 at 07:04 AM.
    ASUS STRIX X470-F AMD 2700x 4GHz | Win10Prox64 | 32GB | NVIDIA GEforce GT1030 Fanless | WinTV DMB-TH | WinTV HVR-1280 | Hauppauge Colossus | Various HD's | AC86U | USB-UIRT | PCH-A110 | RPi2 | Sony Bravia LCD X9000F Android TV |. Frustrated that NextPVR is not working? Take a moment and consider this and this and this and this and this and this. Credit where credit's due; for one guy (with a wife and two kids), most problems are solved outrageously quickly. Patience.

  5. #25
    Join Date
    May 2006
    Location
    Canada
    Posts
    27,572
    Quote Originally Posted by jksmurf View Post
    Hi Martin,

    Right, I'm back. I ran it twice:

    1. XNEWA with NextPVR logs and Kodi Debug link attached https://paste.kodi.tv/acisuxuher
    2. From Kodi VIDEOS (assuming path was SMB); https://paste.kodi.tv/tobahiniwu

    [*]I get a fair bit of buffering when using XNEWA and I skip or fast forward.
    That will vary by your client HW and O/S. Wired network is recommended. HTTP and direct play performance will vary. Once you get advancedsettings working Kodi library and x-newa performance will be exactly the same. Bottom line not really an x-newa issue
    [*]The timeline only shows in XNEWA (not Kodi Videoas) although there is no longer the nice PCH Blue button to bring it up), if I hit pause I can see it.
    I've posted often that Kodi Library does not show EDL break points.
    [*]Skip still doesn't work for me (the reason for this thread).
    Well your test did help but you didn't use a guest share so you need to configure your advanced settings to use the same username and password as I suggested earlier The syntax is something like

    Code:
    <substitute>
      <from>G:/ArchivedMovies/</from>
      <to>smb://username:password@192.168.1.10/ArchivedMovies/</to>
    </substitute>
    I will let you work on your own trying to figure out guest access. You can ditch ArchMovies since the 12 character issue doesn't seem to be a problem.

    [*]When I hit forward or skip in XNEWA, when in Kodi on the TV, the timeline jumps forward then jumps back? Not sure why?
    That would mean the client Kodi is not accepting the seek requests. Let's work on this after you get comskip working, assuming Kodi skips ok.

    Martin

  6. #26
    Join Date
    Jul 2005
    Location
    HK - Pal I
    Posts
    3,435
    Quote Originally Posted by mvallevand View Post
    That will vary by your client HW and O/S. Wired network is recommended. HTTP and direct play performance will vary. Once you get advancedsettings working Kodi library and x-newa performance will be exactly the same. Bottom line not really an x-newa issue.
    Understood. Will get to that later (already have buffer . read /. memory settings in advancedsettings.xml on the RPi2 but not yet on the TV).

    Quote Originally Posted by mvallevand View Post
    I've posted often that Kodi Library does not show EDL break points.
    Sure, no problem Martin. There's some talk here about it being looked at but it's not important for me to run it from Kodi, just to find a way to bring it up in XNEWA like I used to on the PCH (with the remote key-press). I have not found a way to do this when playing it in XNEWA - trust this clarifies the difference?

    Quote Originally Posted by mvallevand View Post
    Well your test did help but you didn't use a guest share so you need to configure your advanced settings to use the same username and password as I suggested earlier
    Okey Dokey. I thought that as I could actually browse to the Samba share manually the access was already available. These share things seem way over-complicated and with Windows breaking it the goalposts keep moving too.

    Quote Originally Posted by mvallevand View Post
    The syntax is something like

    Code:
    <substitute>
      <from>G:/ArchivedMovies/</from>
      <to>smb://username:password@192.168.1.10/ArchivedMovies/</to>
    </substitute>
    OK; I am currently a wee bit stuck trying to find out where the username /password is for Guest access as the Win10 Home console does not show any Guest as a user.

    Quote Originally Posted by mvallevand View Post
    I will let you work on your own trying to figure out guest access. You can ditch ArchMovies since the 12 character issue doesn't seem to be a problem.
    OK; you may have seen I have done this to some extent above and in the thread here but I will continue to work on it. I am becoming concerned about security risks though.

    Quote Originally Posted by mvallevand View Post
    That would mean the client Kodi is not accepting the seek requests. Let's work on this after you get comskip working, assuming Kodi skips ok. Martin
    Okey Dokey.

    Thank you,

    k.
    ASUS STRIX X470-F AMD 2700x 4GHz | Win10Prox64 | 32GB | NVIDIA GEforce GT1030 Fanless | WinTV DMB-TH | WinTV HVR-1280 | Hauppauge Colossus | Various HD's | AC86U | USB-UIRT | PCH-A110 | RPi2 | Sony Bravia LCD X9000F Android TV |. Frustrated that NextPVR is not working? Take a moment and consider this and this and this and this and this and this. Credit where credit's due; for one guy (with a wife and two kids), most problems are solved outrageously quickly. Patience.

  7. #27
    Join Date
    May 2006
    Location
    Canada
    Posts
    27,572
    I wasn't suggesting you use a guest password just setup advancedsettings with whatever you used for the video library.

    Martin

  8. #28
    Join Date
    Jul 2005
    Location
    HK - Pal I
    Posts
    3,435
    Quote Originally Posted by mvallevand View Post
    I wasn't suggesting you use a guest password just setup advancedsettings with whatever you used for the video library.

    Martin
    Sorry to appear completely daft, but I'm not sure what you mean? From the Kodi log I posted, my advanced settings are these:
    Can you please explain what you mean by "whatever you used for the video library", I didn't really make any settings for that, I just navigated the Samba shares and selected each Share path, gave it a name, then it asked for what type of media (Movie/TV Shows etc) and downloaded details for each show?

    I also have password protected sharing off in Windows Networks Sharing settings.

    Code:
    12:45:02.892 T:12616  NOTICE: Contents of special://profile/advancedsettings.xml are...
                                                <advancedsettings>
                                                  <cache>
                                                    <buffermode>1</buffermode>
                                                    <memorysize>104857600</memorysize>
                                                    <readfactor>1.5</readfactor>
                                                  </cache>
                                                  <pathsubstitution>
                                                    <substitute>
                                                      <from>D:/GBPVRVids/</from>
                                                      <to>smb://192.168.1.10/GBPVRVids/</to>
                                                    </substitute>
                                                    <substitute>
                                                      <from>G:/ArchivedMovies/</from>
                                                      <to>smb://192.168.1.10/ArchMovies/</to>
                                                    </substitute>
                                                    <substitute>
                                                      <from>D:/PlayOnVids/</from>
                                                      <to>smb://192.168.1.10/PlayOnVids1/</to>
                                                    </substitute>
                                                    <substitute>
                                                      <from>X:/PlayOnVids2/</from>
                                                      <to>smb://192.168.1.10/PlayOnVids2/</to>
                                                    </substitute>
                                                    <substitute>
                                                      <from>G:/PlayOnVids3/</from>
                                                      <to>smb://192.168.1.10/PlayOnVids3/</to>
                                                    </substitute>
                                                    <substitute>
                                                      <from>E:/Storage/HDCamVideos/</from>
                                                      <to>smb://192.168.1.10/HDCamVideos/</to>
                                                    </substitute>
                                                    <substitute>
                                                      <from>E://Jkm/FamilyStuff/GoPro</from>
                                                      <to>smb://192.168.1.10/GoPro/</to>
                                                    </substitute>
                                                    <substitute>
                                                      <from>E:/VideosKids/</from>
                                                      <to>smb://192.168.1.10/VideosKids/</to>
                                                    </substitute>
                                                    <substitute>
                                                      <from>G:/NPVRDVDs/</from>
                                                      <to>smb://192.168.1.10/NPVRDVDs/</to>
                                                    </substitute>
                                                  </pathsubstitution>
                                                </advancedsettings>
    k.
    Last edited by jksmurf; 2019-02-12 at 01:51 AM. Reason: More Info
    ASUS STRIX X470-F AMD 2700x 4GHz | Win10Prox64 | 32GB | NVIDIA GEforce GT1030 Fanless | WinTV DMB-TH | WinTV HVR-1280 | Hauppauge Colossus | Various HD's | AC86U | USB-UIRT | PCH-A110 | RPi2 | Sony Bravia LCD X9000F Android TV |. Frustrated that NextPVR is not working? Take a moment and consider this and this and this and this and this and this. Credit where credit's due; for one guy (with a wife and two kids), most problems are solved outrageously quickly. Patience.

  9. #29
    Join Date
    May 2006
    Location
    Canada
    Posts
    27,572
    From the log it looks like you added a username and password when you created the share in Kodi.

    Martin

  10. #30
    Join Date
    Jul 2005
    Location
    HK - Pal I
    Posts
    3,435
    Quote Originally Posted by mvallevand View Post
    From the log it looks like you added a username and password when you created the share in Kodi.

    Martin
    OK I think I have the shares with username and password sorted now; at least I can get it to work, after a fashion***

    ***
    I say after a fashion because the first time I run the show in XNEWA it jumps back (as I mentioned before) to the start of the recording i.e. seems to ignore the skip, jumps forward then back and when I try to toggle the timeline it comes up with KODIs timeline, not XNEWAs. See pics.

    The second time I run it it starts at the first cut just fine; AND I can skip forward by the one minute without losing the timeline; AND it skips the next commercial just fine. See pic and logs which should capture BOTH runs hopefully.

    https://paste.kodi.tv/biforujesa

    Have to say I'm not impressed with how KODI manages the media sources files and the shares setup is a nightmare.
    I really wish sub had just implemented skip (and access to the Videos Directory) in the Android client and be done with it.

    k.
    Attached Images Attached Images    
    ASUS STRIX X470-F AMD 2700x 4GHz | Win10Prox64 | 32GB | NVIDIA GEforce GT1030 Fanless | WinTV DMB-TH | WinTV HVR-1280 | Hauppauge Colossus | Various HD's | AC86U | USB-UIRT | PCH-A110 | RPi2 | Sony Bravia LCD X9000F Android TV |. Frustrated that NextPVR is not working? Take a moment and consider this and this and this and this and this and this. Credit where credit's due; for one guy (with a wife and two kids), most problems are solved outrageously quickly. Patience.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •