Results 1 to 5 of 5

Thread: X-NEWA Web Client Not Acting On Keypresses

  1. #1
    Join Date
    Jun 2007
    Location
    St. Paul, MN, USA
    Posts
    1,322

    X-NEWA Web Client Not Acting On Keypresses

    OK, Martin. Here's another one of those oddities I'm seeing sometimes. (Note, this one happens much less frequently but has been happening for a while.)

    Here are the logs.

    At the end of the the kodi.log (in the Logs folder), I pressed the right arrow and then the pause button several times. It seems the button press is being passed to the NextPVR server because when I press the pause, the OSD comes up for a little bit. However, the player doesn't actually respond to the button press. So for the right arrow, the play doesn't skip forward. And for the pause, the video just keeps playing.

    EDIT: I've also noticed that when this happens, commercial auto-skipping doesn't work. See 07:30:04 in this updated kodi.log.
    Last edited by BrettB; 2019-02-01 at 01:37 PM.

  2. #2
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,143
    It looks like this happens when you hit a pause after a pause. I wonder if I am expecting the server to tell the client to pause? The same could be true about comskip. I will have to discuss this with sub.

    There is another error when x-newa sends the keystroke for the pause while it is in a kind of pause state.

    Code:
    2019-02-01 07:18:20.981	[DEBUG][39]	Got Web Request (::ffff:192.168.143.25): /control    time=1549027101&key=32&client=sdl-KNEWA0xb827ebd2d752L&sid=45de62e7ba914420a366c024ce06ee73
    2019-02-01 07:18:20.985	[DEBUG][4]	Got Web Request (::ffff:192.168.143.25): /control    media=12.6380004883&client=sdl-KNEWA0xb827ebd2d752L&sid=45de62e7ba914420a366c024ce06ee73
    2019-02-01 07:18:21.128	[DEBUG][4]	Unexpected client control error: System.InvalidOperationException: Object is currently in use elsewhere.
    
    Server stack trace: 
       at System.Drawing.Graphics.FromImage(Image image)
       at NextPVR.ControllerForm.ClientGetScreenImage()
       at NextPVR.ClientControlRemote.ClientGetScreenImage()
       at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
       at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
    
    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at NUtility.IClientControl.ClientGetScreenImage()
       at Cassini.Request.Control()
    Martin

  3. #3
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,143
    Ok except for also getting that rendering issue for sub, my client is working fine. The pause is handled immediately by Kodi when I hit the pause key. Perhaps try a keyboard and see if the space bar toggles play.

    For comskip it is also handled by the client and x-newa and the server really aren't involved. When you hit your first commerical it is up to Kodi to do the skip but nothing happens.

    07:30:04.148 T:1171256176 DEBUG: CheckAutoSceneSkip - Clock in commercial break [00:11:55.380 - 00:14:50.030]: 00:11:55.403. Automatically skipping to end of commercial break

    You probably need to report that to LE. Given you were running Kodi for almost 48 hours who knows what kind of memory leaks might come into play.

    Martin

  4. #4
    Join Date
    Jun 2007
    Location
    St. Paul, MN, USA
    Posts
    1,322
    Quote Originally Posted by mvallevand View Post
    Ok except for also getting that rendering issue for sub, my client is working fine. The pause is handled immediately by Kodi when I hit the pause key. Perhaps try a keyboard and see if the space bar toggles play.

    For comskip it is also handled by the client and x-newa and the server really aren't involved. When you hit your first commerical it is up to Kodi to do the skip but nothing happens.

    07:30:04.148 T:1171256176 DEBUG: CheckAutoSceneSkip - Clock in commercial break [00:11:55.380 - 00:14:50.030]: 00:11:55.403. Automatically skipping to end of commercial break

    You probably need to report that to LE. Given you were running Kodi for almost 48 hours who knows what kind of memory leaks might come into play.
    I didn't try using the keyboard in this particular case. But I have in the past. And it doesn't pause either. I agree that I think it is most likely a LE or Kodi bug. It doesn't happen too often. And I haven't been able to figure out what triggers it. And I thought you might see something else in the logs which would give us a clue. Thanks for taking a look.

  5. #5
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,143
    That's the think I saw nothing at all from the Kodi subsystems in the logs when the problems occurred.

    Martin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •