Results 1 to 10 of 10

Thread: Import Error with Updated NPVR Release

  1. #1
    Join Date
    Dec 2018
    Location
    Canada
    Posts
    7

    Import Error with Updated NPVR Release

    Updated to the latest NPVR Release and am now getting an Import Error when trying to reload my EPG XML.

    Unable to read: xxxxxxx.xml
    The Remote server returned an error: (500) Internal Server Error.

    When i load the link in my browser the file downloads perfectly.

    Name:  Import Error NPVR.jpg
Views: 88
Size:  13.5 KB

    Your help is greatly appreciated.
    Attached Files Attached Files
    Last edited by Coulen; 2019-03-08 at 03:02 PM.

  2. #2
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    88,129
    Is this when you're using the 'Import' button in the IPTV device settings? or is this when you're hitting 'update epg'?

  3. #3
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    88,129
    See if this helps.
    Attached Files Attached Files

  4. #4
    Join Date
    Dec 2018
    Location
    Canada
    Posts
    7
    Quote Originally Posted by sub View Post
    See if this helps.
    Hey Sub, Same issue.
    This is when i hit the import button in the device settings menu yes.

    I stopped NPVR, changed the DLL, restarted NPVR.

    Edit:
    I just tried changing my link to a gz. If i use that link it imports. This is new with the updated nshared.dll Switching before did not work.
    Is using the zipped gz vs xml any faster or slower bringing the data in ?

    I do notice as well that when i try to map channels, I no longer can see whats inside the xml.

    Name:  Import Error NPVR 2.jpg
Views: 79
Size:  41.9 KB

    But the EPG Data is coming again.
    Thanks Sub

  5. #5
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    88,129
    Quote Originally Posted by Coulen View Post
    Edit:
    I just tried changing my link to a gz. If i use that link it imports. This is new with the updated nshared.dll Switching before did not work.
    Is using the zipped gz vs xml any faster or slower bringing the data in ?
    Can you see if this helps with the non .gz version?

    Basically it looks like your IPTV provider is now requiring a UserAgent to be specified to be able to download the EPG. This stuff hadn't changed in NextPVR, so I'm guessing it was a coincidence it stopped working about when you installed the new updated version.
    Attached Files Attached Files

  6. #6
    Join Date
    May 2006
    Location
    Canada
    Posts
    27,070
    I noted that some providers are moving to brotli compression too, probably will become more relevant with time.

    Martin

  7. #7
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    88,129
    Ok, I'll keep an eye out for that. Looks like I should be able to add support for that.

  8. #8
    Join Date
    Dec 2018
    Location
    Canada
    Posts
    7
    Quote Originally Posted by sub View Post
    Can you see if this helps with the non .gz version?

    Basically it looks like your IPTV provider is now requiring a UserAgent to be specified to be able to download the EPG. This stuff hadn't changed in NextPVR, so I'm guessing it was a coincidence it stopped working about when you installed the new updated version.
    Thanks Sub, that worked perfectly for both GZ, and XML.
    As well as the Channel Mapping is showing correctly now as well.

    Thanks Again.

  9. #9
    Join Date
    Dec 2018
    Location
    Canada
    Posts
    7
    NEW Issue:

    Streams dont play now. It says Tuner not available in Kodi and just doesnt play in NextPVR.


    No idea what changed, but everything just started working.
    Sorry for that..

    Looks good now.
    Attached Files Attached Files
    Last edited by Coulen; 2019-03-08 at 09:18 PM.

  10. #10
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    88,129
    Quote Originally Posted by Coulen View Post
    No idea what changed, but everything just started working.
    ...

    Looks good now.
    Ok - great.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •