Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: AppleTV - FF/SEARCH Issues

  1. #1
    Join Date
    Mar 2019
    Location
    Canada
    Posts
    11

    Exclamation AppleTV - FF/SEARCH Issues

    Hello, I have recently installed the AppleTV client and all works very well except for FF or SEARCH. On most recordings when I try to use these features the playback starts at the begining again. If I leave it I can watch a show, but unable to skip comercials.

    I tried this on the PC application and the web client and this does not happen. It only appears to be in the AppleTV application. I understand that the AppletV does not decode so I doubt it is a render issue.

    Does anyone else have this issue and any thoughts on a resolution?

    Thank you,
    /Derek

  2. #2
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    89,166
    If you press the pause button on the apple tv remote, then move left/right, then click does that work any better?

  3. #3
    Join Date
    Mar 2019
    Location
    Canada
    Posts
    11
    Quote Originally Posted by sub View Post
    If you press the pause button on the apple tv remote, then move left/right, then click does that work any better?
    Thank you for your quick response. I have tried this while playing and while paused with the same results, always returing to the begining of the recording, however the bar sometimes moves to that spot.

    Is the file created from a direct stream from the ATSC feed or is there something that happens to it from the card to disk (encoding, etc?) If the feeds are all the same then its odd that there would be different results, unless the card is doing this. Just a thought.

    /Derek

  4. #4
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    89,166
    With he Apple TV, it's always using the direct stream.

    Maybe restart the recording service (to reset the logs), then restart the apple tv app, start playback, push pause, try skipping to software else, then zip and attach the logs and I'll take a look.

  5. #5
    Join Date
    Mar 2019
    Location
    Canada
    Posts
    11
    Quote Originally Posted by sub View Post
    With he Apple TV, it's always using the direct stream.

    Maybe restart the recording service (to reset the logs), then restart the apple tv app, start playback, push pause, try skipping to software else, then zip and attach the logs and I'll take a look.
    Attached is the log. I tried this on two seperate recordings multiple ways.

    /Derek
    Attached Files Attached Files

  6. #6
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    89,166
    You need to zip and attach all the logs. This log file wont contain any apple tv stuff. (that's all in web.log and nrecord.log)

  7. #7
    Join Date
    Mar 2019
    Location
    Canada
    Posts
    11
    Quote Originally Posted by sub View Post
    You need to zip and attach all the logs. This log file wont contain any apple tv stuff. (that's all in web.log and nrecord.log)
    Sorry, here is the complete set.
    Attached Files Attached Files

  8. #8
    Join Date
    Mar 2019
    Location
    Canada
    Posts
    11
    Quote Originally Posted by dsaunders View Post
    Sorry, here is the complete set.
    I was able to avoid the issue by moving the recording directory to a local drive instead of my NAS. Not ideal as the NAS has the space I need for this solution.

    Do you think this is a latency issue? Is there a setting somewhere that would assist with this? I doubt it is permission based as the application volume is setup as read/write for all and the server does record to it.

    Thanks,
    /Derek

  9. #9
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    89,166
    Sorry - I've been super overworked recently, and hadn't got back to you. You post was still sitting in an open tab in my browser, for me to come back to, but it hadn't happened yet.

    You could try setting this registry setting to see if it helps:
    HKEY_LOCAL_MACHINE\Software\Wos6432Node\NPVR\ SeparateTimingInfo=1(DWORD)

    There is an extra timing file called "timing.info" created for each recording. On an NTFS filesystem, it's embedded within the .ts recording. On a NAS it might not be created. In theory it should have worked fine without this file, but it's possible this is a factor.

    Do a new test recording with this registry setting set, and you should notice alongside your "recording.ts", a new "recording.ts.timing.info" file. See if this file skips any better.

  10. #10
    Join Date
    Mar 2019
    Location
    Canada
    Posts
    11
    Quote Originally Posted by sub View Post
    Sorry - I've been super overworked recently, and hadn't got back to you. You post was still sitting in an open tab in my browser, for me to come back to, but it hadn't happened yet.

    You could try setting this registry setting to see if it helps:
    HKEY_LOCAL_MACHINE\Software\Wos6432Node\NPVR\ SeparateTimingInfo=1(DWORD)

    There is an extra timing file called "timing.info" created for each recording. On an NTFS filesystem, it's embedded within the .ts recording. On a NAS it might not be created. In theory it should have worked fine without this file, but it's possible this is a factor.

    Do a new test recording with this registry setting set, and you should notice alongside your "recording.ts", a new "recording.ts.timing.info" file. See if this file skips any better.
    No need for appologies. I really appreciate the ability to have this dialog.

    I tried your registry edit above and it seems to have solved the problem! Thank you. I will watch it for the next few days but it clearly had an impact right away.

    Not sure why this would happen. The network share is an NTFS volume, but it does appear to work.

    Thanks again,
    /Derek

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •