Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 38

Thread: Kodi addon keeps freezing, on playback then dumping back in the recordings list

  1. #21
    Join Date
    Jul 2017
    Location
    UK
    Posts
    105
    I stopped and restarted the recording service at 6:03 per your suggestion in another thread here. The Event Viewer confirms that.

    I think I am getting lost in your terminology yet again. You asked above "I did notice that the web server reset earlier while streaming a recording did you restart it manually or reboot the server?" and I said that I had rebooted the server since at least yesterday. If recording service = web server then, yes, I did a manual stop/start at 6:03 ... but I'm pretty sure there was no recording being played or in a paused state at that time. I always ensure Kodi is out of action when doing stuff on the NPVR backend, and that was the last thing I did on the backend today other than package the two NPVR logs posted above.

  2. #22
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,459
    Ok, semantics for sure. When I speak of server I generally mean the recording service and not the PC. I also asked for you to restart both the server and Kodi to have a clean started, but you didn't restart Kodi so I was confused. You were deleting files in Kodi 2 seconds after the server was back up without a new login.

    Also you don't do the EPG update overnight my point is really about do the clean restart after the EPG update .

    Martin

  3. #23
    Join Date
    Jul 2017
    Location
    UK
    Posts
    105
    OK, sorry. It has just crashed again - Kodi and NPVR logs at https://drive.google.com/drive/u/0/f...VXHGjlBxuecOvF - but I'm now going to go the whole hog by doing a manual EPG update with the client PC turned off, then reboot the backend PC, reboot the client PC and clear the Kodi EPG so that it reloads. Hope this is what you want.

    Can you confirm that I am now using the advancedsettings.xml, please?

  4. #24
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,459
    Can you make that a public link?

    Martin

  5. #25
    Join Date
    Jul 2017
    Location
    UK
    Posts
    105

  6. #26
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,459
    Yes it is better, I probably need to do a deeper check tomorrow but I do see you had a recording paused for many hours which is probably not a great idea.

    2019-04-05 20:34:49.975 T:784 DEBUG: CAnnouncementManager - Announcement: OnPause from xbmc
    ...
    2019-04-06 03:19:30.743 T:4272 DEBUG: CAESinkDirectSound::CheckPlayStatus: Resuming Playback
    ...
    2019-04-06 03:21:12.018 T:4376 DEBUG: AddOnLog: NextPVR PVR Client: DoRequest return /service?method=recording.watched.set&recording_id= 11625&position=1423 200 66 1

    After that because of the delay there is a major update to get all the guide info etc and you probably shouldn't have started to play the video so soon after that. Then I see you try and upload the logs but the log was too big.

    What I don't see is a crash.


    Martin

  7. #27
    Join Date
    Jul 2017
    Location
    UK
    Posts
    105
    Yes, that long pause was my mistake and I will try not to repeat it - I got distracted when I paused.

    And it is semantics again, I'm afraid: on this occasion, I definitely should not have said "crashed". It did the freezing thing and then dropped out of playback to the recordings listing. There was no buffering circle but there was a pause of anything up to maybe 10 seconds before it flipped from the non-moving playback to the listing.

    Yes, the log was too big for paste.kodi.tv, hence uploading it with the NPVR logs to GDrive.

    Thanks for your perseverance with this.

  8. #28
    Join Date
    Jul 2017
    Location
    UK
    Posts
    105
    It has just done the same thing again, despite all of the restarting, updating EPG etc. Kodi log at https://paste.kodi.tv/axuperoyoh and the NPVR log is that timed at 0521 at https://drive.google.com/open?id=1sy...VXHGjlBxuecOvF

    I can see a lot of timer updates around 0519 but if I am reading the log correctly, those are after it is dropped from playback into the recordings list.
    Last edited by sitush; 2019-04-06 at 04:33 AM.

  9. #29
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,459
    Those are more like your original freeze issue where the server did not respond to either the playback or watch.set command.

    To answer your other question no that advancedsettings.xml is not working perhaps use the setting I suggested with the ip and not "PVR"

    Martin

  10. #30
    Join Date
    Jul 2017
    Location
    UK
    Posts
    105
    Happened again at about 2030 7 April - logs at https://drive.google.com/open?id=1sy...VXHGjlBxuecOvF

    I adjusted the advancedsettings.xml to use the backend IP address but would still be grateful for confirmation that it is working. The Windows share is definitely accessible from other PCs on the network, both Windows and Ubuntu.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •