Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 32

Thread: Channel order wrong - any ideas?

  1. #11
    Join Date
    Oct 2017
    Location
    United Kingdom
    Posts
    46
    Quote Originally Posted by Lao Pan View Post
    Have you adjusted the "Unattended Sleep Timeout"? - Windows 10 goes back to sleep after 2mins if it wakes up on it's own - I had to set mine to 18 minutes.
    You can use the attached reg file to add the setting to advanced power options/sleep.

    You could set them Manually in the Settings / Channels / Detail Menu - I do when they don't behave.
    I have increased the the time spent looking for the EPG on each frequency to 90 seconds and this fixed the "no show details" problem.

    In the Settings/Channels/Details BBC ONE HD has channel number 101. On the NextPVR screen display the channel is shown as 101. But it's the channel order that is incorrect. The number sequence for channels before/after 101 is 45,5,102,101,103,104,105,204,86,45.
    Windows 10 Pro 10.0.1.17763 Build 17763, 64bit 2.50GHz 8GB RAM
    Hauppauge WinTV-dualHD TV T2
    NextPVR 4.2.4 (190307)

  2. #12
    Join Date
    Jun 2007
    Location
    Scotland
    Posts
    2,751
    Other users have posted about this problem...

    Maybe try the advice given in this post...

    Alex

  3. #13
    Join Date
    Oct 2008
    Location
    Severn Estuary (Mendip) UK
    Posts
    1,175
    Quote Originally Posted by Bunkermentality View Post
    In the Settings/Channels/Details BBC ONE HD has channel number 101. On the NextPVR screen display the channel is shown as 101. But it's the channel order that is incorrect. The number sequence for channels before/after 101 is 45,5,102,101,103,104,105,204,86,45.
    In the Menu at the top of the epg screen try setting Group to "All Channels"

    If I set mine to DVB-T or the other options the channels are no longer in numerical order (possibly Mux Order or maybe by Unique OID)
    It's not an overly complicated system - it's more - overly simple operatives

  4. #14
    Join Date
    Oct 2017
    Location
    United Kingdom
    Posts
    46
    Now that is an interesting suggestion. "All Channels" does cause the order to be correct. It isn't a workable solution because I also have 500+ IPTV channels and the DVB-T channels get lost so I do need to select individual groups.

    But if I delete the IPTV device then the DVB-T channels appear in the correct order when "All Channels" is selected but go back to the incorrect order if the "DVB-T" group is selected. Does this give any clues?

    Now if I delete all DVB-T channels and rescan from start group "All Channels" shows the correct order whilst group "DVB-T" shows the incorrect order. But then I re-create the IPTV
    device but skip the EPG build as this is very slow, and then view the group "DVB-T" it displays in the correct order. Bingo!

    Finally I recreate the EPG for both DVB-T and IPTV channels and the DVB-T channels are displayed in the correct order when using group "DVB-T".

    So the channels are once again in the correct order. I'm not sure which of the steps above triggered the fix but it seems related to the IPTV channel groups.
    Windows 10 Pro 10.0.1.17763 Build 17763, 64bit 2.50GHz 8GB RAM
    Hauppauge WinTV-dualHD TV T2
    NextPVR 4.2.4 (190307)

  5. #15
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    89,988
    Quote Originally Posted by Bunkermentality View Post
    Now that is an interesting suggestion. "All Channels" does cause the order to be correct. It isn't a workable solution because I also have 500+ IPTV channels and the DVB-T channels get lost so I do need to select individual groups.

    But if I delete the IPTV device then the DVB-T channels appear in the correct order when "All Channels" is selected but go back to the incorrect order if the "DVB-T" group is selected. Does this give any clues?

    Now if I delete all DVB-T channels and rescan from start group "All Channels" shows the correct order whilst group "DVB-T" shows the incorrect order. But then I re-create the IPTV
    device but skip the EPG build as this is very slow, and then view the group "DVB-T" it displays in the correct order. Bingo!

    Finally I recreate the EPG for both DVB-T and IPTV channels and the DVB-T channels are displayed in the correct order when using group "DVB-T".

    So the channels are once again in the correct order. I'm not sure which of the steps above triggered the fix but it seems related to the IPTV channel groups.
    What you're probably talking about...

    When you import IPTV channels, the IPTV provider usually don't specify a channel number, so the application will pick the next available channel number in the database and start from there. ie, probably channel number 1 to channel number x. If you later scan DVB-T channels, it'll use the channel numbers from the broadcast, which will likely be channel numbers that overlap with the channel numbers that already - but it goes ahead and does it anyway, resulting in a mixture of IPTV and DVB channels in the range channel 1 to channel x.

    If you scan in the opposite order, then DVB-T channels get their normal numbers, but when you then import the IPTV channels, it'll got for the next available number, which might be 200 or whatever, so you end up with a list of the DVB-T channels first, and the IPTV channels that follow them.

  6. #16
    Join Date
    Oct 2017
    Location
    United Kingdom
    Posts
    46
    So in short, if DVB-T channels need to be rescanned then always delete the original DVB-T channels and remove the IPTV channels, then rescan DVB-T channels and recreate IPTV channels from m3u file.

    Thanks all for your help. Appreciated. Paul
    Windows 10 Pro 10.0.1.17763 Build 17763, 64bit 2.50GHz 8GB RAM
    Hauppauge WinTV-dualHD TV T2
    NextPVR 4.2.4 (190307)

  7. #17
    Join Date
    May 2006
    Location
    Canada
    Posts
    28,193
    Groups are never sorted they are shown in the order they are created. I thought this was so they could be shown in a preference order.

    Martin

  8. #18
    Join Date
    Oct 2017
    Location
    United Kingdom
    Posts
    46
    A few days ago I had to rescan my DVB-T channels as some stations were reallocated in the UK. As a result my channel ordering problems have returned. In an attempt to overcome this I have

    1. Deleted my IPTV device.
    2. Deleted my DVB-T and DVB-C devices.
    3. Stopped and restarted all NextPVR services.
    4. Done device setup on DVB-T devices. EPG refresh not done.
    5. Channel list is displayed in random order.
    6. Update EPG. No difference.


    Might there be some residue of the previous device settings that might be causing this problem?

    Any advice would be appreciated.

    Thanks Paul

    Name:  NextPVR channels.jpg
Views: 46
Size:  143.8 KB
    Windows 10 Pro 10.0.1.17763 Build 17763, 64bit 2.50GHz 8GB RAM
    Hauppauge WinTV-dualHD TV T2
    NextPVR 4.2.4 (190307)

  9. #19
    Join Date
    Nov 2003
    Location
    NextPVR HQ, Wellington, New Zealand
    Posts
    89,988
    I'd try going to the Settings->Channels screen, delete all the channels, then head to Settings->Devices and scan the DVB-T device.

  10. #20
    Join Date
    Oct 2017
    Location
    United Kingdom
    Posts
    46
    Thanks for the advice. I just deleted all channels, then did a rescan. Channel order still wrong.

    In the earlier posts on this thread we concluded that it was the IPTV channels that were causing the problem. The final summary was

    "So in short, if DVB-T channels need to be rescanned then always delete the original DVB-T channels and remove the IPTV channels, then rescan DVB-T channels and recreate IPTV channels from m3u file."

    This time the IPTV is removed and yet every variation on rescan that I can think of fails to produce an ordered final channel list.
    Windows 10 Pro 10.0.1.17763 Build 17763, 64bit 2.50GHz 8GB RAM
    Hauppauge WinTV-dualHD TV T2
    NextPVR 4.2.4 (190307)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •